Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I upgraded to Firefox 25 today and now my Bookmarks menu seems to have additional spacing, requiring a lot more scrolling. How do I get it back to how it was?

  • 53 replies
  • 156 have this problem
  • 16287 views
  • Last reply by westcoasting

more options

Upgraded from v 24 to 25 and on program restart noticed my bookmarks menu is really long now due to extra added blank space between each bookmark. Is there any way to fix it as scrolling up and down all the time is a pain in the neck. The spacing is a waste of space now.

Chosen solution

Hi prostheus, try this:

@namespace url(http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul);
.sidebar-placesTree treechildren::-moz-tree-row {
  height: 1.3em !important;
  border-width: 1px !important;
}

I tested using the "Portable" build of Firefox 25, but the internal style rules should work the same.

For users who prefer to use the Stylish extension rather than editing userChrome.css, you can create a new blank rule and paste the above (see screen shots for results, this is on a "Basic" Windows 7 theme). Make sure to close and open the sidebar to force a redraw after using Preview or Save in Stylish.

Follow-ups:

Read this answer in context 👍 40

All Replies (13)

more options

Yes colaclone, I found the same issue with white lines after the ver25 update, but am not worried as I find them barely visible and not detrimental.

more options

Thank you cor-el, but no change

Modified by jill_33

more options

Is there any way to fix this for the bookmark menu as well? There's still a lot more space there than there was before I updated.

more options

Hi ScorpSt, do you mean the drop-down menu? I'm not seeing much difference on Windows 7 between the spacing of bookmark menu items (23 pixels high for folders, 22 pixels high for bookmarks) and history menu items (22 pixels high), for example.

What OS are you running?

If you are on Windows 8.1, you may have noticed something strange happen with the triangles on the right side for folders and that might affect the spacing. See:

more options

I like a compact drop-down list and use code like this:

#navigator-toolbox menupopup menu, #navigator-toolbox menupopup menuitem {height:14px!important;font-size:12px!important}
#navigator-toolbox toolbarseparator {margin:0 -4px !important}
more options

I've tried this repeatedly, and no luck. I created the chromecss file, then pasted in the instructions, saved the updated chrome css file, restarted firefox and again, nothing is changing.

I know it's obvious But I have to wonder that didn't ANYONE think this was going to be an issue?

more options

Does any code in the userChrome.css file work?

Make sure to select "All files" and not "Text files" when saving the file to prevent windows from adding a hidden .txt file extension.
The file type should be Cascading Style Sheet and not TEXT file if you check that in the Properties.

more options

Hi westcoasting, the exact location and spelling and case are critical for the userChrome.css file. You may have followed the steps to the letter, and just used some strange naming in your reply, but I thought it was worth mentioning that.

You also could consider using the Stylish extension. I've described the detailed steps in another thread.

more options

Hi... Nope. I don't understand why this isn't working, and I've also followed this as well http://kb.mozillazine.org/Editing_configuration/Troubleshooting

Any other ideas?

Really, really frustrating.

more options

Hi... Nope. I don't understand why this isn't working, and I've also followed this as well http://kb.mozillazine.org/Editing_configuration/Troubleshooting

Any other ideas?

Really, really frustrating.

more options

I'm attaching a screenshot of the code in question, also the file name to ensure that I'm not a total tosser. Thanks again for your help.

more options

Hi westcoasting, the screen shot of the editor shows a double .css file extension. I recommend turning off the Windows feature to hide recognized file extensions, since that often causes problems like this where you want to use an extension that isn't the default one for the program creating the file.

How to show or hide file name extensions in Windows Explorer

more options

Holy cow. It worked! Turning off the hide file extentions did it! Thank you very much for your help! Still wish is there wasn't so many hoops to jump through... but thanks all the same, FF is usable again! I really appreciate you all getting back to me about this.

  1. 1
  2. 2
  3. 3