X
Tap here to go to the mobile version of the site.

Support Forum

Why does my Firefox not have a Java plug-in?

Posted

My question is similar to "Java Plug-in for JRE7u21?" but all the suggestions there that worked are for Windows, and I'm on a Mac, and I don't want to hijack that thread. For the record, that thread is /questions/958847. aw

I have Mac OS X 10.8.5 Mountain Lion, Firefox 24.0, which says it's up to date, and Java 7 update 45, also up to date. I only want answers for Mac OS X, not Windows, not Linux.

The online Java test works OK in Safari but not in Firefox. Firefox thinks Java is not installed. There's no "Java Applet Plug-in" in the plug-ins list.

Since Safari is OK, I assume there's a bug in Firefox. Can we narrow it down by identifying which combinations of versions (of Mac OS X, Firefox and Java) have the Java plug-in and which don't?

My question is similar to "Java Plug-in for JRE7u21?" but all the suggestions there that worked are for Windows, and I'm on a Mac, and I don't want to hijack that thread. <sub> For the record, that thread is [/questions/958847]. aw </sub> I have Mac OS X 10.8.5 Mountain Lion, Firefox 24.0, which says it's up to date, and Java 7 update 45, also up to date. I only want answers for Mac OS X, not Windows, not Linux. The online Java test works OK in Safari but not in Firefox. Firefox thinks Java is not installed. There's no "Java Applet Plug-in" in the plug-ins list. Since Safari is OK, I assume there's a bug in Firefox. Can we narrow it down by identifying which combinations of versions (of Mac OS X, Firefox and Java) have the Java plug-in and which don't?

Modified by AliceWyman

Chosen solution

P.S. (Long shot) You aren't running Firefox in 32-bit mode, by any chance? That was mentioned in the "Java Plug-in for JRE7u21" thread, /questions/958847?page=2#answer-446868 : Most likely issue is with with the Firefox 32/64 bit selection. Open Firefox info panel (Cmd-I) and deselect "Open in 32-bit mode" tick box. That worked for me!

To confirm that you aren't running Firefox in 32-bit mode, control-click (right-click) the Firefox.app in your Applications folder and select "Get Info" from the list of options. In the "Firefox Info" window, make sure the box in front of "Open in 32-bit mode" is not selected

Read this answer in context 6

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.9 r900
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • DivX VOD Helper Plug-in
  • Adobe Shockwave for Director Netscape plug-in, version 12.0.4
  • DivX Web Player version 3.0.0.155
  • The Google Earth Plugin allows you to view 3D imagery and terrain in your web browser.
  • LastPass Plugin
  • 5.1.20513.0
  • Glims Plug-in for Safari
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • Garmin Communicator Plug-in Version 4.0.2.6
  • Yahoo! Installer Plug-in provides application installation support

Application

  • Firefox 24.0
  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:24.0) Gecko/20100101 Firefox/24.0
  • Support URL: https://support.mozilla.org/1/firefox/24.0/Darwin/en-US/

Extensions

  • fireform 0.7.4 (fireform@mozilla.org)
  • Follow That Page 0.2.1 ({7282A944-FE1F-11DA-8171-3B6D5C103D30})
  • LastPass 2.5.0 (support@lastpass.com)
  • Print Edit 10.2 (printedit@DW-dev)
  • Save-To-Read 0.4.2 (save2read@konstantin.plotnikov)
  • Saved Password Editor 2.7.1 (savedpasswordeditor@daniel.dawson)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Cooliris 1.12.3.58254 (piclens@cooliris.com) (Inactive)
  • DivX Plus Web Player HTML5 <video> 2.1.2.182 ({23fcfd51-4958-4f00-80a3-ae97e717ed8b}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription:
  • adapterDeviceID: 0x 8a4
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: 0x10de
  • driverDate:
  • driverVersion:
  • info: {u'AzureContentBackend': u'none', u'AzureCanvasBackend': u'quartz', u'AzureFallbackCanvasBackend': u'none'}
  • numAcceleratedWindows: 2
  • numTotalWindows: 2
  • webglRenderer: NVIDIA Corporation -- NVIDIA GeForce 320M OpenGL Engine
  • windowLayerManagerRemote: False
  • windowLayerManagerType: OpenGL

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.fixup.alternate.enabled: False
  • browser.history_expire_days.mirror: 180
  • browser.places.importBookmarksHTML: False
  • browser.places.smartBookmarksVersion: 4
  • browser.search.useDBForOrder: True
  • browser.sessionstore.restore_on_demand: False
  • browser.startup.homepage_override.buildID: 20130910160258
  • browser.startup.homepage_override.mstone: 24.0
  • browser.tabs.onTop: False
  • browser.tabs.warnOnClose: False
  • dom.ipc.plugins.enabled.i386.coolirisembedded.bundle: False
  • dom.ipc.plugins.enabled.x86_64.coolirisembedded.bundle: False
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 24.0
  • font.internaluseonly.changed: True
  • general.autoScroll: False
  • gfx.blacklist.webgl.msaa: 4
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1382632702
  • places.history.expiration.transient_current_max_pages: 104858
  • places.history.expiration.transient_optimal_database_size: 167772160
  • places.last_vacuum: 1302925774
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.expose_full_path: True
  • plugin.importedState: True
  • plugin.state.adobepdfviewernpapi: 0
  • plugin.state.directorshockwave: 2
  • plugin.state.divx web player: 2
  • plugin.state.flash: 2
  • plugin.state.flip4mac wmv plugin: 2
  • plugin.state.garmingpscontrol: 2
  • plugin.state.glimsadditions: 2
  • plugin.state.google earth web plug-in: 2
  • plugin.state.nplastpass: 2
  • plugin.state.ovshelper: 2
  • plugin.state.quicktime plugin: 2
  • plugin.state.silverlight: 2
  • plugin.state.yahoo! installer: 2
  • privacy.cpd.cookies: False
  • privacy.cpd.downloads: False
  • privacy.cpd.formdata: False
  • privacy.cpd.history: False
  • privacy.cpd.offlineApps: True
  • privacy.cpd.sessions: False
  • privacy.donottrackheader.enabled: True
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.timeSpan: 0
  • security.warn_viewing_mixed: False
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1381989041

Misc

  • User JS: No
  • Accessibility: No
Wesley Branton 184 solutions 2297 answers

Does this issue still occur right now?
The Java was disabled on Firefox for security reasons a couple of days ago.


If you are questioning about the Java Deployment Toolkit, please be advised that this plugin has been disabled for security vulnerabilities.

Sorry for any inconvenience.

Does this issue still occur right now?<br> The Java was disabled on Firefox for security reasons a couple of days ago. ------------------- If you are questioning about the Java Deployment Toolkit, please be advised that this plugin has been disabled for security vulnerabilities. Sorry for any inconvenience.

Helpful Reply

Security is a bad answer. Safari allows Java to run if the user allows it. Why can't Firefox do the same? If Firefox has security vulnerabilities that Safari doesn't have, how long will it take to fix them?

What's all this about the Java Deployment Toolkit? I'm talking about the JRE, the Java Runtime Environment. I'm not a developer, I'm not an administrator, I'm a user, and I want to use Firefox. Silly me.

Sorry for the irritation. I'm expletive deleted tired of people telling me what I can and can't do for my own safety.

Security is a bad answer. Safari allows Java to run if the user allows it. Why can't Firefox do the same? If Firefox has security vulnerabilities that Safari doesn't have, how long will it take to fix them? What's all this about the Java Deployment Toolkit? I'm talking about the JRE, the Java Runtime Environment. I'm not a developer, I'm not an administrator, I'm a user, and I want to use Firefox. Silly me. Sorry for the irritation. I'm expletive deleted tired of people telling me what I can and can't do for my own safety.
Wesley Branton 184 solutions 2297 answers

These are not Firefox security vulnerabilities. They are vulnerabilities with the Java program which is in no way related to Mozilla.

The Java Deployment Toolkit will be disabled until Oracle creates an update to repair the security issue(s).

These are not Firefox security vulnerabilities. They are vulnerabilities with the Java program which is in no way related to Mozilla. The Java Deployment Toolkit will be disabled until Oracle creates an update to repair the security issue(s).
Wesley Branton 184 solutions 2297 answers

We are sorry that you are displeased with Firefox.


Potentially unsafe versions of the Java plugin are "Click to Play" blocked, meaning that you have to click to activate Java for each site. See the How to allow Java on trusted sites article for more information.

Note: To make sure that your Java plugin is working, you can visit the test pages listed in the article, Use the Java plugin to view interactive content on websites. If an "Activate Java" message box appears, click inside the box to activate the Java plugin.

When you see the "Activate Java" message box, simply click it to load the Java content normally.

Fx24-JavaActivate

If there is no visible area to activate Java content in the page, click the red plugin icon in the address bar. In the message panel that opens, choose "Allow Now" to enable Java content temporarily.

Fx24-JavaAllowNow

The next time you visit the site or any other that uses Java you will see this message again.

If you want to always activate Java for a particular site, you can use the "Allow and Remember" option shown above.

After activating Java, you may also see a "Security Warning" dialog box, asking you to confirm that you want to run Java. This warning comes from Java itself, not from Firefox.

Does this solve your problem? Please report back soon.

We are sorry that you are displeased with Firefox. ------------------- Potentially unsafe versions of the Java plugin are "Click to Play" blocked, meaning that you have to click to activate Java for each site. See the [[How to enable Java if it's been blocked]] article for more information. '''Note:''' To make sure that your Java plugin is working, you can visit the test pages listed in the article, [[Use the Java plugin to view interactive content on websites]]. If an "Activate Java" message box appears, click inside the box to activate the Java plugin. When you see the "Activate Java" message box, simply click it to load the Java content normally. <br><br> [[Image:Fx24-JavaActivate]] If there is no visible area to activate Java content in the page, click the red plugin icon in the address bar. In the message panel that opens, choose "Allow Now" to enable Java content temporarily. <br><br> [[Image:Fx24-JavaAllowNow]] <br><br> The next time you visit the site or any other that uses Java you will see this message again. If you want to always activate Java for a particular site, you can use the "Allow and Remember" option shown above. After activating Java, you may also see a "Security Warning" dialog box, asking you to confirm that you want to run Java. This warning comes from Java itself, not from Firefox. Does this solve your problem? Please report back soon.
AliceWyman
  • Moderator
195 solutions 2266 answers

You said,

I have Mac OS X 10.8.5 Mountain Lion, Firefox 24.0, which says it's up to date, and Java 7 update 45, also up to date.

The online Java test works OK in Safari but not in Firefox. Firefox thinks Java is not installed. There's no "Java Applet Plug-in" in the plug-ins list.

I don't see the Java plugin in your "More System Details" Installed Plugins list. Open the Firefox Tools -> Add-ons - Plugins list and look for the Java Applet Plugin. If it's set to "Never Activate", use the drop-down menu and select either "Always Activate" or "Ask to Activate", whichever is available.

I don't know what online Java test you used but, to make sure that your Java plugin is working, you can visit the test pages listed in the article, Use the Java plugin to view interactive content on websites.

If "Ask to Activate" is your only option then you will have to click to activate Java for each site for the time being, as explained in the How to allow Java on trusted sites article, even though you have the latest Java 7 U45 installed. See bug 914690 if you're interested in the background.

You said, ''I have Mac OS X 10.8.5 Mountain Lion, Firefox 24.0, which says it's up to date, and Java 7 update 45, also up to date.'' ''The online Java test works OK in Safari but not in Firefox. Firefox thinks Java is not installed. There's no "Java Applet Plug-in" in the plug-ins list.'' I don't see the Java plugin in your "More System Details" Installed Plugins list. Open the Firefox Tools -> Add-ons - Plugins list and look for the '''Java Applet Plugin'''. If it's set to "Never Activate", use the drop-down menu and select either "Always Activate" or "Ask to Activate", whichever is available. I don't know what online Java test you used but, to make sure that your Java plugin is working, you can visit the test pages listed in the article, [[Use the Java plugin to view interactive content on websites]]. If "Ask to Activate" is your only option then you will have to click to activate Java for each site for the time being, as explained in the [[How to enable Java if it's been blocked]] article, even though you have the latest Java 7 U45 installed. See [https://bugzilla.mozilla.org/show_bug.cgi?id=914690#c80 bug 914690] if you're interested in the background.

Modified by AliceWyman

Question owner

OK, ComputerWhiz and AliceWyman. You didn't understand the question. You think "Java Applet Plugin" is somewhere in my Plugins list. It isn't. That's what I'm saying. It isn't there at all. I can't activate something that isn't there.

OK, ComputerWhiz and AliceWyman. You didn't understand the question. You think "Java Applet Plugin" is somewhere in my Plugins list. It isn't. That's what I'm saying. It isn't there at all. I can't activate something that isn't there.
Wesley Branton 184 solutions 2297 answers

Ok.
We are sorry for any inconvenience.

Please download Java on your computer from here.

Ok.<br> We are sorry for any inconvenience. Please download Java on your computer from [http://www.java.com/en/download/index.jsp here].

Question owner

Again, ComputerWhiz, you didn't read the question. I already downloaded Java from the page you're pointing me to. The Java Control Panel, "Update" tab, says "Your system has the recommended version of Java. / Java 7 Update 45."

Java is installed. Why doesn't my Firefox show the Java plug-in?

Again, ComputerWhiz, you didn't read the question. I already downloaded Java from the page you're pointing me to. The Java Control Panel, "Update" tab, says "Your system has the recommended version of Java. / Java 7 Update 45." Java is installed. Why doesn't my Firefox show the Java plug-in?
Wesley Branton 184 solutions 2297 answers

Sorry again.


Here is a Java documentation of your issue.

You'll need to uninstall Java and reinstall it again.

Sorry for any inconvenience.

Sorry again. --------------------- [http://www.java.com/en/download/help/firefox_java.xml Here] is a Java documentation of your issue. You'll need to uninstall Java and reinstall it again. Sorry for any inconvenience.

Question owner

Let's get back to the original question. Do you experts have the Java plug-in in your plugins list? If so, do you have the same version of Mac OS X, Firefox, and JRE that I have? How does your system configuration differ from mine? Why do you have the plugin and I don't?

Let's get back to the original question. Do you experts have the Java plug-in in your plugins list? If so, do you have the same version of Mac OS X, Firefox, and JRE that I have? How does your system configuration differ from mine? Why do you have the plugin and I don't?
Wesley Branton 184 solutions 2297 answers

Please see my above post.


I am running the same version of Java and Firefox, but I am using Windows XP. The plugin displayed in my plugin list.

Please see my above post. ------------------- I am running the same version of Java and Firefox, but I am using Windows XP. The plugin displayed in my plugin list.

Question owner

ComputerWhiz: you wrote "Here is a Java documentation of your issue."

Expletive deleted! I told you right in the beginning I didn't want any Windows solutions! "Here" says the solution is to "Remove all versions of Java and JavaFX through the Windows Uninstall Control Panel." That's not a Mac OS X solution!

ComputerWhiz: you wrote "Here is a Java documentation of your issue." Expletive deleted! I told you right in the beginning I didn't want any Windows solutions! "Here" says the solution is to "Remove all versions of Java and JavaFX through the Windows Uninstall Control Panel." That's not a Mac OS X solution!
Wesley Branton 184 solutions 2297 answers

The people who answer questions here, for the most part, are other Firefox users volunteering their time (like me), not Mozilla employees or Firefox developers.
Please treat all of our volunteers with respect.

The people who answer questions here, for the most part, are other Firefox users volunteering their time (like me), not Mozilla employees or Firefox developers.<br> Please treat all of our volunteers with respect.
Wesley Branton 184 solutions 2297 answers

You can remove Java from Mac, that same as Windows.
Please do so and then reinstall it.

Thank you in advance.

You can remove Java from Mac, that same as Windows.<br> Please do so and then reinstall it. Thank you in advance.

Question owner

Please treat me with respect. I'm not stupid. I asked a question and I expect either an answer to the question, or no answer at all. Thank you for your efforts and let's hold this till tomorrow while we read and reread the question.

Please treat me with respect. I'm not stupid. I asked a question and I expect either an answer to the question, or no answer at all. Thank you for your efforts and let's hold this till tomorrow while we read and reread the question.

Question owner

Note to ComputerWhiz: I did that already. I uninstalled the JRE by the recommended procedure, deleting (actually renaming) the file JavaAppletPlugin.plugin. After I renamed the file, the Java preferences icon did not appear in the System Preferences window. Then I reinstalled the JRE from the downloaded file. No help.

Note to ComputerWhiz: I did that already. I uninstalled the JRE by the recommended procedure, deleting (actually renaming) the file JavaAppletPlugin.plugin. After I renamed the file, the Java preferences icon did not appear in the System Preferences window. Then I reinstalled the JRE from the downloaded file. No help.
Wesley Branton 184 solutions 2297 answers

Please consider contacting the Java support team about this issue.

Please consider contacting the Java support team about this issue.

Question owner

What should I tell the Java support team? That I don't know why Firefox doesn't recognize their plugin?

It would help if I could get the information I asked for: who has the plugin, who hasn't, and what versions they have.

Am I the only user in the world who has fully updated Firefox, fully updated Mountain Lion, fully updated JRE, and doesn't have the Java plugin in Firefox?

What should I tell the Java support team? That I don't know why Firefox doesn't recognize their plugin? It would help if I could get the information I asked for: who has the plugin, who hasn't, and what versions they have. Am I the only user in the world who has fully updated Firefox, fully updated Mountain Lion, fully updated JRE, and doesn't have the Java plugin in Firefox?

Question owner

OK, I put in a user comment on the Java website. Meanwhile, Safari warned me that a future release will disable Java. Apparently our technology is falling apart of its own weight. Soon we'll be writing each other letters and sending them by post. Post office revenue will increase and the price of a postage stamp might even go down. Congress will rush to bring the Post Office back into the government so the Treasury can absorb the excess revenue.

Thanks for your efforts. I have a typewriter in the back closet just in case....

OK, I put in a user comment on the Java website. Meanwhile, Safari warned me that a future release will disable Java. Apparently our technology is falling apart of its own weight. Soon we'll be writing each other letters and sending them by post. Post office revenue will increase and the price of a postage stamp might even go down. Congress will rush to bring the Post Office back into the government so the Treasury can absorb the excess revenue. Thanks for your efforts. I have a typewriter in the back closet just in case....

Question owner

Guessing the answer to my original question: you all have the same updated versions I have, but I'm the only one who doesn't have the Java plugin.

I just restarted in safe mode, and I still don't have the plugin, so it isn't in my startup apps. My next guess is that some preference file is messed up.

How can I clear all the preferences (etc.) for Java 7 and Firefox?

Guessing the answer to my original question: you all have the same updated versions I have, but I'm the only one who doesn't have the Java plugin. I just restarted in safe mode, and I still don't have the plugin, so it isn't in my startup apps. My next guess is that some preference file is messed up. How can I clear all the preferences (etc.) for Java 7 and Firefox?