X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Why does my Firefox not have a Java plug-in?

Posted

My question is similar to "Java Plug-in for JRE7u21?" but all the suggestions there that worked are for Windows, and I'm on a Mac, and I don't want to hijack that thread. For the record, that thread is /questions/958847. aw

I have Mac OS X 10.8.5 Mountain Lion, Firefox 24.0, which says it's up to date, and Java 7 update 45, also up to date. I only want answers for Mac OS X, not Windows, not Linux.

The online Java test works OK in Safari but not in Firefox. Firefox thinks Java is not installed. There's no "Java Applet Plug-in" in the plug-ins list.

Since Safari is OK, I assume there's a bug in Firefox. Can we narrow it down by identifying which combinations of versions (of Mac OS X, Firefox and Java) have the Java plug-in and which don't?

Modified by AliceWyman

Chosen solution

P.S. (Long shot) You aren't running Firefox in 32-bit mode, by any chance? That was mentioned in the "Java Plug-in for JRE7u21" thread, /questions/958847?page=2#answer-446868 : Most likely issue is with with the Firefox 32/64 bit selection. Open Firefox info panel (Cmd-I) and deselect "Open in 32-bit mode" tick box. That worked for me!

To confirm that you aren't running Firefox in 32-bit mode, control-click (right-click) the Firefox.app in your Applications folder and select "Get Info" from the list of options. In the "Firefox Info" window, make sure the box in front of "Open in 32-bit mode" is not selected

Read this answer in context 6
Post a Reply

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.9 r900
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • DivX VOD Helper Plug-in
  • Adobe Shockwave for Director Netscape plug-in, version 12.0.4
  • DivX Web Player version 3.0.0.155
  • The Google Earth Plugin allows you to view 3D imagery and terrain in your web browser.
  • LastPass Plugin
  • 5.1.20513.0
  • Glims Plug-in for Safari
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • Garmin Communicator Plug-in Version 4.0.2.6
  • Yahoo! Installer Plug-in provides application installation support

Application

  • Firefox 24.0
  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:24.0) Gecko/20100101 Firefox/24.0
  • Support URL: https://support.mozilla.org/1/firefox/24.0/Darwin/en-US/

Extensions

  • fireform 0.7.4 (fireform@mozilla.org)
  • Follow That Page 0.2.1 ({7282A944-FE1F-11DA-8171-3B6D5C103D30})
  • LastPass 2.5.0 (support@lastpass.com)
  • Print Edit 10.2 (printedit@DW-dev)
  • Save-To-Read 0.4.2 (save2read@konstantin.plotnikov)
  • Saved Password Editor 2.7.1 (savedpasswordeditor@daniel.dawson)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Cooliris 1.12.3.58254 (piclens@cooliris.com) (Inactive)
  • DivX Plus Web Player HTML5 <video> 2.1.2.182 ({23fcfd51-4958-4f00-80a3-ae97e717ed8b}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription:
  • adapterDeviceID: 0x 8a4
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: 0x10de
  • driverDate:
  • driverVersion:
  • info: {u'AzureContentBackend': u'none', u'AzureCanvasBackend': u'quartz', u'AzureFallbackCanvasBackend': u'none'}
  • numAcceleratedWindows: 2
  • numTotalWindows: 2
  • webglRenderer: NVIDIA Corporation -- NVIDIA GeForce 320M OpenGL Engine
  • windowLayerManagerRemote: False
  • windowLayerManagerType: OpenGL

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.fixup.alternate.enabled: False
  • browser.history_expire_days.mirror: 180
  • browser.places.importBookmarksHTML: False
  • browser.places.smartBookmarksVersion: 4
  • browser.search.useDBForOrder: True
  • browser.sessionstore.restore_on_demand: False
  • browser.startup.homepage_override.buildID: 20130910160258
  • browser.startup.homepage_override.mstone: 24.0
  • browser.tabs.onTop: False
  • browser.tabs.warnOnClose: False
  • dom.ipc.plugins.enabled.i386.coolirisembedded.bundle: False
  • dom.ipc.plugins.enabled.x86_64.coolirisembedded.bundle: False
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 24.0
  • font.internaluseonly.changed: True
  • general.autoScroll: False
  • gfx.blacklist.webgl.msaa: 4
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1382632702
  • places.history.expiration.transient_current_max_pages: 104858
  • places.history.expiration.transient_optimal_database_size: 167772160
  • places.last_vacuum: 1302925774
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.expose_full_path: True
  • plugin.importedState: True
  • plugin.state.adobepdfviewernpapi: 0
  • plugin.state.directorshockwave: 2
  • plugin.state.divx web player: 2
  • plugin.state.flash: 2
  • plugin.state.flip4mac wmv plugin: 2
  • plugin.state.garmingpscontrol: 2
  • plugin.state.glimsadditions: 2
  • plugin.state.google earth web plug-in: 2
  • plugin.state.nplastpass: 2
  • plugin.state.ovshelper: 2
  • plugin.state.quicktime plugin: 2
  • plugin.state.silverlight: 2
  • plugin.state.yahoo! installer: 2
  • privacy.cpd.cookies: False
  • privacy.cpd.downloads: False
  • privacy.cpd.formdata: False
  • privacy.cpd.history: False
  • privacy.cpd.offlineApps: True
  • privacy.cpd.sessions: False
  • privacy.donottrackheader.enabled: True
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.timeSpan: 0
  • security.warn_viewing_mixed: False
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1381989041

Misc

  • User JS: No
  • Accessibility: No
cor-el
  • Top 10 Contributor
  • Moderator
10753 solutions 96760 answers

If the Java plugin doesn't show in Tools > Add-ons > Plugins then Firefox doesn't find this plugin.
If it does show, but is disabled then you can enable the Java plugin.
Note that the security block of the Java plugin has been lifted, so it isn't blocked anymore once the blocklist file has been updated.

You can open the Browser Console (Firefox/Tools > Web Developer;Command+Shift+J) and paste this code on the command line at the bottom to refresh the blocklist.xml file.

Components.classes['@mozilla.org/extensions/blocklist;1'].getService(Components.interfaces.nsITimerCallback).notify(null);

You can check the Security tab in the Java console to check if Java is enabled.
You can also check the plugin directory for possible plugin conflicts.

  • /Library/Internet Plug-Ins/

See also:

Was this helpful to you? 2
Reply
AliceWyman
  • Top 25 Contributor
  • Moderator
191 solutions 1967 answers

On Mac OS systems with Java 7, the Java Control Panel has a Security tab with a checkbox that lets you enable or disable Java in your Web browser.

See http://www.java.com/en/download/help/jcp_security.xml which includes a screenshot and these instructions to access it:


Mac OS X 10.7.3 and above

   Click on Apple icon on upper left of screen.
   Go to System Preferences
   Click on the Java icon to access the Java Control Panel.

In the Java Control Panel, go to the Security tab. Is the box "Enable Java content in the browser" unchecked by any chance?

I don't know why this would only affect Firefox, if unchecked, and not Safari. Which Java test page did you use for Safari? Did you try the ones listed here?
https://support.mozilla.org/kb/use-java-plugin-to-view-interactive-content#w_testing-java

Was this helpful to you?
Reply

Question owner

Thanks for the suggestions, cor-el. Unfortunately, nothing helped.

The Java plugin doesn't show in Tools > Add-ons > Plugins. Firefox doesn't find it, so I can't enable it.

I entered the command to refresh the blocklist, but that didn't help because there's no plugin to unblock.

"Enable Java content in the browser" is checked in the security tab of the Java control panel. (That also answers you, AliceWyman. Every one of the testers you asked if I tried says Java is either blocked or not installed.)

I looked at the mozillazine article. I deleted pluginreg.dat and restarted Firefox, no help. POSSIBLE CLUE: the Java plugin is listed in the "[INVALID]" section of that file. Why would the plugin be considered invalid?

I looked into the plugin directory but I wouldn't know what might conflict. Do you want a list of the contents (from ls -l)? I don't think that could be the problem if the Java plugin itself is listed as invalid. I could try downloading Java 7 again in case there's an error in the install file, but that seems unlikely, since Java installation proceeded without error.

Any other ideas?

Was this helpful to you? 1
Reply

Question owner

Problem resolved (though not solved).

I must have downloaded a bad install file from java.com. Deleting the plugin and reinstalling from the same download didn't help.

I just deleted the download and downloaded the install file again from java.com, deleted the plugin and reinstalled. Firefox now has the plugin, and the Java test in Firefox (at the end of the installation) says I have the most recent version.

Incredibly, the installation from the first download worked in Safari and the Java Control Panel, but not in Firefox. Was it a bad download, or was there a secret update between my first and second downloads? Who knows?

Was this helpful to you?
Reply

Question owner

Still puzzled. Unix cmp says the two downloaded files are identical. Why did I get an invalid plugin from one of them, but not the other? Might never know.

Was this helpful to you?
Reply
AliceWyman
  • Top 25 Contributor
  • Moderator
191 solutions 1967 answers

<previous comment deleted. Thread is still unsolved.>

Modified by AliceWyman

Was this helpful to you?
Reply

Question owner

Oh-oh. We've been here before. Problem not resolved.

Close Firefox, download and install Java, respond to the prompt to verify, Firefox opens, verification succeeds. Close Firefox and reopen, refresh the verification window, and "We are unable to verify if Java is currently installed and enabled in your browser."

I read something like this in "Java Plug-in for JRE7u21?" The response by swmartian dated 9/30/13 12:21 AM says "1. Uninstall the JavaAppletPlugin.Plugin by dragging it to the trash. 2. Reinstall Java with FF off 3. When FF restarts the plug in will be there 4. When you close FF and restart it - it will be gone again. "

That's exactly what I just experienced and it's not a solution.

Was this helpful to you?
Reply

Question owner

When Firefox is opened by the Java plugin installer, or if it's open when the Java plugin installer runs, the file pluginreg.dat in the Firefox profile folder lists JavaAppletPlugin.plugin in the [PLUGINS] section, and Java verification succeeds.

When Firefox is then closed, JavaAppletPlugin.plugin is still listed in the [PLUGINS] section.

After Firefox is restarted, JavaAppletPlugin.plugin is listed in pluginreg.dat in the [INVALID] section, and Java verification fails.

What's telling Firefox that it should not load the Java plugin? How does the Java plugin installer tell Firefox that it should load the Java plugin?

Was this helpful to you?
Reply
AliceWyman
  • Top 25 Contributor
  • Moderator
191 solutions 1967 answers

I don't know why Firefox is seeing your JavaAppletPlugin.plugin as invalid. (Bug 616271 - Plugin-like files add overhead on every startup explains why "rejected" plugins are entered in the [INVALID] section of pluginreg.dat in case it helps.)

You did say you deleted the Java plugin before reinstalling Java .... by deleting the /Library/Internet Plug-Ins/JavaAppletPlugin.plugin file? Ref: http://www.java.com/en/download/help/mac_uninstall_java.xml

To rule out Firefox profile issues (user data and settings) you can try creating a new, additional Firefox profile for testing purposes. See Use the Profile Manager to create and remove Firefox profiles.

Long shot but maybe something in this MozillaZine forum thread will help:

http://forums.mozillazine.org/viewtopic.php?f=38&t=2576411 Mac + firefox + java applet plugins == pain

If no one here has any other ideas, you can also consider filing a new bug on bugzilla.mozilla.org or ask over in discussions.apple.com where there are other Mac users with the latest Java and Firefox, who may be able to help.

Was this helpful to you?
Reply
AliceWyman
  • Top 25 Contributor
  • Moderator
191 solutions 1967 answers

Chosen Solution

P.S. (Long shot) You aren't running Firefox in 32-bit mode, by any chance? That was mentioned in the "Java Plug-in for JRE7u21" thread, /questions/958847?page=2#answer-446868 : Most likely issue is with with the Firefox 32/64 bit selection. Open Firefox info panel (Cmd-I) and deselect "Open in 32-bit mode" tick box. That worked for me!

To confirm that you aren't running Firefox in 32-bit mode, control-click (right-click) the Firefox.app in your Applications folder and select "Get Info" from the list of options. In the "Firefox Info" window, make sure the box in front of "Open in 32-bit mode" is not selected

Was this helpful to you? 6
Reply

Question owner

Thank you, AliceWyman! I saw something about 32-bit mode in the other thread, but it was about Windows, and I couldn't figure out where it was in Mac OS X, or whether there even was that option in Mac OS X. Following your directions, I looked in "Get Info" and "Open in 32-bit mode" was selected. I unchecked it, and now Java verification succeeds.

I'll call this one solved.

Was this helpful to you?
Reply
AliceWyman
  • Top 25 Contributor
  • Moderator
191 solutions 1967 answers

You're welcome. Good to hear it's finally solved!

Was this helpful to you?
Reply
trickyt57 0 solutions 1 answers

I, like many people had the same problem: Using an iMac, latest software update (Mountain Lion, now OSX 10.9 (I forget the latest name), using the latest version of Firefox, and installed the latest version of Java, but it just does not appear in my list of Add Ons. I read through this thread, and was saddened by the fact that people really failed to understand the issue which was clearly explained. The poor guy has a MAC! Answers for the PC were useless. Anyway finally I found the solution which works as below:


Chosen solution

To confirm that you aren't running Firefox in 32-bit mode, control-click (right-click) the Firefox.app in your Applications folder and select "Get Info" from the list of options. In the "Firefox Info" window, make sure the box in front of "Open in 32-bit mode" is not selected

Was this helpful to you? 2
Reply
ziomaurits 0 solutions 1 answers

Hi, If you still have this problem (i.e., the Java plugin is installed in the Add-ons Manager, but is not working ("Missing plu-in")), try this:

1) Quit Firefox

2) find this file: pluginreg.dat

It should be in the following directory:

/Users/.../Library/Application\ Support/Firefox/Profiles/y9rgr6uk.default/pluginreg.dat

3) Move the "pluginreg.dat" file to the trash

A new pluginreg.dat file will be generated when you restart the browser.

This solution worked for me (I have Firefox 26; Java 1.7.45; Mac osx 10.9.1)

Cheers

PS of course, make sure the box in front of "Open in 32-bit mode" is not checked (if it is, remove the check-mark).

Was this helpful to you? 2
Reply
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.