Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Warning Firefox behavior. It writes to SSD too much! Feedback.

  • 5 replies
  • 25 have this problem
  • 3598 views
  • Last reply by cor-el

more options

I have tried to contact to someone from Mozilla but it is easier to contact the Martians directly. Maybe they will look at this topic.

I am using SSD drive. We all know that it has limited writes although you need to write really a lot before it dies. However looks like Firefox is working hard to speed up the time for this! Even if I set my OS to write as less as it can.

I know someone gonna smile right now and think that I should use SSD at full power because I bought it for using it instead of keeping it. BUT JUST LOOK AT THIS!

With launched browser and 2 opened tabs (of simple forum) FOR 10 MINUTES it could write to the disk UP TO 160MB OF DATA!

For 40 minutes of monitoring whole computer where Firefox was turned on for about 25 minutes there were 512MB of written data whereas more that 360MB was written by Firefox!

You can see the list of those files on the picture. http://clip2net.com/clip/m151930/1382384549-clip-127kb.png

I am curious what FF builders can say about that. Was that wrong information which 3-rd party software shows or FF really is built like that?

All Replies (5)

more options

You can use the portable Firefox version to avoid such issues.

more options

or disable the disk cache: enter about:config into the firefox address bar (confirm the info message in case it shows up) & search for the preference named browser.cache.disk.enable. double-click it and change its value to false.

more options

It is easier to disable the disk cache by using "Clear history when Firefox closes" to clear the disk cache.
See also the about:cache page.

The disk cache is in AppData\Local and that only shows 39 MB.
I don't know why the number for the main Firefox folder in AddpData\Roaming is so high.
315 MB is a lot for the main profile folder.

Do you know which files are involved?

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window.
more options

Thanks. I have already heard advices about portable application which didn't inspire me. Same about disk caching but will try it even though if I think it will not help. I moved Firefox' cache to a C:\FF_cache using browser.cache.disk.parent_directory command. At first it was on another drive but then I decided to put it back to SSD and chose clean path for folder. As you can see this on the screenshot, that folder got just 6MB of writes. Which looks fair as I almost have done nothing for those 25 minutes.

Specifically files: cookies.sqlite-wal which takes the biggest amount of writes, then go cookies.sqlite, sessionstore.js.tmp, places.sqlite-wal, places.sqlite. I looked at them and they are very little. Looks like Firefox constantly rewrites them or what?

EDIT: I guess now it decided to write somewhat less. Just 35MB for 7 minutes of doing nothing. (except 1 post edit here). Here is a screenshot. It is much less than before but still 3 times more than all other all together on the computer. Now it is 55MB for 10 minutes. Much less indeed. http://clip2net.com/clip/m151930/1382639553-clip-42kb.png

Modified by AjvarXX

more options

The sqlite-wal and sqlite-shm files are temporary files used by SQlite (wal: Write-Ahead Logging; shm: Shared Memory files).

The sessionstore.js gets written every 10 seconds and the size of this file depends on the number of opened tabs and includes the tab history.
You would have to disable Session Restore (pref: ) or increase the time to write a next backup (pref browser.sessionstore.interval).

You can also let all cookies expire when you close Firefox and possibly only enable third-party cookies for visited sites to reduce writing to cookies.sqlite.