Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Twitter is currently not working on Firefox (most updated beta version)

more options

Twitter cannot load fully at all on Firefox, and has been operating extremely slowly for hte last few days. Ohter browsers (non-Firefox) seem to be working fine with it.

All Replies (18)

more options


Many site issues can be caused by corrupt cookies or cache. In order to try to fix these problems, the first step is to clear both cookies and the cache. Note: This will temporarily log you out of all sites you're logged in to. To clear cache and cookies do the following:

  1. Go to Firefox > History > Clear recent history or (if no Firefox button is shown) go to Tools > Clear recent history.
  2. Under "Time range to clear", select "Everything".
  3. Now, click the arrow next to Details to toggle the Details list active.
  4. From the details list, check Cache and Cookies and uncheck everything else.
  5. Now click the Clear now button.

Further information can be found in the Clear your cache, history and other personal information in Firefox article.

Did this fix your problems? Please report back to us!

Thank you.

more options

I've already tried that, and it does not work. I think it's a Firefox-Twitter browser incompatibility issue (As this isn't the first time it's happened).

more options

Try Firefox Safe Mode to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • On Windows you can open Firefox 4.0+ in Safe Mode by holding the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac you can open Firefox 4.0+ in Safe Mode by holding the option key while starting Firefox.
  • On Linux you can open Firefox 4.0+ in Safe Mode by quitting Firefox and then going to your Terminal and running: firefox -safe-mode (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)
  • Or open the Help menu and click on the Restart with Add-ons Disabled... menu item while Firefox is running.


Once you get the pop-up, just select "'Start in Safe Mode" Safe Mode Fx 15 - Win

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.

Thank you.

more options

Neither of those things works Nellus. I've attached an image for how every twitter page loads. I'm also using Firefox Beta (v 25).

As a side note, I have to say Firefox has been very disappointing when it comes to social networking sites lately. Vine doesn't work without a Greasemonkey script or about:config change, and Instagram has only recently started working again.

more options
more options

The problem is probably something else, I have also tried everything and twitter has been acting up in firefox the past few days. The same problem as OP.

more options

As a note, my twitter now "works" that half the time it does, half the time it doesn't, and when it does work neither the background nor the DPs of any users show up (not to mention the extremely slow loading time).

And I've been getting the same image as rawbinator when it does not work.

more options

I have the same problems, it "works" 20% of the time for me. But when it does, it is very slow and there are almost no profile pictures either.

But mostly, it doesn't work at all and looks the same as rawbinator posted.

It looks fine in Chrome so I am using that for twitter at the moment.

more options fails to load fairly often in Aurora for me, causing this problem.

The error: Secure Connection Failed

An error occurred during a connection to The OCSP response contains out-of-date information. (Error code: sec_error_ocsp_old_response)

You can fix it by toggling off security.OCSP.enabled, but that isn't a good idea as far as security goes.

Modified by chaud

more options

Try to set the security.ssl.enable_ocsp_stapling pref to false on the about:config page.

See also:

Modified by cor-el

more options

Downgrading back to Firefox 24.0 (vs Firefox 25.0 beta, which I was on) fixes the issue too. It worked fine on Chrome for me but I didn't want to bother having two browsers up/transition all my Firefox tabs since my main browser is firefox. Quick fix, although I think I will stop using beta versions now.

more options

Same problem here. Even hootsuite (social media tools) fails to load resources from twitter. itself work almost when coming from google, when reloading (F5) its totally broken (even without CSS).

more options

I don't know what changed, but twitter is working fine today. I guess it was a beta update in firefox or something.

more options

If files are broken then best is to do a hard reload (Ctrl+F5) to bypass the cache.

Reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • Hold down the Shift key and left-click the Reload button
  • Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • Press "Command + Shift + R" (Mac)
more options

For me to get Twitter working again on FF 25.0, I had to disable Adblock Plus 2.4. This was the oldest working add-on in my list, using Firefox since 2008.

more options

I have no Add-Ons, no extensions, nothing. Fresh copy of 25.0. Twitter WILL. NOT. LOAD. I downgrade to 24.0 and I can login to Twitter normally -- as I can on any other browser. Something is wrong with FF 25.0.

more options

Sorry ekaez, all I can offer is to stay with 24.0 until bugs are worked out of 25. If I had to take a wild guess, maybe your security is set too strong and is not allowing Twitter through your firewall. Or maybe you are not downloading FireFox 25.0 directly from Don't try downloading from any other address, they potentially are clones with viruses inside. The site has 4 computer threats according to my Norton 360 antivirus.

more options

Sometimes, this could be network issue related to your DNS server. Try changing your DNS settings to point to Google Public DNS. It helped me when I encountered the same problem. Here's how: