X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

YouTube videos don't play

Posted

YouTube video do not start playing. Loading circle just stop and nothing happens. Everything's Ok in other browsers. Did resetting Firefox, deleting and reinstaling it and Flash plugin with zero result.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.9 r900
  • Foxit Reader Plug-In For Firefox and Netscape
  • Picasa plugin
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • Firefox 24.0
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20100101 Firefox/24.0
  • Support URL: https://support.mozilla.org/1/firefox/24.0/WINNT/ru/

Extensions

  • Troubleshooter 1.1a (troubleshooter@mozilla.org)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: ATI Radeon HD 4670
  • adapterDescription2:
  • adapterDeviceID: 0x9488
  • adapterDeviceID2:
  • adapterDrivers: atiu9p64 aticfx64 atiu9pag aticfx32 atiumd64 atidxx64 atiumdag atidxx32 atiumdva atiumd6a atitmm64
  • adapterDrivers2:
  • adapterRAM: 256
  • adapterRAM2:
  • adapterVendorID: 0x1002
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'tryNewerDriver', u'10.6']
  • directWriteEnabled: False
  • directWriteVersion: 6.2.9200.16571
  • driverDate: 4-19-2010
  • driverDate2:
  • driverVersion: 8.723.3.0
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'none'}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (ATI Radeon HD 4670 Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Direct3D 9

Modified Preferences

  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.startup.homepage_override.buildID: 20130910160258
  • browser.startup.homepage_override.mstone: 24.0
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 24.0
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1382089663
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • plugin.state.flash: 2
  • privacy.sanitize.migrateFx3Prefs: True
  • storage.vacuum.last.index: 0
  • storage.vacuum.last.places.sqlite: 1382089663

Misc

  • User JS: No
  • Accessibility: No
iamjayakumars
  • Top 10 Contributor
415 solutions 4924 answers

Check your plugins are uptodate!

Type about:addons in URL and Goto Plugins

  • Check all the plugins are "Always Active"

Somewhere on the page right click, go to view page info > permissions and make sure that adobe flash content is allowed to play on that domain.

cor-el
  • Top 10 Contributor
  • Moderator
10749 solutions 96724 answers

Clear the cache and cookies only from websites that cause problems.

"Clear the Cache":

  • Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Firefox/Tools > Options > Privacy > Cookies: "Show Cookies"

Helpful Reply

Thank you but I tried all above with no success. :( Problem not only in YouTube but generally with flash videos. Flash plugin is up to date. I'm scratching my head... Here is screen how it looks on YouTube.

MadAmster 0 solutions 4 answers

A workaround for this issue is to install IE Tab

Right click on the video and choose the option to "view the page in IE Tab".

Question owner

Heh, I always encourage users to use Firefox instead of other browsers telling it's the best and installing them on their systems by default. Of cause I can install Chrome or use IE (or IE tab in Firefox) but imagine how stupid I'll look then :)

MadAmster 0 solutions 4 answers

If it works then use it otherwise you'll simply be cutting off your nose to spite your face.

I expect more of these conflicts to appear in time. Flash, different makes of browser, Google, Yahoo, Microsoft, Norton and all the other suppliers of software won't be able to sync everything all the time. For some it is a policy to make money.

We users are the ones who are confronted with the problems.

Question owner

And I expect Flash technologies will be superseeded in near future by something less bugged since Adobe products like Flash or Reader are one of the most insecure apps. I confronted problems with Flash in the past and solved them by using some methods above (like clearing cache/cookies) but this time I guess it's no use trying to jump off the pants forcing Firefox work with Flash. -_-

Modified by niseimono

Ian.F 1 solutions 38 answers

Hello all.

Today I found a solution to the problem of being unable to play YouTube videos at the YouTube website - although they would play on someone else's website - that had dogged me for several weeks. I discovered the solution whilst writing up a contribution for another FF thread ( https://support.mozilla.org/en-US/questions/967209?page=2).

To cut a long story short, I found a live version of Clapton's 'Layla' on YouTube that like everything else had refused to play for several weeks and typed https:// in front of the video address in the address bar and went to that page; the video not only played on the YouTube website, but the playback was really good (I use a dongle and video often lags behind audio, but not now). Worked in Chrome too with which I had experienced the identical problem in the same period (video freezing up after 28s and the video screen turning green).

cor-el
  • Top 10 Contributor
  • Moderator
10749 solutions 96724 answers

The video area turning green in likely on overlay issue where you get the green background once the plugin is no longer overlaying this part of the screen.

This would look like an issue with your security software that can no longer interfere if you switch to a secure connection.

Question owner

Secure http doesnt work for me. I guess for my case it's complex issue involving too many aspects to comprehend.

Ian.F 1 solutions 38 answers

niseimono, hi.

Sorry to hear you are still having difficulties with flash videos. I don't have a solution for you, but may I suggest a couple of procedures to help identify the cause of the problem.

1) 'Video Playback Issues':

This discussion by Adobe at http://helpx.adobe.com/flash-player/kb/video-playback-issues.html offers you a video in HTML5 and non-HTML5 (flash) video formats - if you can view the HTML5 video, but not the other then it is suggested that your flash player might be the problem.

(The same page also suggests disabling hardware acceleration for the flash player, which you can test on this page.)

2) The Adobe Flash Uninstaller:

I gather you have already uninstalled and reinstalled the flash player, but if the above test suggests your flash player is the problem and if you have not already done so you might want to try using the Adobe flash uninstaller, which also involves deleting some files manually to ensure a clean reinstall (i.e. nothing is left behind to compromise it). Unless you are using Windows 64-bit you can ignore stage 3d.

The uninstaller and the uninstallation procedure is found at http://helpx.adobe.com/flash-player/kb/uninstall-flash-player-windows.html.

Modified by Ian.F

Lucavi 0 solutions 3 answers

Hello, everyone.

I would like a possible solution for this peculiar problem: I have begun to experience a similar problem to this and have tried numerous means like the original poster had done.

Since yesterday ( November 7th, 2013 ) , Youtube videos have stopped playing after it played just once. It is frozen (with the video's image slightly distorted) and refuses to function for a 2nd time.. Unless I refreshed the page.

This problem doesn't occur on other browsers but only on Firefox. I have tried both flash 10 and 11 and there had no changes. The cache and cookies were entirely emptied and the video showed no sign of recovery for that website only.

Ian.F 1 solutions 38 answers

Lucavi, hi.

Assuming that my own solution, which I gave above, did not work for you I cannot offer you a solution at this time, but perhaps we cannot get a little closer to identifying the cause.

1) The original question owner said that he had problems not only with YouTube videos, but "...generally with flash videos." Is this the case with you or can you play flash videos on sites other than YouTube?

2) Many people in Firefox and Google threads have said that whilst they cannot play YouTube videos on the YouTube website they can play them when they are embedded in someone else's website: is this true for you? If you are not sure try one of the videos on the following page, which are also found on the YouTube website: http://justinguitar.com/en/ST-324-LaylaUnplugged.php.

3) You said that the problem you describe does not occur in other browsers: what browsers have you tried?

Browsers do not all use the same version of Adobe Flash Player, so conceivably a problem with flash video may have a different cause for one browser as compared to another. Firefox and Opera, however, use the same external flash plugin and I have never had a problem playing YouTube videos at YouTube.com with Opera 12.16/15, whereas with Firefox I now have to use a secure http for this (i.e. https). I don't know why.

Modified by Ian.F

Lucavi 0 solutions 3 answers

Well, Ian.F.

The videos work on the website itself and in an embedded form. However the problem lies in manually starting the video again (After ending by its own, without interference) and then being unable to be manually started again.

  • I have tried Google Chrome; version 30.0.1599.101 and there is zero problems with the site.
  • I have tried Internet Explorer; version 8.0.6001.18702 and there is less of a problem than Firefox.. It sometimes manually starts up again, sometimes becomes in a frozen state like firefox.
  • I describe the frozen videos as.. in a way like this: Video buffers.. video ends. Starting it again and it freezes afterwards as if it can't buffer the video once again.


Edit: I think I have managed to fix the problem on my own. Thanks for the assistance, though.

Modified by Lucavi

Ian.F 1 solutions 38 answers

Lucavi, hello.

If you have managed to fix the problem that is obviously a good result, but if you could confirm the fix has worked and report the solution to this forum it could also benefit others.

I am still not clear, however, if, like the original questioner, your problem was with flash videos in general or only with YouTube, whether that be on the YouTube website or in other people's web pages. You seem to be saying that the problem occurs with YouTube videos on any web page: is that correct?

Here is a flash video that is NOT YouTube: http://www.ustream.tv/recorded/30076916

Do you have the same problem with this as with the YouTube videos?

Question owner

Hello, Ian.F! Thank you for your help. But uninstaller couldn't help to solve the issue. And indeed problem is with Flash Player, HTML5 works well. Even flash player settings don't pop up when I click them in menu. BTW, Explorer before playing video shows a message that flash player isn't installed for a second but than continue to play. Well, what can I say... Adobe Flash player, screw you! :)

Ian.F 1 solutions 38 answers

Helpful Reply

niseimono, hi.

Well, some progress then: HTML5 video works for you. In that case, if you have not already found it, you might want to try Firefox's addon, 'YouTube ALL HTML5', which you can find at https://addons.mozilla.org/en-US/firefox/addon/youtube-all-html5/.

I have not tried the addon myself, although the reviews are good: some of the initial criticisms were evidently silenced in the latest update.

Google, YouTube & HTML5, a Warning: Google, whom you may know own YouTube, have been experimenting with HTML5 video for a while and offer people the opportunity to opt in to the experiment so switiching to HTML5 video when available. A great many people, however, not least Google Chrome users, have had bad experiences of this and have had great difficulty opting out completely and returning to Adobe Flash, so if you have encountered this option consider it carefully before participating.

I hope you get to enjoy YouTube again.

Ian.F 1 solutions 38 answers

Cor-el, hi.

You might be correct: read on.

In one of your replies to me in this thread you suggested that the fact that using https solved my YouTube problem might indicate "...an issue with your security software that can no longer interfere if you switch to a secure connection. " I just wanted to say that whilst this remains to be proven someone in the google YouTube forum who like me uses Avast anti-virus software tried my solution and it worked for him: the symptoms of his problem he said were exactly as I had described. Also, I have used and installed Firefox on several computers recently that use AVG anti-virus and do not currently exhibit any problems with YouTube, so perhaps there is an Avast problem. You will recall, however, that when I viewed YouTube videos in Opera v12.16/v15 I had no problems, so if Avast is causing an issue now it is not affecting all browsers in the same way: for me you will remember Chrome had exactly the same problem/symptoms as FF and responded to the same solution.

Modified by Ian.F