X
Tap here to go to the mobile version of the site.

Support Forum

This thread was closed and archived. Please ask a new question if you need help.

Java has stopped working with Firefox

Posted

I've never had a problem before, but now I can't get Java to work. I tried using Google Drive with Firefox, but it said I needed to enable Java to get a feature to work. As far as I knew, it was already enabled.

So I removed older versions, then downloaded and installed Java, and now it doesn't work with Firefox. I've uninstalled and re-installed Firefox with no difference. Under Add-ons it says Java is enabled, but no sites are recognizing it. Java's site can't verify it when I try testing it.

This is very frustrating as a lot of sites just don't work without it. Am I doing something wrong? It's installed, it's there, but it's just not getting to Firefox. It works fine in other browsers, but I'd rather not use other browsers.

Thank you for your help.

I've never had a problem before, but now I can't get Java to work. I tried using Google Drive with Firefox, but it said I needed to enable Java to get a feature to work. As far as I knew, it was already enabled. So I removed older versions, then downloaded and installed Java, and now it doesn't work with Firefox. I've uninstalled and re-installed Firefox with no difference. Under Add-ons it says Java is enabled, but no sites are recognizing it. Java's site can't verify it when I try testing it. This is very frustrating as a lot of sites just don't work without it. Am I doing something wrong? It's installed, it's there, but it's just not getting to Firefox. It works fine in other browsers, but I'd rather not use other browsers. Thank you for your help.

Chosen solution

You should be running the latest version of Java, since outdated, insecure versions of Java are blocked in Firefox. See How to allow Java on trusted sites

If you see Java(TM) Platform SE 7 U45 in the Firefox Add-ons Plugins list, then you have the most recent version installed.

Ochd12, Are you still having issues with Java? Your troubleshooting information shows "javascript.enabled: false" which can cause some plugins to stop working (ref.)

To test this, please enable Javascript as follows:

  1. In the Location bar, type about:config and press Enter. The about:config "This might void your warranty!" warning page may appear.
  2. Click I'll be careful, I promise!, to continue to the about:config page.
  3. In the list of preferences, find javascript.enabled.
  4. Right-click on this preference and click Reset to change the value back to "true" (the default).
Read this answer in context 0

Additional System Details

Application

  • User Agent:

More Information

cor-el
  • Top 10 Contributor
  • Moderator
12011 solutions 111604 answers

Helpful Reply

Do you see the Java plugin listed on the about:plugins page?

Note that Firefox needs a 32 bit version of Java. You didn't list any System Details, so could you please post them in a next reply.
You can edit your first post in this thread (see the menu in the sidebar) and enter the data in the available fields.


See also:

Do you see the Java plugin listed on the about:plugins page? Note that Firefox needs a 32 bit version of Java. You didn't list any System Details, so could you please post them in a next reply.<br /> You can edit your first post in this thread (see the menu in the sidebar) and enter the data in the available fields. ----- See also: *http://kb.mozillazine.org/Java

Helpful Reply

I don't think I can edit, because the menus aren't dropping down for me.

Yes, it is in about:plugins and is listed as "Enabled". I went through the link you provided and tried a few things, but nothing worked.

I'm not sure what system details you need, but I'll provide what I can.

I don't think I can edit, because the menus aren't dropping down for me. Yes, it is in about:plugins and is listed as "Enabled". I went through the link you provided and tried a few things, but nothing worked. I'm not sure what system details you need, but I'll provide what I can.
cor-el
  • Top 10 Contributor
  • Moderator
12011 solutions 111604 answers
See: *https://support.mozilla.org/kb/Using+the+Troubleshooting+Information+page

Question owner

Application Basics


Name: Firefox Version: 24.0 User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20100101 Firefox/24.0

Extensions


Name: Adblock Plus Version: 2.4 Enabled: false ID: {d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}

Name: Adobe Acrobat - Create PDF Version: 1.0 Enabled: false ID: web2pdfextension@web2pdf.adobedotcom

Name: DownThemAll! Version: 2.0.16 Enabled: false ID: {DDC359D1-844A-42a7-9AA1-88A850A938A8}

Important Modified Preferences


accessibility.typeaheadfind.flashBar: 0 browser.cache.disk.capacity: 358400 browser.cache.disk.smart_size.first_run: false browser.cache.disk.smart_size.use_old_max: false browser.cache.disk.smart_size_cached_value: 358400 browser.places.smartBookmarksVersion: 4 browser.sessionstore.restore_on_demand: false browser.startup.homepage: tsn.ca browser.startup.homepage_override.buildID: 20130910160258 browser.startup.homepage_override.mstone: 24.0 dom.mozApps.used: true dom.w3c_touch_events.expose: false extensions.lastAppVersion: 24.0 gfx.direct3d.last_used_feature_level_idx: 0 gfx.direct3d.prefer_10_1: true javascript.enabled: false mousewheel.withcontrolkey.action: 0 mousewheel.withcontrolkey.sysnumlines: true network.cookie.prefsMigrated: true places.database.lastMaintenance: 1381898197 places.history.expiration.transient_current_max_pages: 104858 plugin.disable_full_page_plugin_for_types: application/pdf plugin.importedState: true plugin.state.flash: 2 plugin.state.java: 2 print.printer_Brother_MFC-255CW_Printer.print_bgcolor: false print.printer_Brother_MFC-255CW_Printer.print_bgimages: false print.printer_Brother_MFC-255CW_Printer.print_colorspace: print.printer_Brother_MFC-255CW_Printer.print_command: print.printer_Brother_MFC-255CW_Printer.print_downloadfonts: false print.printer_Brother_MFC-255CW_Printer.print_duplex: 1953063741 print.printer_Brother_MFC-255CW_Printer.print_edge_bottom: 0 print.printer_Brother_MFC-255CW_Printer.print_edge_left: 0 print.printer_Brother_MFC-255CW_Printer.print_edge_right: 0 print.printer_Brother_MFC-255CW_Printer.print_edge_top: 0 print.printer_Brother_MFC-255CW_Printer.print_evenpages: true print.printer_Brother_MFC-255CW_Printer.print_footercenter: print.printer_Brother_MFC-255CW_Printer.print_footerleft: print.printer_Brother_MFC-255CW_Printer.print_footerright: print.printer_Brother_MFC-255CW_Printer.print_headercenter: print.printer_Brother_MFC-255CW_Printer.print_headerleft: print.printer_Brother_MFC-255CW_Printer.print_headerright: print.printer_Brother_MFC-255CW_Printer.print_in_color: true print.printer_Brother_MFC-255CW_Printer.print_margin_bottom: 0.5 print.printer_Brother_MFC-255CW_Printer.print_margin_left: 0.5 print.printer_Brother_MFC-255CW_Printer.print_margin_right: 0.5 print.printer_Brother_MFC-255CW_Printer.print_margin_top: 0.5 print.printer_Brother_MFC-255CW_Printer.print_oddpages: true print.printer_Brother_MFC-255CW_Printer.print_orientation: 0 print.printer_Brother_MFC-255CW_Printer.print_page_delay: 50 print.printer_Brother_MFC-255CW_Printer.print_paper_data: 1 print.printer_Brother_MFC-255CW_Printer.print_paper_height: 11.00 print.printer_Brother_MFC-255CW_Printer.print_paper_name: print.printer_Brother_MFC-255CW_Printer.print_paper_size_type: 0 print.printer_Brother_MFC-255CW_Printer.print_paper_size_unit: 0 print.printer_Brother_MFC-255CW_Printer.print_paper_width: 8.50 print.printer_Brother_MFC-255CW_Printer.print_plex_name: print.printer_Brother_MFC-255CW_Printer.print_resolution: 2003134806 print.printer_Brother_MFC-255CW_Printer.print_resolution_name: print.printer_Brother_MFC-255CW_Printer.print_reversed: false print.printer_Brother_MFC-255CW_Printer.print_scaling: 1.00 print.printer_Brother_MFC-255CW_Printer.print_shrink_to_fit: true print.printer_Brother_MFC-255CW_Printer.print_to_file: false print.printer_Brother_MFC-255CW_Printer.print_unwriteable_margin_bottom: 0 print.printer_Brother_MFC-255CW_Printer.print_unwriteable_margin_left: 0 print.printer_Brother_MFC-255CW_Printer.print_unwriteable_margin_right: 0 print.printer_Brother_MFC-255CW_Printer.print_unwriteable_margin_top: 0 privacy.cpd.cookies: false privacy.donottrackheader.enabled: true privacy.sanitize.migrateFx3Prefs: true privacy.sanitize.timeSpan: 0 security.warn_viewing_mixed: false storage.vacuum.last.index: 1 storage.vacuum.last.places.sqlite: 1381795850

Graphics


Adapter Description: AMD Radeon(TM) HD 6520G Adapter Drivers: aticfx64 aticfx64 aticfx64 aticfx32 aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64 Adapter RAM: 512 Device ID: 0x9647 Direct2D Enabled: true DirectWrite Enabled: true (6.2.9200.16571) Driver Date: 4-20-2011 Driver Version: 8.834.1.0 GPU #2 Active: false GPU Accelerated Windows: 3/3 Direct3D 10 Vendor ID: 0x1002 WebGL Renderer: Google Inc. -- ANGLE (AMD Radeon(TM) HD 6520G Direct3D9Ex vs_3_0 ps_3_0) windowLayerManagerRemote: false AzureCanvasBackend: direct2d AzureContentBackend: direct2d AzureFallbackCanvasBackend: cairo

JavaScript


Incremental GC: true

Accessibility


Activated: false Prevent Accessibility: 0

Library Versions


NSPR Expected minimum version: 4.10 Version in use: 4.10

NSS Expected minimum version: 3.15.1 Basic ECC Version in use: 3.15.1 Basic ECC

NSSSMIME Expected minimum version: 3.15.1 Basic ECC Version in use: 3.15.1 Basic ECC

NSSSSL Expected minimum version: 3.15.1 Basic ECC Version in use: 3.15.1 Basic ECC

NSSUTIL Expected minimum version: 3.15.1 Version in use: 3.15.1

Application Basics ------------------ Name: Firefox Version: 24.0 User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20100101 Firefox/24.0 Extensions ---------- Name: Adblock Plus Version: 2.4 Enabled: false ID: {d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d} Name: Adobe Acrobat - Create PDF Version: 1.0 Enabled: false ID: web2pdfextension@web2pdf.adobedotcom Name: DownThemAll! Version: 2.0.16 Enabled: false ID: {DDC359D1-844A-42a7-9AA1-88A850A938A8} Important Modified Preferences ------------------------------ accessibility.typeaheadfind.flashBar: 0 browser.cache.disk.capacity: 358400 browser.cache.disk.smart_size.first_run: false browser.cache.disk.smart_size.use_old_max: false browser.cache.disk.smart_size_cached_value: 358400 browser.places.smartBookmarksVersion: 4 browser.sessionstore.restore_on_demand: false browser.startup.homepage: tsn.ca browser.startup.homepage_override.buildID: 20130910160258 browser.startup.homepage_override.mstone: 24.0 dom.mozApps.used: true dom.w3c_touch_events.expose: false extensions.lastAppVersion: 24.0 gfx.direct3d.last_used_feature_level_idx: 0 gfx.direct3d.prefer_10_1: true javascript.enabled: false mousewheel.withcontrolkey.action: 0 mousewheel.withcontrolkey.sysnumlines: true network.cookie.prefsMigrated: true places.database.lastMaintenance: 1381898197 places.history.expiration.transient_current_max_pages: 104858 plugin.disable_full_page_plugin_for_types: application/pdf plugin.importedState: true plugin.state.flash: 2 plugin.state.java: 2 print.printer_Brother_MFC-255CW_Printer.print_bgcolor: false print.printer_Brother_MFC-255CW_Printer.print_bgimages: false print.printer_Brother_MFC-255CW_Printer.print_colorspace: print.printer_Brother_MFC-255CW_Printer.print_command: print.printer_Brother_MFC-255CW_Printer.print_downloadfonts: false print.printer_Brother_MFC-255CW_Printer.print_duplex: 1953063741 print.printer_Brother_MFC-255CW_Printer.print_edge_bottom: 0 print.printer_Brother_MFC-255CW_Printer.print_edge_left: 0 print.printer_Brother_MFC-255CW_Printer.print_edge_right: 0 print.printer_Brother_MFC-255CW_Printer.print_edge_top: 0 print.printer_Brother_MFC-255CW_Printer.print_evenpages: true print.printer_Brother_MFC-255CW_Printer.print_footercenter: print.printer_Brother_MFC-255CW_Printer.print_footerleft: print.printer_Brother_MFC-255CW_Printer.print_footerright: print.printer_Brother_MFC-255CW_Printer.print_headercenter: print.printer_Brother_MFC-255CW_Printer.print_headerleft: print.printer_Brother_MFC-255CW_Printer.print_headerright: print.printer_Brother_MFC-255CW_Printer.print_in_color: true print.printer_Brother_MFC-255CW_Printer.print_margin_bottom: 0.5 print.printer_Brother_MFC-255CW_Printer.print_margin_left: 0.5 print.printer_Brother_MFC-255CW_Printer.print_margin_right: 0.5 print.printer_Brother_MFC-255CW_Printer.print_margin_top: 0.5 print.printer_Brother_MFC-255CW_Printer.print_oddpages: true print.printer_Brother_MFC-255CW_Printer.print_orientation: 0 print.printer_Brother_MFC-255CW_Printer.print_page_delay: 50 print.printer_Brother_MFC-255CW_Printer.print_paper_data: 1 print.printer_Brother_MFC-255CW_Printer.print_paper_height: 11.00 print.printer_Brother_MFC-255CW_Printer.print_paper_name: print.printer_Brother_MFC-255CW_Printer.print_paper_size_type: 0 print.printer_Brother_MFC-255CW_Printer.print_paper_size_unit: 0 print.printer_Brother_MFC-255CW_Printer.print_paper_width: 8.50 print.printer_Brother_MFC-255CW_Printer.print_plex_name: print.printer_Brother_MFC-255CW_Printer.print_resolution: 2003134806 print.printer_Brother_MFC-255CW_Printer.print_resolution_name: print.printer_Brother_MFC-255CW_Printer.print_reversed: false print.printer_Brother_MFC-255CW_Printer.print_scaling: 1.00 print.printer_Brother_MFC-255CW_Printer.print_shrink_to_fit: true print.printer_Brother_MFC-255CW_Printer.print_to_file: false print.printer_Brother_MFC-255CW_Printer.print_unwriteable_margin_bottom: 0 print.printer_Brother_MFC-255CW_Printer.print_unwriteable_margin_left: 0 print.printer_Brother_MFC-255CW_Printer.print_unwriteable_margin_right: 0 print.printer_Brother_MFC-255CW_Printer.print_unwriteable_margin_top: 0 privacy.cpd.cookies: false privacy.donottrackheader.enabled: true privacy.sanitize.migrateFx3Prefs: true privacy.sanitize.timeSpan: 0 security.warn_viewing_mixed: false storage.vacuum.last.index: 1 storage.vacuum.last.places.sqlite: 1381795850 Graphics -------- Adapter Description: AMD Radeon(TM) HD 6520G Adapter Drivers: aticfx64 aticfx64 aticfx64 aticfx32 aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64 Adapter RAM: 512 Device ID: 0x9647 Direct2D Enabled: true DirectWrite Enabled: true (6.2.9200.16571) Driver Date: 4-20-2011 Driver Version: 8.834.1.0 GPU #2 Active: false GPU Accelerated Windows: 3/3 Direct3D 10 Vendor ID: 0x1002 WebGL Renderer: Google Inc. -- ANGLE (AMD Radeon(TM) HD 6520G Direct3D9Ex vs_3_0 ps_3_0) windowLayerManagerRemote: false AzureCanvasBackend: direct2d AzureContentBackend: direct2d AzureFallbackCanvasBackend: cairo JavaScript ---------- Incremental GC: true Accessibility ------------- Activated: false Prevent Accessibility: 0 Library Versions ---------------- NSPR Expected minimum version: 4.10 Version in use: 4.10 NSS Expected minimum version: 3.15.1 Basic ECC Version in use: 3.15.1 Basic ECC NSSSMIME Expected minimum version: 3.15.1 Basic ECC Version in use: 3.15.1 Basic ECC NSSSSL Expected minimum version: 3.15.1 Basic ECC Version in use: 3.15.1 Basic ECC NSSUTIL Expected minimum version: 3.15.1 Version in use: 3.15.1
turborider 0 solutions 1 answers

Try downgrading your version of Java. This happened to me and it ended up being an issue with the newest version of java that had been updated.

I tried uninstalling and re-installing the current version with no success. But once I uninstalled and Installed a previous version of Java I was back up and running.

Try downgrading your version of Java. This happened to me and it ended up being an issue with the newest version of java that had been updated. I tried uninstalling and re-installing the current version with no success. But once I uninstalled and Installed a previous version of Java I was back up and running.
AliceWyman
  • Moderator
193 solutions 2216 answers

Chosen Solution

You should be running the latest version of Java, since outdated, insecure versions of Java are blocked in Firefox. See How to allow Java on trusted sites

If you see Java(TM) Platform SE 7 U45 in the Firefox Add-ons Plugins list, then you have the most recent version installed.

Ochd12, Are you still having issues with Java? Your troubleshooting information shows "javascript.enabled: false" which can cause some plugins to stop working (ref.)

To test this, please enable Javascript as follows:

  1. In the Location bar, type about:config and press Enter. The about:config "This might void your warranty!" warning page may appear.
  2. Click I'll be careful, I promise!, to continue to the about:config page.
  3. In the list of preferences, find javascript.enabled.
  4. Right-click on this preference and click Reset to change the value back to "true" (the default).
You should be running the latest version of Java, since outdated, insecure versions of Java are blocked in Firefox. See [[How to enable Java if it's been blocked]] If you see '''Java(TM) Platform SE 7 U45''' in the Firefox Add-ons Plugins list, then you have the most recent version installed. '''Ochd12''', Are you still having issues with Java? Your troubleshooting information shows "javascript.enabled: false" which can cause some plugins to stop working ([http://kb.mozillazine.org/Video_or_audio_does_not_play#Other_solutions ref.]) To test this, please enable Javascript as follows: # In the [[Location bar autocomplete|Location bar]], type '''about:config''' and press '''Enter'''. The about:config "''This might void your warranty!''" warning page may appear. # Click '''I'll be careful, I promise!''', to continue to the about:config page. #In the list of preferences, find '''javascript.enabled'''. #Right-click on this preference and click ''Reset'' to change the value back to "true" (the default).

Modified by AliceWyman

Question owner

Alice,

That did the trick, thank you very much!

Happy to begin using Firefox again.

Alice, That did the trick, thank you very much! Happy to begin using Firefox again.
AliceWyman
  • Moderator
193 solutions 2216 answers

Ochd12, Happy to hear the problem is fixed.

Since the issue was fixed by enabling JavaScript, I just wanted to clarify for you and anyone else reading this thread:

Even though the names both include "Java", JavaScript and Java are entirely different. Java is a plugin that some websites need, while JavaScript code is used by many websites and must be enabled for those sites to function properly. See: http://kb.mozillazine.org/JavaScript_is_not_Java and http://kb.mozillazine.org/JavaScript for details.

'''Ochd12,''' Happy to hear the problem is fixed. Since the issue was fixed by enabling JavaScript, I just wanted to clarify for you and anyone else reading this thread: Even though the names both include "Java", JavaScript and Java are entirely different. Java is a plugin that some websites need, while JavaScript code is used by many websites and must be enabled for those sites to function properly. See: http://kb.mozillazine.org/JavaScript_is_not_Java and http://kb.mozillazine.org/JavaScript for details.
philosopher1104 0 solutions 1 answers

I have been having trouble with Java for Firefox for months. It works for awhile, and then websites that require it just stop loading altogether, or load without images and links, or just load a very basic page. I have never been able to figure out exactly how to fix it. I have used about:config to check that Javascript is enabled, downloaded and reinstalled Java (also uninstalled it manually first, before reinstalling), reset Firefox, disabled and reenabled all extensions, uninstalled and reinstalled Firefox...nothing ever works consistently. I can get it back up and working, but no consistency about how to do that. Occasionally it will stop working, and then just as mysteriously start working again, without any intervention on my part. I use both the 64- and 32-bit versions of Java. Windows 7 Pro SP1 x64 Intel Core i7-2600 @ 3.40GHz Ram: 16GB Intel SSD 120GB System drive Firefox 25 Java SE7 U45

Does anyone have any suggestions of things I haven't tried?

I have been having trouble with Java for Firefox for months. It works for awhile, and then websites that require it just stop loading altogether, or load without images and links, or just load a very basic page. I have never been able to figure out exactly how to fix it. I have used about:config to check that Javascript is enabled, downloaded and reinstalled Java (also uninstalled it manually first, before reinstalling), reset Firefox, disabled and reenabled all extensions, uninstalled and reinstalled Firefox...nothing ever works consistently. I can get it back up and working, but no consistency about how to do that. Occasionally it will stop working, and then just as mysteriously start working again, without any intervention on my part. I use both the 64- and 32-bit versions of Java. Windows 7 Pro SP1 x64 Intel Core i7-2600 @ 3.40GHz Ram: 16GB Intel SSD 120GB System drive Firefox 25 Java SE7 U45 Does anyone have any suggestions of things I haven't tried?
AliceWyman
  • Moderator
193 solutions 2216 answers

philosopher1104,

Try the test links in http://kb.mozillazine.org/Java#Testing_Java to see if Java is working. If the problem is only with specific websites, first take a look at these articles:

If you need more help you should ask a new question (see Get community support for some resources). Be sure to include troubleshooting information and links to problem websites in your new thread.

I'll close this thread since the original question has been solved.

philosopher1104, Try the test links in http://kb.mozillazine.org/Java#Testing_Java to see if Java is working. If the problem is only with specific websites, first take a look at these articles: *[[Websites look wrong or appear differently than they should]] *[[Websites don't load - troubleshoot and fix error messages]] If you need more help you should [/questions/new ask a new question] (see [[Get community support]] for some resources). Be sure to include troubleshooting information and links to problem websites in your new thread. I'll close this thread since the original question has been solved.