X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Fullscreen mode doesn't go well with keyboard shortcuts

Posted

I used F11 to go to fullscreen mode in firefox. To make a search, I used Ctrl+T and typed the search. I could see awesome bar and tabs while typing the keywords. That was OK. But, when I got the search results, I hoped firefox would reach fullscreen mode again. No, Firefox went fullscreen only when I move the mouse. I mostly operate with keyboard and don't like to use mousepad. Is there any way I can make firefox go fullscreen automatically?

One more thing, if I want to see the address of a webpage, is moving the cursor to top of screen, the only way? Is there any keyboard shortcut for this?

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.2 r202
  • DivX Web Player version 1.4.0.233
  • The Videos 3.6.3 plugin handles video and audio streams.
  • This plug-in detects the presence of iTunes when opening iTunes Store URLs in a web page with Firefox.

Application

  • Firefox 24.0
  • User Agent: Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:24.0) Gecko/20100101 Firefox/24.0
  • Support URL: https://support.mozilla.org/1/firefox/24.0/Linux/en-US/

Extensions

  • Pocket 3.0.4 (isreaditlater@ideashower.com)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Ubuntu Firefox Modifications 2.7 (ubufox@ubuntu.com)
  • Ubuntu Online Accounts 0.4.5 (online-accounts@lists.launchpad.net)
  • Unity Desktop Integration 2.4.6 (webapps-team@lists.launchpad.net)
  • Unity Websites integration 2013.04.05.beta ({2e1445b0-2682-11e1-bfc2-0800200c9a66})

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel Open Source Technology Center -- Mesa DRI Intel(R) Ivybridge Mobile x86/MMX/SSE2
  • adapterDeviceID: Mesa DRI Intel(R) Ivybridge Mobile x86/MMX/SSE2
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: Intel Open Source Technology Center
  • driverDate:
  • driverVersion: 3.0 Mesa 9.1.4
  • info: {u'AzureCanvasBackend': u'cairo', u'AzureFallbackCanvasBackend': u'none', u'AzureContentBackend': u'none'}
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 1
  • webglRenderer: Intel Open Source Technology Center -- Mesa DRI Intel(R) Ivybridge Mobile x86/MMX/SSE2
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Basic

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.startup.homepage: about:home
  • browser.startup.homepage_override.buildID: 20130911155657
  • browser.startup.homepage_override.mstone: 24.0
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 24.0
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1381422996
  • places.history.expiration.transient_current_max_pages: 100174
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • privacy.sanitize.migrateFx3Prefs: True
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1380378022

Misc

  • User JS: No
  • Accessibility: No
ideato
  • Top 25 Contributor
616 solutions 4258 answers

Hello Nitish, it is the correct behaviour when you move the mouse to go to full screen again !

if you want to see always the tabs and location bar when full screen mode is enabled, follow these steps:

  1. In the Location bar, type about:config and press Enter. The about:config "This might void your warranty!" warning page may appear.
  2. Click I'll be careful, I promise!, to continue to the about:config page.
  3. In the Search field, type browser.fullscreen.autohide
  4. Double-click the browser.fullscreen.autohide preference to set its value to false.

with the above you can do your searches, BUT you lost a little 'full screen mode functionality' !

i think if you close firefox in full screen mode then when you re-open firefox you are in full screen mode again.

thank you

Question owner

Thanks for the reply, but what I want is exactly opposite. Once I type the web address or search keywords in awesome bar, firefox must go to fullscreen mode without any mouse movement. Is there any way for this?

cor-el
  • Top 10 Contributor
  • Moderator
10738 solutions 96600 answers

Firefox will keep the Navigation Toolbar visible in full screen mode if you enter a new URL in the location bar, so you can see what is happening and which to URL you end up. There is no way to change this.

Question owner

It's OK upto that. But, even after loading completely, the location bar stays. Can anything be done for it?