X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

What do I do if Firefox crashes a few secs after trying to load any animated material, be it ads at the side of Cheezburger websites, YouTube videos, or Hulu?

Posted

I just bought a new HP Pavilion 23 inch All-In-One desktop, the one without a modem on the side because everything stands straight up. I'm usually technically literate and can figure most things out easily. This, however, dumbfounds me because I have to think and know exactly how something does what, and I cannot come up with an answer at all. Anyway I downloaded Flash a couple more times to try to fix this problem, but it hasn't gone away. What it does, is, whenever I want to watch [or don't want to watch, in some side-of-website-video-ads] the Firefox tab with the animation will be very sensitive, and the slightest click to any website, such as the next Cheezburger Website page, or just the fact that a video is loading on YouTube or on Hulu will cause Adobe Flash Player to crash within a few milliseconds. It does let you hear the first 5 seconds or so of the video before it stops [a few seconds after Adobe's unresponsiveness, I might add] due to Adobe not responding and therefore crashing. In most cases where the video does make it crash, the majority of the time either the video's picture won't load before it crashes, or, even if a picture does attempt to load, it's just a dark forest green color instead of the video's picture on YouTube. If I'm just looking at non-moving pictures and small GIFs, such as the funnies at Cheezburger websites or the funnies at Explosm.net, it doesn't crash on me. The majority of the videos I watch are Anime related. I don't want to have to use Google Chrome, since I trust Firefox to catch ads from popping up, which is very nice, but I might have to if this is not resolved.

Modified by WindScar22

Chosen solution

Try disabling graphics hardware acceleration. Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches.

You might need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.).

Then perform these steps:

  • Click the orange Firefox button at the top left, then select the "Options" button, or, if there is no Firefox button at the top, go to Tools > Options.
  • In the Firefox options window click the Advanced tab, then select "General".
  • In the settings list, you should find the Use hardware acceleration when available checkbox. Uncheck this checkbox.
  • Now, restart Firefox and see if the problems persist.

Additionally, please check for updates for your graphics driver by following the steps mentioned in the following Knowledge base articles:

Did this fix your problems? Please report back soon.

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.8 r800
  • Google Update
  • Picasa plugin
  • WildTangent Games App V2 Presence Detector
  • NPWLPG
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • Firefox 24.0
  • User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:24.0) Gecko/20100101 Firefox/24.0
  • Support URL: https://support.mozilla.org/1/firefox/24.0/WINNT/en-US/

Extensions

  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • WOT 20130924 ({a0d7ccb3-214d-498b-b4aa-0e8fda9a7bf7})
  • Norton Toolbar 2013.4.3.4 ({2D3F3651-74B9-4795-BDEC-6DA2F431CB62}) (Inactive)
  • Norton Vulnerability Protection 12.0.0.380 - 1 ({BBDA0591-3099-440a-AA10-41764D9DB4DB}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: KB 4C 25W (9830)
  • adapterDescription2:
  • adapterDeviceID: 0x9830
  • adapterDeviceID2:
  • adapterDrivers: aticfx64 aticfx64 aticfx64 aticfx32 aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
  • adapterDrivers2:
  • adapterRAM: 512
  • adapterRAM2:
  • adapterVendorID: 0x1002
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.16433
  • driverDate: 2-25-2013
  • driverDate2:
  • driverVersion: 12.101.1.0
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d'}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (KB 4C 25W (9830) Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Direct3D 10

Modified Preferences

  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.startup.homepage_override.buildID: 20130910160258
  • browser.startup.homepage_override.mstone: 24.0
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 24.0
  • font.internaluseonly.changed: True
  • gfx.direct3d.last_used_feature_level_idx: 0
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1380416724
  • places.history.expiration.transient_current_max_pages: 92852
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • privacy.sanitize.migrateFx3Prefs: True
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1379833225

Misc

  • User JS: No
  • Accessibility: No
Wesley Branton
  • Top 25 Contributor
178 solutions 2062 answers

Try Firefox Safe Mode to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • On Windows you can open Firefox 4.0+ in Safe Mode by holding the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac you can open Firefox 4.0+ in Safe Mode by holding the option key while starting Firefox.
  • On Linux you can open Firefox 4.0+ in Safe Mode by quitting Firefox and then going to your Terminal and running: firefox -safe-mode (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)
  • Or open the Help menu and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

FirefoxSafeMode

Once you get the pop-up, just select "'Start in Safe Mode" Safe Mode Fx 15 - Win

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

Please report back soon.

Wesley Branton
  • Top 25 Contributor
178 solutions 2062 answers

Please check if all your plugins are up-to-date. To do this, go to the Mozilla Plugin Check site.

Once you're there, the site will check if all your plugins have the latest versions. If you see plugins in the list that have a yellow Update button or a red Update now button, please update these immediately.

To do so, please click each red or yellow button. Then you should see a site that allows you to download the latest version. Double-click the downloaded file to start the installation and follow the steps mentioned in the installation procedure.

Helpful Reply

I've checked, and it does not work in Safe Mode. Also, I have very little plug-ins except Picasa and WOT that actually do something. They're up to date. I can't seem to generate a cause in my head.

Waka_Flocka_Flame
  • Top 25 Contributor
528 solutions 5041 answers

We're sorry to hear that Firefox is crashing. In order to assist you better, please follow the steps below to provide us crash ID's to help us learn more about your crash.

  1. Enter about:crashes in the address bar (that's where you enter your website URL) and press Enter. You should now see a list of submitted crash reports.

    aboutcrashes.png
  2. Copy the 5 most recent crash ID's that you see in the crash report window and paste them into your response here.

More information and further troubleshooting steps can be found in the Firefox crashes - Troubleshoot, prevent and get help fixing crashes article.

Question owner

ebdddaf6-d461-42aa-bc48-596dbb7e5513 9/29/2013 8:34 PM

bp-3fcd98ba-c18c-4f42-8459-46c542130930 9/29/2013 8:15 PM

2a115212-4114-451b-9519-a5b172d40e6c 9/29/2013 7:54 PM

9d48d0cc-8ebd-4775-a8ce-160d42aa19bd 9/29/2013 7:50 PM

62f64e96-9a8a-44a8-be16-7640d9b9c121 9/29/2013 7:49 PM

29b4708c-05bc-4cb4-a469-36367348201d 9/29/2013 7:49 PM

Here ya go.

Modified by WindScar22

Helpful Reply

Is anyone here to help?

Waka_Flocka_Flame
  • Top 25 Contributor
528 solutions 5041 answers

That crash is a problem with the Adobe Flash Player.

Other, more technical information about these issues can be found under these Links:


Please tell us if this helped!

Wesley Branton
  • Top 25 Contributor
178 solutions 2062 answers

Chosen Solution

Try disabling graphics hardware acceleration. Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches.

You might need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.).

Then perform these steps:

  • Click the orange Firefox button at the top left, then select the "Options" button, or, if there is no Firefox button at the top, go to Tools > Options.
  • In the Firefox options window click the Advanced tab, then select "General".
  • In the settings list, you should find the Use hardware acceleration when available checkbox. Uncheck this checkbox.
  • Now, restart Firefox and see if the problems persist.

Additionally, please check for updates for your graphics driver by following the steps mentioned in the following Knowledge base articles:

Did this fix your problems? Please report back soon.

Question owner

Well, it seems that stopping the Graphic Hardware Acceleration has fixed the video problem. Now I'm going to go check Hulu.

EDIT: Hulu works fine as well, since the ad at the beginning of a played. So, it seems as though my problem has been fixed, and I guess I'll check now and again on the GHA to see if they haven't addressed my problem. For now, though, it stays off.

Thank you, ComputerWhiz. Also, thank you, Wacka-Flocka-Flame for at least trying to fix my problem. You guys are really helpful. Thanks again!

Modified by WindScar22