X
Tap here to go to the mobile version of the site.

Support Forum

Geolocation stopped working in Firefox 24 after update (Win7 64). Downgraded to FF 23.0.1 solved the problem. Same with other FF installation at another PC.

Posted

Visiting this page: https://developers.google.com/maps/documentation/javascript/examples/map-geolocation or any other website using geolocation to track my location, shows a blank map and no prompt "Share location: Allow, Block, Not now".

This happened since upgrading to FF 24 (Desktop Win7 64). Downgrading to FF 23.0.1, solves the problem: FF prior to 24 supports geolocation with no problem. Tried in both my desktop and laptop with separate FF installations, using different plugins.

Thank you in advance.

[ NOTE: Now using Firefox 23.0.1, the problem only occurs after upgrading to Firefox 24 ]

Visiting this page: https://developers.google.com/maps/documentation/javascript/examples/map-geolocation or any other website using geolocation to track my location, shows a blank map and no prompt "Share location: Allow, Block, Not now". This happened since upgrading to FF 24 (Desktop Win7 64). Downgrading to FF 23.0.1, solves the problem: FF prior to 24 supports geolocation with no problem. Tried in both my desktop and laptop with separate FF installations, using different plugins. Thank you in advance. [ NOTE: Now using Firefox 23.0.1, the problem only occurs after upgrading to Firefox 24 ]

Chosen solution

Uninstalling Firefox completely from my laptop and installing it again, solved the problem.

I haven't tried with my desktop yet.

The laptop uses wifi while the desktop ethernet. The problem existed in the laptop installation of FF 24 too, so I don't think that was the root of the problem, at least in my case.

Read this answer in context 2

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.8 r800
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.04
  • 5.1.20513.0
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.0

Application

  • Firefox 23.0.1
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:23.0) Gecko/20100101 Firefox/23.0
  • Support URL: http://support.mozilla.org/1/firefox/23.0.1/WINNT/en-US/

Extensions

  • about:addons-memory 7 (about-addons-memory@tn123.org)
  • Adblock Plus 2.3.2 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • All-in-One Sidebar 0.7.20 ({097d3191-e6fa-4728-9826-b533d755359d})
  • Free Download Manager plugin 1.5.8 (fdm_ffext@freedownloadmanager.org)
  • Image Toolbar 0.6.12 ({A4732521-77D9-447E-A557-B279AC923F06})
  • Memory Restart 1.11 (memoryrestart@teamextension.com)
  • Pearl Crescent Page Saver Basic 2.8 ({c151d79e-e61b-4a90-a887-5a46d38fba99})
  • Private Tab 0.1.5 (privateTab@infocatcher)
  • Saved Password Editor 2.7 (savedpasswordeditor@daniel.dawson)
  • SearchPreview 6.4 ({EF522540-89F5-46b9-B6FE-1829E2B572C6})
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Web Developer Tools - toolbar button 1.0.22 (devtoolsmenu@AccessFirefox.org)
  • Adobe Acrobat - Create PDF 2.0 (web2pdfextension@web2pdf.adobedotcom) (Inactive)
  • Print pages to PDF 0.1.9.3 (printPages2Pdf@reinhold.ripper) (Inactive)
  • QuickJava 1.8.1.1 ({E6C1199F-E687-42da-8C24-E7770CC3AE66}) (Inactive)
  • SeoQuake 2.8.12.1 ({317B5128-0B0B-49b2-B2DB-1E7560E16C74}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: NVIDIA GeForce GT 430
  • adapterDescription2:
  • adapterDeviceID: 0x0de1
  • adapterDeviceID2:
  • adapterDrivers: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
  • adapterDrivers2:
  • adapterRAM: 2047
  • adapterRAM2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.16571
  • driverDate: 2-9-2013
  • driverDate2:
  • driverVersion: 9.18.13.1407
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d'}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (NVIDIA GeForce GT 430)
  • windowLayerManagerType: Direct3D 10

Modified Preferences

  • accessibility.typeaheadfind: True
  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 51200
  • browser.cache.disk.smart_size.enabled: False
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 640000
  • browser.cache.memory.capacity: 65536
  • browser.display.show_image_placeholders: True
  • browser.places.smartBookmarksVersion: 4
  • browser.privatebrowsing.dont_prompt_on_enter: True
  • browser.search.useDBForOrder: True
  • browser.sessionstore.interval: 35000
  • browser.sessionstore.max_tabs_undo: 12
  • browser.sessionstore.max_windows_undo: 2
  • browser.startup.homepage: about:newtab
  • browser.startup.homepage_override.buildID: 20130814063812
  • browser.startup.homepage_override.mstone: 23.0.1
  • browser.tabs.tabMinWidth: 100
  • browser.urlbar.autocomplete.enabled: True
  • browser.urlbar.autofill: True
  • dom.disable_window_open_feature.resizable: False
  • dom.indexedDB.enabled: False
  • dom.max_script_run_time: 20
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 23.0.1
  • font.internaluseonly.changed: False
  • font.name.serif.x-western: Tahoma
  • gfx.direct3d.last_used_feature_level_idx: 0
  • gfx.direct3d.prefer_10_1: True
  • gfx.font_rendering.cleartype.use_for_downloadable_fonts: False
  • javascript.options.mem.log: True
  • keyword.URL: http://www.google.com/search?ie=UTF-8&oe=utf-8&q=
  • network.cookie.prefsMigrated: True
  • network.dns.disableIPv6: True
  • network.http.max-connections: 48
  • network.http.max-connections-per-server: 16
  • network.http.max-persistent-connections-per-proxy: 16
  • network.http.max-persistent-connections-per-server: 8
  • network.http.pipelining: True
  • network.http.pipelining.maxrequests: 8
  • network.http.proxy.pipelining: True
  • network.http.request.max-start-delay: 0
  • places.database.lastMaintenance: 1379597082
  • places.history.expiration.transient_current_max_pages: 104858
  • places.history.expiration.transient_optimal_database_size: 167772160
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.expose_full_path: True
  • plugin.importedState: True
  • plugin.state.np_asc_plugin: 0
  • plugin.state.npadobeaamdetect: 0
  • plugin.state.npascsafaripluginprotect: 0
  • plugin.state.npauthz: 0
  • plugin.state.npgeplugin: 0
  • plugin.state.npgoogleupdate: 0
  • plugin.state.npspwrap: 0
  • privacy.clearOnShutdown.cookies: False
  • privacy.clearOnShutdown.formdata: False
  • privacy.clearOnShutdown.history: False
  • privacy.clearOnShutdown.offlineApps: True
  • privacy.clearOnShutdown.sessions: False
  • privacy.cpd.formdata: False
  • privacy.cpd.sessions: False
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.timeSpan: 0
  • security.default_personal_cert: Select Automatically
  • security.dialog_enable_delay: 0
  • security.warn_viewing_mixed: False
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1377156532
  • webgl.force-enabled: True

Misc

  • User JS: Yes
  • Accessibility: No
cor-el
  • Top 10 Contributor
  • Moderator
17273 solutions 156121 answers

You should see a notification icon on the left hand side of the location bar to ask for permission, similar to the key icon for saving passwords and other notifications that you see in the location bar. Current Firefox versions no longer have the info notification bar.

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window.
You should see a notification icon on the left hand side of the location bar to ask for permission, similar to the key icon for saving passwords and other notifications that you see in the location bar. Current Firefox versions no longer have the info notification bar. Start Firefox in <u>[[Safe Mode|Safe Mode]]</u> to check if one of the extensions (Firefox/Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Firefox/Tools > Add-ons > Appearance). *Do NOT click the Reset button on the Safe Mode start window. *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes

Question owner

Visiting https://developers.google.com/maps/documentation/javascript/examples/map-geolocation

Firefox 24, re-started in Safe Mode with all addons disabled, using the default theme, having unhecked the "use hardware acceleration" option (Options > Advanced), but still no luck.

Tried disabling all plugins too (Adobe Acrobat, Flash, Silverlight e.g.) just in case but nothing happened.

FF24 does not ask me if I want my location to be shared, not even if I set site permissions to always share my location with the current domain (developes.google.com).

Please see the attached screenshot, no prompt, no target (geolocation) icon, no nothing.

Any clues? Is it only me?

Thank you in avance.

Visiting https://developers.google.com/maps/documentation/javascript/examples/map-geolocation Firefox 24, re-started in Safe Mode with all addons disabled, using the default theme, having unhecked the "use hardware acceleration" option (Options > Advanced), but still no luck. Tried disabling all plugins too (Adobe Acrobat, Flash, Silverlight e.g.) just in case but nothing happened. FF24 does not ask me if I want my location to be shared, not even if I set site permissions to always share my location with the current domain (developes.google.com). Please see the attached screenshot, no prompt, no target (geolocation) icon, no nothing. Any clues? Is it only me? Thank you in avance.
cor-el
  • Top 10 Contributor
  • Moderator
17273 solutions 156121 answers

What is the setting for "Share Location" in "Tools > Page Info > Permissions" when you visit this web page?


You can inspect and manage the permissions for all domains on the about:permissions page or for the domain in the currently selected tab by clicking the "Site Identity Button" (globe/padlock) on the location bar and "More Information" to open "Page Info" and go to the Permissions tab.

What is the setting for "Share Location" in "Tools > Page Info > Permissions" when you visit this web page? ---- You can inspect and manage the permissions for all domains on the <b>about:permissions</b> page or for the domain in the currently selected tab by clicking the "Site Identity Button" (globe/padlock) on the location bar and "More Information" to open "Page Info" and go to the Permissions tab. *https://support.mozilla.org/kb/how-do-i-manage-website-permissions

Question owner

Thank you for your reply, but, as I mentioned above, even if I set site permissions to always share my location with the current domain) the permissions are not the problem:

developers.google.com

Store passwords: Allow | Share location: Allow | Set Cookies: Allow

Neither "allow: or "always ask" solve the problem.

I did not alter any values in about:config [geo.enabled and it is set to true]

I don't know if this helps, but I am using Palemoon (a custom edition of Firefox) in both machines, but Palemoon uses its own profile.

Palemoon 24 has the same issue as Firefox 24 regarding geolocation - downgrading either of them to an earlier version solves the problem for each one.

I will try to uninstall both, remove all preferences and install a fresh copy of Firefox 24 to see if it makes any difference.

I will inform you tor the result.

Thank you in advance.

Thank you for your reply, but, as I mentioned above, ''even if I set site permissions to always share my location with the current domain)'' the permissions are not the problem: developers.google.com Store passwords: Allow | '''Share location: Allow''' | Set Cookies: Allow Neither "allow: or "always ask" solve the problem. I did not alter any values in about:config [geo.enabled and it is set to true] I don't know if this helps, but I am using Palemoon (a custom edition of Firefox) in both machines, but Palemoon uses its own profile. Palemoon 24 has the same issue as Firefox 24 regarding geolocation - downgrading either of them to an earlier version solves the problem for each one. I will try to uninstall both, remove all preferences and install a fresh copy of Firefox 24 to see if it makes any difference. I will inform you tor the result. Thank you in advance.
mortoman 0 solutions 3 answers

Hi SotirisKalathas,

I was wondering if you have any update on your tests ? I also have found the same issues with Safari, Chrome, and Firefox 24; IE 10 works as far as getting a map object back but then fails to pin an infoWindow. Would be interested to know if anyone has the same issue or has found a solution ?

cheers

Hi SotirisKalathas, I was wondering if you have any update on your tests ? I also have found the same issues with Safari, Chrome, and Firefox 24; IE 10 works as far as getting a map object back but then fails to pin an infoWindow. Would be interested to know if anyone has the same issue or has found a solution ? cheers
mortoman 0 solutions 3 answers

Hi all,

For people interested I've found the reason (although not sure why this behavior has been adopted by the browser developers unless due to accuracy). I have an old Apple PowerBook G4 and tried the geolocation code out using Ten Four Fox. When connected to Ethernet the geolocation API fails; whilst once wireless connectivity is present it works !!!

I replaced my wired connection in my development PC with a wireless card and hey presto all the functionality of the geolocation API returns.

Now I can only assume the default behavior is to ignore the calls if there isn't a wireless connection present as the wired connection will provide inaccurate location data (IE 10 thinks I'm in London at the address of my ISP), but the wireless connection will provide a location within a couple of hundred meters of the true latitude and longitude intersection.

Perhaps someone from Mozilla could confirm if this is the case i.e. gelocation calls for getCurrentPosition will fail unless a wireless connection is present, is this correct ?

Anyway my code is working via Firefox and Chrome again.

Hope this helps someone out,

cheers guys,

mortoman.

Hi all, For people interested I've found the reason (although not sure why this behavior has been adopted by the browser developers unless due to accuracy). I have an old Apple PowerBook G4 and tried the geolocation code out using Ten Four Fox. When connected to Ethernet the geolocation API fails; whilst once wireless connectivity is present it works !!! I replaced my wired connection in my development PC with a wireless card and hey presto all the functionality of the geolocation API returns. Now I can only assume the default behavior is to ignore the calls if there isn't a wireless connection present as the wired connection will provide inaccurate location data (IE 10 thinks I'm in London at the address of my ISP), but the wireless connection will provide a location within a couple of hundred meters of the true latitude and longitude intersection. Perhaps someone from Mozilla could confirm if this is the case i.e. gelocation calls for getCurrentPosition will fail unless a wireless connection is present, is this correct ? Anyway my code is working via Firefox and Chrome again. Hope this helps someone out, cheers guys, mortoman.

Chosen Solution

Uninstalling Firefox completely from my laptop and installing it again, solved the problem.

I haven't tried with my desktop yet.

The laptop uses wifi while the desktop ethernet. The problem existed in the laptop installation of FF 24 too, so I don't think that was the root of the problem, at least in my case.

Uninstalling Firefox completely from my laptop and installing it again, solved the problem. I haven't tried with my desktop yet. The laptop uses wifi while the desktop ethernet. The problem existed in the laptop installation of FF 24 too, so I don't think that was the root of the problem, at least in my case.
Ghosthack 0 solutions 1 answers

I have exactly the same problem here, geolocation doesn't work anywhere in Firefox 24.

I have exactly the same problem here, geolocation doesn't work anywhere in Firefox 24.
ivan.zderadicka 0 solutions 1 answers

Same problem here: FF 24.0 on Ubuntu 13.04 The confirmation is not even displayed. Save mode did not help. What helped a bit was starting FF with fresh profile firefox -profileManage

I got confirmation , but geolocation was not still working - location error event: --

Geolocation error: timeout.

Not sure if these two problems are related.

Same problem here: FF 24.0 on Ubuntu 13.04 The confirmation is not even displayed. Save mode did not help. What helped a bit was starting FF with fresh profile firefox -profileManage I got confirmation , but geolocation was not still working - location error event: -- Geolocation error: timeout. Not sure if these two problems are related.
mortoman 0 solutions 3 answers

Hi guys,

I still get the same functionality; I switch to an Ethernet only connection and try geolocation.getCurrentPosition this gives me the request in FF24 to permit my location to be shared. I grant permission and then nothing, I try the same in IE10 and I get back the location (although highly inaccurate) and the google map using the maps API. I switch back to a wireless only connection and then everything works again !!! I change nothing else except disable the Ethernet card and enable the wireless card, nothing else is changed on the machine. Must be something to do with access via the wireless protocol ??

Hi guys, I still get the same functionality; I switch to an Ethernet only connection and try geolocation.getCurrentPosition this gives me the request in FF24 to permit my location to be shared. I grant permission and then nothing, I try the same in IE10 and I get back the location (although highly inaccurate) and the google map using the maps API. I switch back to a wireless only connection and then everything works again !!! I change nothing else except disable the Ethernet card and enable the wireless card, nothing else is changed on the machine. Must be something to do with access via the wireless protocol ??
dprovost 0 solutions 2 answers

Helpful Reply

Still doesnt work in Firefox 24 or 25. Works like a charm in 23.0.1

Still doesnt work in Firefox 24 or 25. Works like a charm in 23.0.1
Gondomir 0 solutions 4 answers

I have this problem on a fresh installed Windows 7 with all updates. Also on a Suse with FF 26. On my Mac it works. The Mac is connected with WLAN, Windows and Suse are running in VMware, so they have ethernet connection. But this worked also in earlier version (but not as accurate as on the Mac using WLAN).

I have this problem on a fresh installed Windows 7 with all updates. Also on a Suse with FF 26. On my Mac it works. The Mac is connected with WLAN, Windows and Suse are running in VMware, so they have ethernet connection. But this worked also in earlier version (but not as accurate as on the Mac using WLAN).
tsanidas 0 solutions 2 answers

Helpful Reply

I was having this problem and it was driving me crazy. After trying to start and restart several dozen times, I noticed there was a file creation error message in the console. Trying to outsmart that, I ran Firefox as administrator (Win 7), and suddenly geolocation was working again. I noticed that FF had created a new folder:

 c:/Program Files (x86)/Mozilla Firefox/browser/defaults
 right around the time this started working.  Either I did something or my company recently locked down the Firefox directories, which is highly likely.
 I hope this helps someone else.
I was having this problem and it was driving me crazy. After trying to start and restart several dozen times, I noticed there was a file creation error message in the console. Trying to outsmart that, I ran Firefox as administrator (Win 7), and suddenly geolocation was working again. I noticed that FF had created a new folder: c:/Program Files (x86)/Mozilla Firefox/browser/defaults right around the time this started working. Either I did something or my company recently locked down the Firefox directories, which is highly likely. I hope this helps someone else.

Modified by tsanidas

Gondomir 0 solutions 4 answers

After starting FF as administrator I allowed to locate. But it didn't work at this time. After then, I startet FF as user, now it works.

After starting FF as administrator I allowed to locate. But it didn't work at this time. After then, I startet FF as user, now it works.
dprovost 0 solutions 2 answers

Did exactly the same. Ran FF 27 as administrator, and geolocater worked as it should. Restarted FF as regular user and it works too! Thanks tsanidas for your diligent efforts!

Did exactly the same. Ran FF 27 as administrator, and geolocater worked as it should. Restarted FF as regular user and it works too! Thanks tsanidas for your diligent efforts!
tsanidas 0 solutions 2 answers

Glad my obsessing over this yielded some fruit! I'm asking because I've never done this, but is this something that I should report as a bug? If so, how?

Glad my obsessing over this yielded some fruit! I'm asking because I've never done this, but is this something that I should report as a bug? If so, how?