Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Google search plugin redirects to https

  • 23 replies
  • 14 have this problem
  • 2225 views
  • Last reply by Nick2012

more options

I am getting increasingly frustrated by the Google search plugin redirecting search results to https.

I have edited the Google xml file so that all instances of https have been changed to http then deleted the search.json file but my search results still get redirected to https.

I've also deleted cookies and temp files but the problem persists.

The reason is bugs me so much is that my ad blocker is unable to filter https.

I'm not sure if it's a FF issue or more likely, it's Google doing the redirecting but previous version of FF were fine once I edited the xml file.

Any help or suggestions would be cool.

Thanks.

Chosen solution

That's definitely a redirect from Google. Since search plugins are consistent in what they send Google, it's hard to know why you get switched to HTTPS. Presumably the signal is in one of the cookies Google sets, but I don't know what causes it to get set in the first place.

Read this answer in context 👍 1

All Replies (20)

more options

Why wouldnt you want HTTPS, have you used the searchreset tool?

more options

When you are logged in to your Google account, Google will redirect you from HTTP to HTTPS. However, when you are logged out, then the plugin should work as designed.

Rather than edit the standard Google search plugin, which will be replaced the next time you update, you can add a new search plugin for HTTP. You can choose one from the Mycroft site, or I have posted one that I created last July by deleting the "s" from the URLs in the standard search plugin.

Does that work?

more options

Or another thing is you can just a different ad blocker (ad block plus comes to mind).

more options

Thanks Waka_Flocka_Flame, I will try your suggestion.

As I mentioned in my first post, I don't want ssl search results from Google as my ad blocker is unable to filter ssl.

Modified by Nick2012

more options

Thanks jscher2000.

I'm never logged into Google when I use the search bar.

I've also tried the mycroftproject plugin after reading a similar thread. I will try the other link though.

more options

Thanks tylerdowner.

I'm very happy with Ad Muncher as it blocks far more than other apps...just a shame it doesn't currently work with https.

more options

No joy with your plugin I'm afraid jscher2000; same result.

more options

Hi Nick2012, your original post doesn't show your extensions. Do you have anything that could force SSL, such as HTTPS Everywhere or a similar privacy protecting extension?

more options

Here's a list of the extensions I currently have installed: Application: Firefox 23.0.1 (20130814063812) Operating System: WINNT (x86-msvc)

- Adobe Acrobat - Create PDF 2.0 - Bamboo Feed Reader 1.8.3 - British English Dictionary 1.19.1 - CookieCuller 1.4 - Download Statusbar 0.9.10 - DownThemAll! 2.0.16 - Element Properties 8 - Extension List Dumper 1.15.2 - FireGestures 1.7.10 - Flagfox 4.2.12 - Forecastfox 2.2.2 - Google Translator for Firefox 2.1.0.3 - Greasemonkey 1.11 - IE Tab + 2.04.20110724 - Image Zoom 0.6.3 - LastPass 2.0.20 - Lightshot (screenshot tool) 3.1.0 - New Tab Homepage 0.4.3 - Omnibar 0.7.19.20130418 - Popup ALT Attribute 2.0.2012122901 - Print Edit 10.0 - QuickDrag 2.1.3.21 - RealPlayer Browser Record Plugin 1.1.4 (Disabled, Incompatible) - Right Encoding 0.2.6 - Search by Image for Google 1.2.0 - Speed Dial 0.9.6.15 - Tab Preview 0.3 - Textarea Cache 0.8.10 - Thumbnail Zoom Plus 2.5 - ViewSourceWith 0.9.4.2 - Yet Another Smooth Scrolling 3.1.7

It does happen sometimes when I run FF in safe mode.

Also, perhaps I should've mentioned this in the first post...it doesn't happen all the time. Some searches work as they should and go to a regular http page but I can't seem to workout what triggers it changing to https which is why I think that perhaps it's Google and not FF that is causing it.

more options

Just tried a fresh profile with no add-ons and the same thing happened.

more options

Hi Nick2012, is this an accurate summary of the problem:

  • The search bar is configured with an HTTP plugin, not HTTPS
  • Some searches deliver an HTTP results page
  • Some searches deliver an HTTPS results page
  • No extensions are installed in this profile
  • Your connection is proxied through Ad Muncher

I noticed a thread on the Ad Muncher support forum (maybe you saw this, too?) indicating other users are running into this as well: Ad Muncher • View topic - Google search forcing https. No turn off option anymore.

more options

Your summary is accurate jscher2000.

I've just read the thread on the Ad Muncher forum and as a result decided to test after closing Ad Muncher. Unfortunately, the same happened.

I can confirm that Jeff's response occasionally works. Clearing out temp files, cookies etc sometimes gets things working again, but only sometimes.

more options

I don't know whether it's practical to keep open over an extended period of time (because it can degrade performance), but you can watch for a redirect in Firefox's Web Console. To do that:

  • open a new tab
  • press Ctrl+Shift+k to open the Web Console (Ctrl+Shift+k)
  • run your search (click the CSS button to hide those from the list as they tend to clutter it)

As shown in the attached screen shots, you can recognize a redirect from the website by a 301 or 302 return code. If you get HTTPS without a redirect, then I would suspect something in Firefox originated the request that way.

more options

One other thought:

Do any of your Greasemonkey userscripts possibly affect your Google connection?

Are you using any of my userscripts for Google? ;-)

more options

Thanks for the continued support jscher2000.

I will try checking the web console tomorrow.

I don't think any of the Greasemonkey scripts are causing the problem as it happens when FF is running in safe mode plus I don't currently have any Google related scripts enabled.

I may check out some of your scripts though!

Cheers.

more options

Create a new profile as a test to check if your current profile is causing the problems.

See "Creating a profile":

If the new profile works then you can transfer some files from an existing profile to the new profile, but be careful not to copy corrupted files.

more options

Hi cor-el, the results of the new profile test are about mid-page: https://support.mozilla.org/en-US/questions/970785#answer-478041

Hi Nick, maybe you can use a new GM userscript to auto-redirect any https://www.google.com/ to http://www.google.com/ (except when you are logged in which probably could be detected by some content in the page)?

more options

I'm pleased to say it hasn't happened at all today (so far!) but if it does I will check the web console.

I wasn't aware such a script existed but I will have a look on userscripts.org. Don't suppose you have a link for the script please jscher2000?

Thank you :)

more options

Hi Nick2012, I was hypothesizing a new script that someone could write. I don't know whether anyone has written one.

more options

Ahhh ok.

It has started to happen again. Have attached a screenshot of the console which shows the behaviour.

  1. 1
  2. 2