X
Tap here to go to the mobile version of the site.

Support Forum

This thread was closed and archived. Please ask a new question if you need help.

Firefox 23 crashes excessively on certain sites?

Posted

I had no issues at all with Firefox 22, but since upgrading to Firefox 23, my browser is becoming unusable. The biggest issue right now is that Firefox 23 crashes excessively when browsing Facebook. Sometimes I can't even fully load the Facebook page without it crashing, but I can almost always make it crash by just scrolling up and down and forcing it to load new content a few times. This happens even in safe mode, and even after following the instructions to reset my preferences.

Sometimes Google searches also crash within seconds of submitting the search, Firefox crashed 3 times in a row while I tried to search for "Chrome" to install it so I'd be able to look at Facebook. It's more inconsistent with Google searches though, where Facebook is just so completely unstable as to be utterly unusable.

I had no issues at all with Firefox 22, but since upgrading to Firefox 23, my browser is becoming unusable. The biggest issue right now is that Firefox 23 crashes excessively when browsing Facebook. Sometimes I can't even fully load the Facebook page without it crashing, but I can almost always make it crash by just scrolling up and down and forcing it to load new content a few times. This happens even in safe mode, and even after following the instructions to reset my preferences. Sometimes Google searches also crash within seconds of submitting the search, Firefox crashed 3 times in a row while I tried to search for "Chrome" to install it so I'd be able to look at Facebook. It's more inconsistent with Google searches though, where Facebook is just so completely unstable as to be utterly unusable.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.8 r800
  • 5.1.20513.0
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.7

Application

  • Firefox 23.0
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:23.0) Gecko/20100101 Firefox/23.0
  • Support URL: http://support.mozilla.org/1/firefox/23.0/WINNT/en-US/

Extensions

  • Adblock Plus 2.3.2 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • NoScript 2.6.7 ({73a6fe31-595d-460b-a920-fcc0f8843232})
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • WOT 20130515 ({a0d7ccb3-214d-498b-b4aa-0e8fda9a7bf7})

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: AMD Radeon HD 6310 Graphics
  • adapterDescription2:
  • adapterDeviceID: 0x9802
  • adapterDeviceID2:
  • adapterDrivers: aticfx64 aticfx64 aticfx64 aticfx32 aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
  • adapterDrivers2:
  • adapterRAM: 384
  • adapterRAM2:
  • adapterVendorID: 0x1002
  • adapterVendorID2:
  • clearTypeParameters: Gamma: 2200 Pixel Structure: RGB ClearType Level: 100 Enhanced Contrast: 50
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'blockedGfxCard']
  • directWriteEnabled: False
  • directWriteVersion: 6.2.9200.16571
  • driverDate: 9-27-2012
  • driverDate2:
  • driverVersion: 9.2.0.0
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'none'}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'blockedGfxCard']
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (AMD Radeon HD 6310 Graphics)
  • windowLayerManagerType: Basic

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.startup.homepage_override.buildID: 20130730113002
  • browser.startup.homepage_override.mstone: 23.0
  • browser.tabs.onTop: False
  • dom.max_chrome_script_run_time: 40
  • dom.max_script_run_time: 40
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 23.0
  • gfx.blacklist.direct2d: 4
  • gfx.blacklist.layers.direct3d9: 4
  • gfx.direct2d.disabled: True
  • gfx.direct3d.last_used_feature_level_idx: 0
  • layers.acceleration.disabled: True
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1375925389
  • places.history.expiration.transient_current_max_pages: 96697
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • plugin.state.java: 0
  • plugin.state.npdeployjava: 0
  • plugin.state.npgeplugin: 0
  • plugin.state.npgoogleupdate: 0
  • plugin.state.nppdf: 2
  • plugin.state.npvlc: 0
  • plugin.state.npwlpg: 0
  • privacy.sanitize.migrateFx3Prefs: True
  • storage.vacuum.last.index: 0
  • storage.vacuum.last.places.sqlite: 1375925378

Misc

  • User JS: No
  • Accessibility: No
Tyler Downer
  • Top 25 Contributor
  • Moderator
1529 solutions 10654 answers

We're sorry to hear that Firefox is crashing. In order to assist you better, please follow the steps below to provide us crash ID's to help us learn more about your crash.

  1. Enter about:crashes in the address bar (that's where you enter your website URL) and press Enter. You should now see a list of submitted crash reports.
  2. Copy the 5 most recent crash ID's that you see in the crash report window and paste them into your response here.

Thank you for your help!

More information and further troubleshooting steps can be found in the Firefox crashes - Troubleshoot, prevent and get help fixing crashes article.

We're sorry to hear that Firefox is crashing. In order to assist you better, please follow the steps below to provide us crash ID's to help us learn more about your crash. #Enter about:crashes in the address bar (that's where you enter your website URL) and press Enter. You should now see a list of submitted crash reports. #Copy the 5 most recent crash ID's that you see in the crash report window and paste them into your response here. Thank you for your help! More information and further troubleshooting steps can be found in the [[Firefox crashes]] article.
firefox_user_60 0 solutions 2 answers

Also experiencing crashes after FF 23 update. Included are the generated crash IDs:

bp-78367bd2-373a-4b08-ab8f-7a2b32130808

e2592ae2-8d45-4658-9da5-9ca200fdf72b

d3442cc9-f2d2-495a-91df-4667add19de3

3f35f241-236e-4e06-92bc-b44e5cf17462

4c2ceeae-d8f9-4797-9001-79f4d54e149d

Also experiencing crashes after FF 23 update. Included are the generated crash IDs: bp-78367bd2-373a-4b08-ab8f-7a2b32130808 e2592ae2-8d45-4658-9da5-9ca200fdf72b d3442cc9-f2d2-495a-91df-4667add19de3 3f35f241-236e-4e06-92bc-b44e5cf17462 4c2ceeae-d8f9-4797-9001-79f4d54e149d

Modified by firefox_user_60

jscher2000
  • Top 10 Contributor
8637 solutions 70650 answers

Hi firefox_user_60, This is some standard guidance that addresses the most common reasons for Flash problems in Firefox. I'm sure you've seen some of it before, but just in case:

(1) Make sure all recorders/downloaders that interact with Flash media are as up-to-date as possible, or disable them.

(2) Disable hardware graphics acceleration in Firefox and in Flash

(A) In Firefox, un-check the box here and restart:

orange Firefox button (or Tools menu) > Options > Advanced > General > "Use hardware acceleration when available"

(B) In Flash, see this support article from Adobe: http://helpx.adobe.com/flash-player/kb/video-playback-issues.html#main_Solve_video_playback_issues

(3) Disable protected mode (Windows Vista/7/8)

See this support article from Adobe under the heading "Last Resort": Adobe Forums: How do I troubleshoot Flash Player's protected mode for Firefox?

Hi firefox_user_60, This is some standard guidance that addresses the most common reasons for Flash problems in Firefox. I'm sure you've seen some of it before, but just in case: (1) Make sure all recorders/downloaders that interact with Flash media are as up-to-date as possible, or disable them. (2) Disable hardware graphics acceleration in Firefox and in Flash (A) In Firefox, un-check the box here and restart: orange Firefox button (or Tools menu) > Options > Advanced > General > "Use hardware acceleration when available" (B) In Flash, see this support article from Adobe: http://helpx.adobe.com/flash-player/kb/video-playback-issues.html#main_Solve_video_playback_issues (3) Disable protected mode (Windows Vista/7/8) See this support article from Adobe under the heading "Last Resort": [http://forums.adobe.com/message/4468493#TemporaryWorkaround Adobe Forums: How do I troubleshoot Flash Player's protected mode for Firefox?]
kobe 441 solutions 5048 answers

That is a flash problem, you may need to disable a RealPlayer Plugin under Firefox button > Addons > Plugins if you dont use it.

In order to remedy the problem, please perform the steps mentioned in these Knowledge Base articles:

Other, more technical information about these issues can be found under these Links:


Please tell us if this helped!

That is a flash problem, you may need to disable a RealPlayer Plugin under Firefox button > Addons > Plugins if you dont use it. In order to remedy the problem, please perform the steps mentioned in these Knowledge Base articles: * [[Fix problems with RealPlayer add-ons]] * [[Flash Plugin - Keep it up to date and troubleshoot problems]] * [[Flash 11.3 crashes]] * [[Flash 11.3 doesn't load video in Firefox]] Other, more technical information about these issues can be found under these Links: * http://forums.adobe.com/thread/1018071?tstart=0 * http://blogs.adobe.com/asset/2012/06/inside-flash-player-protected-mode-for-firefox.html Please tell us if this helped!
firefox_user_60 0 solutions 2 answers

Thanks for your timely responses. I've taken the suggested steps and will post if additional issues develop. Thanks again!!

Thanks for your timely responses. I've taken the suggested steps and will post if additional issues develop. Thanks again!!

Question owner

bp-f911d10e-4c45-4b6e-86a8-63a192130808
bp-53c1ef9c-a571-43a5-970f-4cb752130808
bp-002f1c4d-570b-4556-a6e9-3b5ce2130808
bp-86bdfebd-fc89-4a5f-91a2-1fac92130808
bp-e322fe9a-9008-4e79-b247-0f5ff2130808
<pre><nowiki>bp-f911d10e-4c45-4b6e-86a8-63a192130808 bp-53c1ef9c-a571-43a5-970f-4cb752130808 bp-002f1c4d-570b-4556-a6e9-3b5ce2130808 bp-86bdfebd-fc89-4a5f-91a2-1fac92130808 bp-e322fe9a-9008-4e79-b247-0f5ff2130808</nowiki></pre>

Modified by cor-el

jscher2000
  • Top 10 Contributor
8637 solutions 70650 answers

Hi JaceNV, several of the bugs linked to your crash reports talk about AMD Radeon driver incompatibilities. Could you try disabling Firefox's use of hardware graphics acceleration?

You usually need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.).

orange Firefox button (or Tools menu) > Options > Advanced

On the "General" mini-tab, uncheck the box for "Use hardware acceleration when available"

If you restart Firefox, is the issue resolved (or at least improved)?

Edit: Actually, it appears when you originally posted, hardware acceleration was disabled already. Or you posted from Firefox's Safe Mode. ??

Hi JaceNV, several of the bugs linked to your crash reports talk about AMD Radeon driver incompatibilities. Could you try disabling Firefox's use of hardware graphics acceleration? You usually need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.). orange Firefox button (or Tools menu) > Options > Advanced On the "General" mini-tab, uncheck the box for "Use hardware acceleration when available" If you restart Firefox, is the issue resolved (or at least improved)? ''Edit: Actually, it appears when you originally posted, hardware acceleration was disabled already. Or you posted from Firefox's Safe Mode. ??''

Modified by jscher2000

Question owner

That was one of the first things I tried, since it's caused some issues in the past. No notable change whether on or off.

Edit: I tried a number of things, including safe mode, creating a new profile, etc. The crash is consistent across all these environments.

Edit 2: I do have an AMD Radeon 6310 in this computer, so that could potentially be an issue if the bugs in these reports are commonly caused by that device/driver.

That was one of the first things I tried, since it's caused some issues in the past. No notable change whether on or off. Edit: I tried a number of things, including safe mode, creating a new profile, etc. The crash is consistent across all these environments. Edit 2: I do have an AMD Radeon 6310 in this computer, so that could potentially be an issue if the bugs in these reports are commonly caused by that device/driver.

Modified by JaceNV

jscher2000
  • Top 10 Contributor
8637 solutions 70650 answers

Another advanced rendering feature, not new to Firefox 23, is "Azure." Disabling that requires a visit to about:config:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the Search box above the list, type or paste gfx and pause while the list is filtered

(3) Double-click gfx.content.azure.enabled to toggle its value from true to false.

Another advanced rendering feature, not new to Firefox 23, is "Azure." Disabling that requires a visit to about:config: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter. Click the button promising to be careful. (2) In the Search box above the list, type or paste '''gfx''' and pause while the list is filtered (3) Double-click '''gfx.content.azure.enabled''' to toggle its value from true to false.

Question owner

No change with that switch, crashes just as frequently and quickly.

No change with that switch, crashes just as frequently and quickly.
jscher2000
  • Top 10 Contributor
8637 solutions 70650 answers

Hi JaceNV, do the sites work any better if you disable the Flash plugin? If so, check out the advice above for the other poster.

Hi JaceNV, do the sites work any better if you disable the Flash plugin? If so, check out the advice above for the other poster.
kobe 441 solutions 5048 answers

It seems like there is a top crasher in firefox in computers with the AMD Raedon 6310, it seems, its being worked on.

It seems like there is a top crasher in firefox in computers with the AMD Raedon 6310, it seems, its being worked on. * https://bugzilla.mozilla.org/show_bug.cgi?id=902349
cdstealer 0 solutions 5 answers

I have this too, however, it would appear in my case that it is the "shockwave Flash" plugin that causes my hangs. Disabling this plugin stops any crashes,hangs,slowness etc etc. The obvious caveat is that you cannot access any flash content :( This is on my laptop which runs a Nvidia 300M GFX and Intel Core i7QM.

The version of flash I have is "11.2.202.297"

Or the exact version is 11.2.202.297-r1 (gentoo package)

I'm running Mozilla/5.0 (X11; Linux x86_64; rv:23.0) Gecko/20100101 Firefox/23.0

about:buildconfig

Build Machine

quadfukka

Build platform

target x86_64-pc-linux-gnu

Build tools Compiler Version Compiler flags

x86_64-pc-linux-gnu-gcc gcc version 4.7.3 (Gentoo 4.7.3 p1.0, pie-0.5.5) -Wall -Wpointer-arith -Wdeclaration-after-statement -Werror=return-type -Wtype-limits -Wempty-body -Wsign-compare -Wno-unused -Wcast-align -march=core2 -pipe -mno-avx -std=gnu99 -fgnu89-inline -fno-strict-aliasing -ffunction-sections -fdata-sections -pthread -pipe -DNDEBUG -DTRIMMED -Os -freorder-blocks -fomit-frame-pointer

x86_64-pc-linux-gnu-g++ gcc version 4.7.3 (Gentoo 4.7.3 p1.0, pie-0.5.5) -Wall -Wpointer-arith -Woverloaded-virtual -Werror=return-type -Wtype-limits -Wempty-body -Wsign-compare -Wno-invalid-offsetof -Wcast-align -march=core2 -pipe -mno-avx -fno-exceptions -fno-strict-aliasing -fno-rtti -ffunction-sections -fdata-sections -fno-exceptions -std=gnu++0x -pthread -pipe -DNDEBUG -DTRIMMED -Os -freorder-blocks -fomit-frame-pointer

Configure arguments

--enable-application=browser --enable-optimize --with-system-jpeg --with-system-zlib --enable-pango --enable-system-cairo --disable-pedantic --disable-updater --disable-strip --disable-install-strip --disable-profilelocking --enable-default-toolkit=cairo-gtk2 --enable-official-branding --enable-dbus --disable-debug --disable-tests --disable-debug-symbols --enable-startup-notification --disable-system-sqlite --enable-necko-wifi --enable-ogg --enable-wave --with-system-libvpx --with-system-nspr --with-nspr-prefix=/usr --with-system-nss --with-nss-prefix=/usr --x-includes=/usr/include --x-libraries=/usr/lib64 --with-system-libevent=/usr --enable-system-hunspell --disable-gnomevfs --disable-gnomeui --enable-gio --disable-crashreporter --enable-jemalloc --enable-replace-malloc --prefix=/usr --libdir=/usr/lib64 --disable-gconf --disable-mailnews --with-system-png --enable-system-ffi --with-default-mozilla-five-home=/usr/lib64/firefox --target=x86_64-pc-linux-gnu --build=x86_64-pc-linux-gnu --disable-gstreamer --enable-pulseaudio --disable-system-sqlite --without-system-jpeg --enable-methodjit --enable-tracejit --enable-ion --disable-system-cairo --enable-extensions=default

I have this too, however, it would appear in my case that it is the "shockwave Flash" plugin that causes my hangs. Disabling this plugin stops any crashes,hangs,slowness etc etc. The obvious caveat is that you cannot access any flash content :( This is on my laptop which runs a Nvidia 300M GFX and Intel Core i7QM. The version of flash I have is "11.2.202.297" Or the exact version is 11.2.202.297-r1 (gentoo package) I'm running Mozilla/5.0 (X11; Linux x86_64; rv:23.0) Gecko/20100101 Firefox/23.0 about:buildconfig Build Machine quadfukka Build platform target x86_64-pc-linux-gnu Build tools Compiler Version Compiler flags x86_64-pc-linux-gnu-gcc gcc version 4.7.3 (Gentoo 4.7.3 p1.0, pie-0.5.5) -Wall -Wpointer-arith -Wdeclaration-after-statement -Werror=return-type -Wtype-limits -Wempty-body -Wsign-compare -Wno-unused -Wcast-align -march=core2 -pipe -mno-avx -std=gnu99 -fgnu89-inline -fno-strict-aliasing -ffunction-sections -fdata-sections -pthread -pipe -DNDEBUG -DTRIMMED -Os -freorder-blocks -fomit-frame-pointer x86_64-pc-linux-gnu-g++ gcc version 4.7.3 (Gentoo 4.7.3 p1.0, pie-0.5.5) -Wall -Wpointer-arith -Woverloaded-virtual -Werror=return-type -Wtype-limits -Wempty-body -Wsign-compare -Wno-invalid-offsetof -Wcast-align -march=core2 -pipe -mno-avx -fno-exceptions -fno-strict-aliasing -fno-rtti -ffunction-sections -fdata-sections -fno-exceptions -std=gnu++0x -pthread -pipe -DNDEBUG -DTRIMMED -Os -freorder-blocks -fomit-frame-pointer Configure arguments --enable-application=browser --enable-optimize --with-system-jpeg --with-system-zlib --enable-pango --enable-system-cairo --disable-pedantic --disable-updater --disable-strip --disable-install-strip --disable-profilelocking --enable-default-toolkit=cairo-gtk2 --enable-official-branding --enable-dbus --disable-debug --disable-tests --disable-debug-symbols --enable-startup-notification --disable-system-sqlite --enable-necko-wifi --enable-ogg --enable-wave --with-system-libvpx --with-system-nspr --with-nspr-prefix=/usr --with-system-nss --with-nss-prefix=/usr --x-includes=/usr/include --x-libraries=/usr/lib64 --with-system-libevent=/usr --enable-system-hunspell --disable-gnomevfs --disable-gnomeui --enable-gio --disable-crashreporter --enable-jemalloc --enable-replace-malloc --prefix=/usr --libdir=/usr/lib64 --disable-gconf --disable-mailnews --with-system-png --enable-system-ffi --with-default-mozilla-five-home=/usr/lib64/firefox --target=x86_64-pc-linux-gnu --build=x86_64-pc-linux-gnu --disable-gstreamer --enable-pulseaudio --disable-system-sqlite --without-system-jpeg --enable-methodjit --enable-tracejit --enable-ion --disable-system-cairo --enable-extensions=default

Modified by cdstealer

cor-el
  • Top 10 Contributor
  • Moderator
17416 solutions 157344 answers

Hi cdstealer

Does it make a difference if you you use a 32 bit Firefox version and a 32 bit Flash player (assuming that you currently use 64 bit versions)?

Hi cdstealer Does it make a difference if you you use a 32 bit Firefox version and a 32 bit Flash player (assuming that you currently use 64 bit versions)?
cdstealer 0 solutions 5 answers

Hi Cor-el, Fired up the old Windows XP (32bit) VM, updated firefox to v23 and flash to v11.8.800.94 and that seems to be ok. I don't have a 32bit Linux install to test. But obviously the big difference here is the flash version.

You can find the flash archive here

I've tried several older versions of flash and all give the same results :( I'm just rolling back to firefox-22.0.

  • edit* any version of flash on 22.0 works OK.

Cheers Steve

Hi Cor-el, Fired up the old Windows XP (32bit) VM, updated firefox to v23 and flash to v11.8.800.94 and that seems to be ok. I don't have a 32bit Linux install to test. But obviously the big difference here is the flash version. You can find the flash archive [http://helpx.adobe.com/flash-player/kb/archived-flash-player-versions.html here] I've tried several older versions of flash and all give the same results :( I'm just rolling back to firefox-22.0. *edit* any version of flash on 22.0 works OK. Cheers Steve

Modified by cdstealer

JanetteDavie 0 solutions 8 answers

Also having browser crashes since Firefox 23 went on my xp machine. I do not have real player on my machine. I run malware bytes and slim cleaner regularly and have good virus/firewall protection. Windows service pack 3 has been on the machine since Microsoft first released that patch.

Last time google earth updated, a lot of us xp users had problems and jumped through hoops. Turned out it WAS google earth problem with xp. Are we safe in guessing that new versions of firefox will also be unstable on our xp machines? Fess up, this many of us with same problems is likely a buy in the browser update when combined with and xp machine.

Also having browser crashes since Firefox 23 went on my xp machine. I do not have real player on my machine. I run malware bytes and slim cleaner regularly and have good virus/firewall protection. Windows service pack 3 has been on the machine since Microsoft first released that patch. Last time google earth updated, a lot of us xp users had problems and jumped through hoops. Turned out it WAS google earth problem with xp. Are we safe in guessing that new versions of firefox will also be unstable on our xp machines? Fess up, this many of us with same problems is likely a buy in the browser update when combined with and xp machine.
jscher2000
  • Top 10 Contributor
8637 solutions 70650 answers

Hi JanetteDavie, can you start a new question and list some of your crash IDs? This allows forum volunteers to view the crash data on Mozilla's crash stats server and see whether there is an obvious cause. Doesn't always work, but often more effective than playing "20 questions."

Hi JanetteDavie, can you start a new question and list some of your crash IDs? This allows forum volunteers to view the crash data on Mozilla's crash stats server and see whether there is an obvious cause. Doesn't always work, but often more effective than playing "20 questions." * Info on how to get the crash IDs: [[Firefox crashes - Troubleshoot, prevent and get help fixing crashes]] * Link for starting a new thread: https://support.mozilla.org/questions/new/desktop/fix-problems
KCFireMike 0 solutions 2 answers

Helpful Reply

The latest version (Firefox 23) has multiple issues for Windows, the Flash Player crashes every 5 minutes.

The latest version (Firefox 23) has multiple issues for Windows, the Flash Player crashes every 5 minutes.
jscher2000
  • Top 10 Contributor
8637 solutions 70650 answers

Hi kcfiremike, can you work down the comments from the top of this thread regarding standard Flash fixes and posting your crash IDs? For more personalized assistance, start your own question. Here's the link:

https://support.mozilla.org/questions/new/desktop/fix-problems

Hi kcfiremike, can you work down the comments from the top of this thread regarding standard Flash fixes and posting your crash IDs? For more personalized assistance, start your own question. Here's the link: https://support.mozilla.org/questions/new/desktop/fix-problems
pontiaku 0 solutions 1 answers

I suggest running combofix just for good measure. Both my desktop and laptop were infected with something. I kept crashing and getting "302 moved the document has moved here" errors when I tried to load webpages. No idea what the infection was yet or how I got it.

I suggest running combofix just for good measure. Both my desktop and laptop were infected with something. I kept crashing and getting "302 moved the document has moved here" errors when I tried to load webpages. No idea what the infection was yet or how I got it.