X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

This thread was closed and archived. Please ask a new question if you need help.

how do I stop firefox from checking compatability of addons and loading of hooray u updated firefox tab

Posted

firefox opens two tabs, hooray you updated firefox and my home page. Before firefox loads it checks my addons to see if they are compatible with new update. This happens every time I start firefox.

Modified by jgdc

Chosen solution

Hi keimanzero, in response to cor-el's suggestions in https://support.mozilla.org/en-US/questions/967218#answer-480480 you said you could not run Firefox.

You do not need to run Firefox to open your profile folder (settings folder) and rename or delete those files.

To jump to that folder, paste this in the Start menu search box and press Enter:

%APPDATA%\Mozilla\Firefox\Profiles

This should launch the folder in a new window. Then if you see multiple profile folders, click into the most recent one. Here you should find the prefs.js and user.js files that cor-el mentioned. Any luck?

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Next Generation Java Plug-in 10.25.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 11.7 r700
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.7
  • VLC media player Web Plugin 2.0.6
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin

Application

  • Firefox 23.0
  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:23.0) Gecko/20100101 Firefox/23.0
  • Support URL: http://support.mozilla.org/1/firefox/23.0/WINNT/en-US/

Extensions

  • Advanced SystemCare Surfing Protection 1.0 (ascsurfingprotection@iobit.com)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Microsoft .NET Framework Assistant 0.0.0 ({20a82645-c095-46ed-80e3-08825760534b}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: RADEON 9200 SERIES
  • adapterDescription2:
  • adapterDeviceID: 0x5961
  • adapterDeviceID2:
  • adapterDrivers: ati2dvag
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterVendorID: 0x1002
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'tryNewerDriver', u'10.6']
  • directWriteEnabled: False
  • directWriteVersion: 0.0.0.0
  • driverDate: 5-3-2006
  • driverDate2:
  • driverVersion: 8.252.0.0
  • driverVersion2:
  • info: {u'AzureContentBackend': u'none', u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo'}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'tryNewerDriver', u'9.6']
  • numTotalWindows: 1
  • webglRendererMessage: [u'tryNewerDriver', u'9.6']
  • windowLayerManagerType: Basic

Modified Preferences

  • accessibility.typeaheadfind: True
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.cache.memory.capacity: 16000
  • browser.display.show_image_placeholders: True
  • browser.places.smartBookmarksVersion: 4
  • browser.startup.homepage_override.buildID: 20130730113002
  • browser.startup.homepage_override.mstone: 23.0
  • browser.urlbar.autocomplete.enabled: True
  • browser.urlbar.autofill: True
  • dom.disable_window_status_change: True
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 23.0
  • network.cookie.prefsMigrated: True
  • network.http.max-connections: 48
  • network.http.max-connections-per-server: 16
  • network.http.max-persistent-connections-per-proxy: 16
  • network.http.max-persistent-connections-per-server: 8
  • network.http.pipelining: True
  • network.http.pipelining.maxrequests: 8
  • network.http.proxy.pipelining: True
  • network.http.request.max-start-delay: 0
  • places.database.lastMaintenance: 1375894560
  • places.history.expiration.transient_current_max_pages: 13376
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.expose_full_path: True
  • plugin.importedState: True
  • privacy.cpd.offlineApps: True
  • privacy.cpd.siteSettings: True
  • privacy.donottrackheader.enabled: True
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.timeSpan: 3
  • security.warn_viewing_mixed: False
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1366132255

Misc

  • User JS: Yes
  • Accessibility: No
Tyler Downer
  • Administrator
  • Moderator
1165 solutions 6641 answers

Hello,

The Reset Firefox feature can fix many issues by restoring Firefox to its factory default state while saving your essential information. Note: This will cause you to lose any Extensions, Open websites, and some Preferences.

To Reset Firefox do the following:

  1. Go to Firefox > Help > Troubleshooting Information.
  2. Click the "Reset Firefox" button.
  3. Firefox will close and reset. After Firefox is done, it will show a window with the information that is imported. Click Finish.
  4. Firefox will open with all factory defaults applied.

Further information can be found in the Reset Firefox – easily fix most problems article.

Did this fix your problems? Please report back to us!

Thank you.

Helpful Reply

yes it seems to have fixed the problem . thank you Tylerdowner . only thing my add ons don't seem to be working so do i have to down load them again or are they hiding some where waiting for me to turn them back on

Tyler Downer
  • Administrator
  • Moderator
1165 solutions 6641 answers

Helpful Reply

Yes you will need to reinstall your add-ons.

Jack McElwee 0 solutions 16 answers

I have a desktop PC so whoop de do I'm strange, right? It's an HP Pavilion p6330f Windows 7 Home Premium w/ dual Pentium processors.

I just uninstalled ALL of the Mozilla Firefox software and I even removed the downloads. Then I downloaded the newest Foxy 24 sw and installed it.

Instead of launching like it promised with blazing speed (How many times has Foxy promised me that eh?) all it did was check the addons for compatibility with this Foxy version.

I am cool w/ that crap except that I don't have any addons! So how do I tell Stupid Foxy to stop it and open the blasted browser?

I do online surveys to make a living and I need Firefox, Google Chrome or IE for most of them. Now I use Opera and Maxthon but I was advised that I needed Foxy's latest fiasco! Help me please? TYVM I hope- Jack/keimanzero keiman0@yahoo.com

Jack McElwee 0 solutions 16 answers

Sorry but I should have mentioned that I am unable to use Foxy troubleshooters because w/o Foxy I cannot get to that TS page, can I?-Jack

cor-el
  • Top 10 Contributor
  • Moderator
10756 solutions 96801 answers

You can check for problems with preferences in cases like this.

Rename or delete the prefs.js file and possible numbered prefs-##.js files and a possible user.js file to reset all prefs to the default value.

You may also have to delete the compatibility.ini file.


See these articles for some suggestions:

Firefox supports multiple home pages separated by '|' (pipe) symbols.

  • Tools > Options > General > Startup: Home page
Jack McElwee 0 solutions 16 answers

I thank you all for the help but I cannot use any of it darn it. Why you ask? Because I cannot get into the Firefox browser! It DLs, installs and then when it is supposed to 'launch with blazing speed' it simply decides to check the addons for compatibility even though I have no addons and no previous Firefox versions. This happens with 16 to 24 versions of Foxy, 24 being the latest. It ran compatibility tests for 72 straight hours, 3 whole days, before I called it quits. I don't want all the frills. I just want a working Firefox browser so I can access my online surveys that require Foxy, Chrome (YUCK) or IE9 or IE10 neither of which work on my PC. Chrome Aw Shucks me to death and IE9 simply crashes Henrietta. The last time I tried Foxy 24 was last night when it turned off my internet connection. I had to call Comcast to get it back on. Comcast informed me that they are not blocking any browsers either so forget that copout, Firefox! Can anyone help at all even a little? I am at my wit's end and w/o surveys I starve! Thanks I hope- Jack/keimanzero Campbelltown PA

cor-el
  • Top 10 Contributor
  • Moderator
10756 solutions 96801 answers

Can you bring up the Profile Manager to create a new profile?

You can also try to rename the profiles.ini file to get Firefox to create a new default profile.

Jack McElwee 0 solutions 16 answers

No I cannot get Firefox to come up at all. Since noon it's been checking for those darned old addons! I even went back to Foxy 23 when I found out 24 were all Betas! No luck at all. Later- Jack

jscher2000
  • Top 10 Contributor
2365 solutions 20923 answers

Chosen Solution

Hi keimanzero, in response to cor-el's suggestions in https://support.mozilla.org/en-US/questions/967218#answer-480480 you said you could not run Firefox.

You do not need to run Firefox to open your profile folder (settings folder) and rename or delete those files.

To jump to that folder, paste this in the Start menu search box and press Enter:

%APPDATA%\Mozilla\Firefox\Profiles

This should launch the folder in a new window. Then if you see multiple profile folders, click into the most recent one. Here you should find the prefs.js and user.js files that cor-el mentioned. Any luck?

Jack McElwee 0 solutions 16 answers

I already thought of that and tried i. I got nothing but gibberish.

Jack McElwee 0 solutions 16 answers

I already thought of that and tried i. I got nothing but gibberish.

Jack McElwee 0 solutions 16 answers

I am giving up on Foxy! Now it's still checking for nonexistent addons after 5 bloody days! It crashes Henrietta every few minutes and just HATES me! I am getting rid of every single instance of this piece of crap! Goodbye maybe for the last time?

[Personal attacks removed by moderator. Please read Forum rules and guidelines, thanks.]

Modified by Chris Ilias

jscher2000
  • Top 10 Contributor
2365 solutions 20923 answers

Hi keimanzero, you wrote:

I already thought of that and tried i. I got nothing but gibberish.

I don't understand what you mean here, since the goal of viewing the folder was just to go down the list of files and delete some of them. ??

Also, since the problem could be that your Firefox can't access the internet, you might review the following articles:

Hopefully you'll reconsider the extremely unkind sentiments in your last post. Those are real humans you're talking about, and Firefox is just a piece of software.

Question owner

to everyone answering this please be advised that my problem has been solved and everything is working just fine now .thanks to all that have offered to help. So you all can stop sending me emails

Modified by jgdc