Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Amazon MP3 samples don't play

  • 13 replies
  • 11 have this problem
  • 3740 views
  • Last reply by Dave71

more options

When attempting to play a MP3 'sample' on Amazon.com i get the Amazon message "error." When I go to the Amazon.com site that features an album and attempt to play a sample I get the Amazon message of "unavailable." I called Amazon and deleted all my cookies, rebooted my router and still nothing. By the way I can play MP3 samples with Google Chrome. Any help out there? Thanks.

Chosen solution

I was having the same issue. I use the "https everywhere" add on. Disabling it for the Amazon sites fixed this issue for me.

Read this answer in context 👍 7

All Replies (13)

more options

If you use extensions (Firefox/Tools > Add-ons > Extensions) that can block content (e.g. Adblock Plus, NoScript, Flash Block, Ghostery) then make sure that such extensions aren't blocking content.

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window.
more options

I disabled AdBlock and did the Safe Mode drill. (DEFAULT theme was already selected.) Thank you but no joy. In FireFox options>applications is there an 'idea' application for playing MP3s? (Amazon.com MP3s play automatically without selecting an application to play the MP3.)

more options

You can set the Boolean pref media.windows-media-foundation.enabled to false on the about:config page to disable the built-in HTML5 media player.

more options

I cannot access <about:config> from FF address bar. Where else may I access <about:config>?

more options

I found <about:config> and changed to <false>. No joy. Changed back to <true>.

Modified by Dave71

more options

Try to disable all unneeded plugins to see if that helps (I see an Amazon MP3 Downloader Plugin 1.0.17).

more options

I disabled all of my plug-ins and the Amazon sampler still doesn't work. Still no joy. (If I want to 'sample' I open the page in IE and it works fine.)

What would happen if I deleted FF and reinstalled it? Would I loose bookmarks, etc.?)

more options

Clear the cache and the cookies from websites that cause problems.

"Clear the Cache":

  • Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Firefox/Tools > Options > Privacy > Cookies: "Show Cookies"
more options

No joy. Thank you cor-el. I called Amazon.com MP3 help and they are forwarding the problem to their tech people. Not sure how they can suggest a fix for a FF issue but I appreciate their help. Would be nice if Mozilla had a call in feature so that someone could actually talk to a tech-type. I do have a work-around in that I can open the FF page in IE and play MP3 without any problem. But I don't like work-arounds. I like software that works the way that it was intended to work. Thanks again cor-el. If something else comes to mind let me know. Dave71

more options

I have exactly the same problem, using Firefox 23.0 with Windows 7. Have never had this problem before with Firefox and Amazon, and the mp3 samples still play with IE, which I prefer not to use. I have tried numerous mp3 samples (many of which I have previously listened to before downloading) and now get one of two messages: "error 3" or "unavailable." I have called Amazon support and the person with whom I spoke was not able to figure out the problem but escalated it to a higher tech level. I am waiting to hear if they can resolve it.

more options

It's like looking into a mirror. Same set up and same experiences. I don't see that either FF or Amazon are doing squat. I can do a 'work around' which is simple enough using IE (which I too detest) conversion of the FF page. But being who I am I like software to do what it is intended to do. I also like IT people to resolve problems (hint! hint!) rather than devise new gimmicky do-dads that 95% of us could care less about (unless they improve security without unduly encumbering the user).

more options

Chosen Solution

I was having the same issue. I use the "https everywhere" add on. Disabling it for the Amazon sites fixed this issue for me.

more options

BEAUTIFUL! You solved the problem! Thank you! Why 'the pros' didn't solve this problem immediately is ... interesting.