X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Using a mac OSX and a logitech M-UAG120 mouse, how do I use the wheel button to open a link in a new tab (but not switch to it)? Can't type a key in box.

Posted

In the logitech control center I've clicked on my mouse (tilt wheel mouse), clicked on 'wheel button', and in the dropdown menu selected keystroke. Under 'configure keystroke', there's a "type a key..." box, and to the right, there's a "choose any modifier" selection.

On this web page, http://www.accessfirefox.org/Firefox_Keyboard_and_Mouse_Shortcuts.html, the instruction for 'open link in new tab' is Cmd+Return Cmd+Click

On this page, https://support.mozilla.org/en-US/kb/mouse-shortcuts-perform-common-tasks, the instruction for 'open link in new tab' is command+Left-click link   Middle-click link 

I cannot figure out how to type these in correctly to make the function work.

 Help please?
 Thank you all.

Chosen solution

Hello again!

You may want to forward the issue to the Logitech customer support and otherwise reinstall the Logitech software again or reset the driver software to factory defaults, since I am not sure anymore that the problem resides within the web browser itself.

If all above fails, try and see if you can get the mouse to work propely on other computers running the same version of Mozilla Firefox.

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • DivX VOD Helper Plug-in
  • DivX Plus Web Player version 2.3.0.87
  • RealPlayer Plugin
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • Shockwave Flash 10.3 r183
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • 4.0.60531.0
  • npmnqmp 071503000004
  • iPhoto6

Application

  • Firefox 16.0.2
  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.5; rv:16.0) Gecko/20100101 Firefox/16.0
  • Support URL: http://support.mozilla.org/1/firefox/16.0.2/Darwin/en-US/

Extensions

  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • DivX Plus Web Player HTML5 <video> 2.1.2.172 ({23fcfd51-4958-4f00-80a3-ae97e717ed8b}) (Inactive)
  • Screengrab 0.96.3 ({02450954-cdd9-410f-b1da-db804e18c671}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription:
  • adapterDeviceID: 0x9583
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: 0x1002
  • driverDate:
  • driverVersion:
  • info: {u'AzureBackend': u'quartz'}
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 1
  • webglRendererMessage: [u'blockedOSVersion']
  • windowLayerManagerType: Basic

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 1048576
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size_cached_value: 1048576
  • browser.history_expire_days.mirror: 180
  • browser.history_expire_days_min: 2
  • browser.places.importBookmarksHTML: False
  • browser.places.importDefaults: False
  • browser.places.leftPaneFolderId: -1
  • browser.places.migratePostDataAnnotations: False
  • browser.places.smartBookmarksVersion: 4
  • browser.places.updateRecentTagsUri: False
  • browser.startup.homepage: http://us.mg4.mail.yahoo.com/dc/launch
  • browser.startup.homepage_override.buildID: 20121024073032
  • browser.startup.homepage_override.mstone: 16.0.2
  • browser.tabs.autoHide: True
  • browser.urlbar.autocomplete.enabled: False
  • dom.storage.enabled: False
  • extensions.lastAppVersion: 16.0.2
  • gfx.blacklist.direct2d: 3
  • gfx.blacklist.layers.direct3d9: 3
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1374585690
  • places.history.expiration.transient_current_max_pages: 104858
  • places.history.expiration.transient_optimal_database_size: 167772160
  • places.last_vacuum: 1300143979
  • plugin.disable_full_page_plugin_for_types: video/quicktime,video/x-ms-wmv,image/jp2,video/mp4,video/mpeg,audio/x-mpegurl,video/msvideo
  • privacy.clearOnShutdown.sessions: False
  • privacy.cpd.offlineApps: True
  • privacy.cpd.sessions: False
  • privacy.cpd.siteSettings: True
  • privacy.donottrackheader.enabled: True
  • privacy.item.cookies: True
  • privacy.item.sessions: False
  • privacy.popups.showBrowserMessage: False
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.timeSpan: 0
  • security.warn_viewing_mixed: False

Misc

  • User JS: No
  • Accessibility: No
Tristan C. 11 solutions 109 answers

Hello, jusara.

I'm sorry to hear you've been experiencing issues with opening new tabs on Firefox and apologize for the wait time you had to go through.

Luckily, I think I may have found a solution to your problem! First, go to Edit -> Preferences -> Tabs and make sure that the When I open a link, switch to it immediately option case is not checked.

This should normally make your browser open new tabs and not switch to them immediately, whether you open the new links with the scrolling wheel button, or any key shortcut.


Should this answer have resolved your current issue, please mark it as such or let us know the result in a comment reply and we will be glad to assist you further.

Thank you for all your interest in Mozilla and have a wonderful day!

cor-el
  • Top 10 Contributor
  • Moderator
10739 solutions 96651 answers

If you choose the standard setting for clicking with the mouse wheel then Firefox should work properly with clicking the mouse wheel.
There is no need to set special keyboard or click action.

Question owner

Thank you for the response. I took a look, and that box is not checked. It must be something else.

Question owner

I do not know what the standard setting is. In my Mac system preferences, when I access the Logitech Control Center, I click on "wheel button" (button 3), and get a drop down menu with the following choices:

Nothing
Click
Advanced Click
Cruise
Horizontal Scroll
Keystroke
Modifiers
Open Application
Open Document
Open Folder
Open Web Page
Back
Forward
Cover Flow
Display Control
Eject CD
End Session
Expose' Dashboard & Spaces
One-Touch Search
Quick Look
Screen Capture
Sound Control
Switch Application
Zoom

I'm lost here. The mouse used to do it, then I needed to unplug it, and when I set it up again, the wheel button is inert when used on a link.

Modified by cor-el

Tristan C. 11 solutions 109 answers

Hello again, jusara.

I'm sorry again you haven't been able to resolve the issue just yet. From the new information you have just provided, it sounds to me like the problem would be tied to the driver software managing your mouse and not Firefox itself.

You may want to try to set your wheel button (button 3) to Click and Advanced Click and see how that goes.

As always, please let us know how it all goes as we will be waiting for your verdict.

Question owner

I have tried this, and when I use the wheel button to click on a link, absolutely nothing happens. I've also downloaded the software for the mouse and re-installed it- still nothing. Perhaps I should just get a different mouse.

Tristan C. 11 solutions 109 answers

Chosen Solution

Hello again!

You may want to forward the issue to the Logitech customer support and otherwise reinstall the Logitech software again or reset the driver software to factory defaults, since I am not sure anymore that the problem resides within the web browser itself.

If all above fails, try and see if you can get the mouse to work propely on other computers running the same version of Mozilla Firefox.

Question owner

I finally figured it out!!!

Re-loaded the logitech software (unnecessarily), and on the wheel button chose advanced click.  Below, under 'configure advanced click', I chose triple click, and in the modifier selection, chose the 'command' option.  Of course the button number was 3.  Don't know if the modifier selection was necessary- but I'm not going to test it and perhaps mess it up again.
 Thanks again!