X
Tap here to go to the mobile version of the site.

Support Forum

Magnet links no longer open in Transmission

Posted

Dear good support folk,

I'm running Firefox 22.0 on Xubuntu Linux 11.10. I used to have Firefox open magnet links in my Transmission client but something has happened; I don't know what. I've tried the normal stuff of going into the preferences -> applications and resetting content type "magnet" to /usr/bin/transmission-gtk but it doesn't seem to take. I'm selecting "use other", I get a dialog saying "Select Helper Application", I browse to transmission, select it, click "Open" and the Action for magnet still says "Use other". If I hit close to the preferences and open it again, magnet says "Always ask". In reality, its not even doing that. When I click on a magnet link, nothing happens at all. It draws a dotted box around the icon so I know I've clicked on it but there's no action happens.

I'm not sure where to go from here so I'd appreciate any help you enlightened folk can offer. I'm happy to answer any questions I can. Thanks in advance.

Dear good support folk, I'm running Firefox 22.0 on Xubuntu Linux 11.10. I used to have Firefox open magnet links in my Transmission client but something has happened; I don't know what. I've tried the normal stuff of going into the preferences -> applications and resetting content type "magnet" to /usr/bin/transmission-gtk but it doesn't seem to take. I'm selecting "use other", I get a dialog saying "Select Helper Application", I browse to transmission, select it, click "Open" and the Action for magnet still says "Use other". If I hit close to the preferences and open it again, magnet says "Always ask". In reality, its not even doing that. When I click on a magnet link, nothing happens at all. It draws a dotted box around the icon so I know I've clicked on it but there's no action happens. I'm not sure where to go from here so I'd appreciate any help you enlightened folk can offer. I'm happy to answer any questions I can. Thanks in advance.

Chosen solution

In summing up, the solution that worked for this problem, as inspired by Waka, was to reset Firefox by going to the help menu and selecting "Restart with Add-ons Disabled" and then selecting the reset option in the dialog box. The next time I clicked a magnet link, Firefox promped me for the application to use and I was able to select it. Firefox is now functioning within normal parameters.

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.2 r202

Application

  • Firefox 22.0
  • User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:22.0) Gecko/20100101 Firefox/22.0
  • Support URL: http://support.mozilla.org/1/firefox/22.0/Linux/en-US/

Extensions

  • Firebug 1.11.4 (firebug@software.joehewitt.com)
  • FireFTP 2.0.16 ({a7c6cf7f-112c-4500-a7ea-39801a327e5f})
  • FireFTP button 1.1.1d ({9BAE5926-8513-417d-8E47-774955A7C60D})
  • FlashGot 1.5.5.5 ({19503e42-ca3c-4c27-b1e2-9cdb2170ee34})
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Ubuntu Firefox Modifications 2.6 (ubufox@ubuntu.com)
  • Download Scheduler 1.7.5 (dlScheduler@ext.net) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: NVIDIA Corporation -- GeForce 8400 GS/PCIe/SSE2
  • adapterDeviceID: GeForce 8400 GS/PCIe/SSE2
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: NVIDIA Corporation
  • driverDate:
  • driverVersion: 3.3.0 NVIDIA 304.88
  • info: {u'AzureCanvasBackend': u'cairo', u'AzureFallbackCanvasBackend': u'none', u'AzureContentBackend': u'none'}
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 6
  • webglRenderer: NVIDIA Corporation -- GeForce 8400 GS/PCIe/SSE2
  • windowLayerManagerType: Basic

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.startup.homepage: https://mail.google.com/mail/?shva=1#inbox
  • browser.startup.homepage_override.buildID: 20130627185035
  • browser.startup.homepage_override.mstone: 22.0
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 22.0
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1374657645
  • places.history.expiration.transient_current_max_pages: 103682
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • privacy.sanitize.migrateFx3Prefs: True
  • security.warn_viewing_mixed: False
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1373529731

Misc

  • User JS: No
  • Accessibility: No
Waka_Flocka_Flame 441 solutions 5048 answers

Helpful Reply

Have you used the "Applications" options in the options menu?

Also note that you may want upgrade Xubuntu as support for 11.10 ended in April.

Have you used the "Applications" options in the options menu? * [[Set how Firefox handles different types of files]] Also note that you may want upgrade Xubuntu as support for 11.10 ended in April.

Question owner

Yep, that's what I was doing, setting the Action in the Applications tab of the Firefox Preferences. Not sure about an options menu though. I'm not aware of one.

Yep, that's what I was doing, setting the Action in the Applications tab of the Firefox Preferences. Not sure about an options menu though. I'm not aware of one.
Waka_Flocka_Flame 441 solutions 5048 answers

you can also try firefox in safe mode

you can also try firefox in safe mode *[[Troubleshoot Firefox issues using Safe Mode]]

Question owner

G'day Waka,

Thanks for persevering. I tried restarting in safe mode but was unable to change the behaviour. I even went back into the Application settings and tried setting magnet to transmission-gtk again and the behaviour was exactly as i reported originally.

I wasn't aware there was a reset option though (guess I never looked around enough in the help menu) and I thought I'd try that. As it happened, it worked perfectly. Clicking on a magnet link resulted in Firefox prompting me for an application to use for opening this kind of link. I was able to browse to the application and set it so that magnet links always open in Transmission. Firefox is now working as it should.

I credit you with the suggestion that allowed me to find the path to the right solution so I tip my hat to you Sir. Thanks very much.

Best Regards.

M@.

G'day Waka, Thanks for persevering. I tried restarting in safe mode but was unable to change the behaviour. I even went back into the Application settings and tried setting magnet to transmission-gtk again and the behaviour was exactly as i reported originally. I wasn't aware there was a reset option though (guess I never looked around enough in the help menu) and I thought I'd try that. As it happened, it worked perfectly. Clicking on a magnet link resulted in Firefox prompting me for an application to use for opening this kind of link. I was able to browse to the application and set it so that magnet links always open in Transmission. Firefox is now working as it should. I credit you with the suggestion that allowed me to find the path to the right solution so I tip my hat to you Sir. Thanks very much. Best Regards. M@.

Chosen Solution

In summing up, the solution that worked for this problem, as inspired by Waka, was to reset Firefox by going to the help menu and selecting "Restart with Add-ons Disabled" and then selecting the reset option in the dialog box. The next time I clicked a magnet link, Firefox promped me for the application to use and I was able to select it. Firefox is now functioning within normal parameters.

In summing up, the solution that worked for this problem, as inspired by Waka, was to reset Firefox by going to the help menu and selecting "Restart with Add-ons Disabled" and then selecting the reset option in the dialog box. The next time I clicked a magnet link, Firefox promped me for the application to use and I was able to select it. Firefox is now functioning within normal parameters.

Modified by Funkmother