X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

ShockWave Flash crashing on Firefox 22.0

Posted

Hello, I just switched to Firefox because Google Chrome was loading very slow. Firefox is faster and I thought my problems were over...well now when I try to watch videos on youtube they lag like crazy and sometimes I get a message saying something about Shockwave crashing. I mean seriously what is wrong with these browsers cant they just do what I want them to without any issues? Please help me because this is frustrating. Here is the clipboard info from troubleshoot.

Chosen solution

OK - I reset my folders to show extensions on all files, renamed the old one to mms2.cfg and then fixed the doctored one to mms.cfg and at least for now that seems to have done the trick - the video I just put on has been playing with only the occasional hiccup. Not perfect but a lot better. Thank you!

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.8 r800
  • Next Generation Java Plug-in 10.25.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Google Update
  • 5.1.20513.0
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.03
  • iTunes Detector Plug-in
  • npsitesafety
  • EMusic Plugin
  • Pando Web Plugin
  • Amazon MP3 Downloader Plugin 1.0.17
  • CANON iMAGE GATEWAY Album Plugin Utility Module for IJ
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • NPWLPG

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20100101 Firefox/22.0

More Information

Application Basics
Name
Firefox
Version
22.0
User Agent
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20100101 Firefox/22.0
Build Configuration
about:buildconfig
Extensions
Name
Version
Enabled
ID
avast! Online Security
8.0.1489
true
wrc@avast.com
Gmail panel
1.0.7
true
gmail_panel@alejandrobrizuela.com.ar
General Crawler
2.6
false
gencrawler@some.com
Logitech SetPoint
6.5
false
{F003DA68-8256-4b37-A6C4-350FA04494DF}
Important Modified Preferences
Name
Value
browser.cache.disk.capacity
358400
browser.cache.disk.smart_size.first_run
false
browser.cache.disk.smart_size.use_old_max
false
browser.cache.disk.smart_size_cached_value
358400
browser.places.smartBookmarksVersion
4
browser.startup.homepage
google.com
browser.startup.homepage_override.buildID
20130618035212
browser.startup.homepage_override.mstone
22.0
browser.tabs.warnOnClose
false
dom.mozApps.used
true
extensions.lastAppVersion
22.0
gfx.direct3d.last_used_feature_level_idx
1
network.cookie.prefsMigrated
true
places.history.expiration.transient_current_max_pages
76666
plugin.disable_full_page_plugin_for_types
application/pdf
plugin.importedState
true
plugin.state.flash
2
plugin.state.np32dsw
0
privacy.sanitize.migrateFx3Prefs
true
Graphics
Adapter Description
Intel(R) HD Graphics
Adapter Drivers
igdumd64 igd10umd64 igdumdx32 igd10umd32
Adapter RAM
Unknown
Device ID
0x0046
Direct2D Enabled
true
DirectWrite Enabled
true (6.2.9200.16571)
Driver Date
7-31-2012
Driver Version
8.15.10.2827
GPU #2 Active
false
GPU Accelerated Windows
1/1 Direct3D 10
Vendor ID
0x8086
WebGL Renderer
Google Inc. -- ANGLE (Intel(R) HD Graphics)
AzureCanvasBackend
direct2d
AzureContentBackend
direct2d
AzureFallbackCanvasBackend
cairo
JavaScript
Incremental GC
true
Accessibility
Activated
false
Prevent Accessibility
0
Library Versions
Expected minimum version
Version in use
NSPR
4.9.6
4.9.6
NSS
3.14.3.0 Basic ECC
3.14.3.0 Basic ECC
NSSSMIME
3.14.3.0 Basic ECC
3.14.3.0 Basic ECC
NSSSSL
3.14.3.0 Basic ECC
3.14.3.0 Basic ECC
NSSUTIL
3.14.3.0
3.14.3.0

Question owner

Application Basics

       Name
       Firefox
       Version
       22.0
       User Agent
       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20100101 Firefox/22.0
       Build Configuration
         about:buildconfig
 Extensions
       Name
       Version
       Enabled
       ID
       avast! Online Security
       8.0.1489
       true
       wrc@avast.com
       Gmail panel
       1.0.7
       true
       gmail_panel@alejandrobrizuela.com.ar
       General Crawler
       2.6
       false
       gencrawler@some.com
       Logitech SetPoint
       6.5
       false
       {F003DA68-8256-4b37-A6C4-350FA04494DF}
 Important Modified Preferences
     Name
     Value
       browser.cache.disk.capacity
       358400
       browser.cache.disk.smart_size.first_run
       false
       browser.cache.disk.smart_size.use_old_max
       false
       browser.cache.disk.smart_size_cached_value
       358400
       browser.places.smartBookmarksVersion
       4
       browser.startup.homepage
       google.com
       browser.startup.homepage_override.buildID
       20130618035212
       browser.startup.homepage_override.mstone
       22.0
       browser.tabs.warnOnClose
       false
       dom.mozApps.used
       true
       extensions.lastAppVersion
       22.0
       gfx.direct3d.last_used_feature_level_idx
       1
       network.cookie.prefsMigrated
       true
       places.history.expiration.transient_current_max_pages
       76666
       plugin.disable_full_page_plugin_for_types
       application/pdf
       plugin.importedState
       true
       plugin.state.flash
       2
       plugin.state.np32dsw
       0
       privacy.sanitize.migrateFx3Prefs
       true
 Graphics
       Adapter Description
       Intel(R) HD Graphics
       Adapter Drivers
       igdumd64 igd10umd64 igdumdx32 igd10umd32
       Adapter RAM
       Unknown
       Device ID
       0x0046
       Direct2D Enabled
       true
       DirectWrite Enabled
       true (6.2.9200.16571)
       Driver Date
       7-31-2012
       Driver Version
       8.15.10.2827
       GPU #2 Active
       false
       GPU Accelerated Windows
       1/1 Direct3D 10
       Vendor ID
       0x8086
       WebGL Renderer
       Google Inc. -- ANGLE (Intel(R) HD Graphics)
       AzureCanvasBackend
       direct2d
       AzureContentBackend
       direct2d
       AzureFallbackCanvasBackend
       cairo
 JavaScript
       Incremental GC
       true
 Accessibility
       Activated
       false
       Prevent Accessibility
       0
 Library Versions
       Expected minimum version
       Version in use
       NSPR
       4.9.6
       4.9.6
       NSS
       3.14.3.0 Basic ECC
       3.14.3.0 Basic ECC
       NSSSMIME
       3.14.3.0 Basic ECC
       3.14.3.0 Basic ECC
       NSSSSL
       3.14.3.0 Basic ECC
       3.14.3.0 Basic ECC
       NSSUTIL
       3.14.3.0
       3.14.3.0
cor-el
  • Top 10 Contributor
  • Moderator
10738 solutions 96600 answers

You can check for problems with current Flash plugin versions and try these:

  • disable a possible RealPlayer Browser Record Plugin extension for Firefox and update the RealPlayer if installed
  • disable protected mode in the Flash plugin (Flash 11.3+ on Windows Vista and later)
  • disable hardware acceleration in the Flash plugin

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window or otherwise make changes.
reallymurphy 0 solutions 11 answers

Helpful Reply

I see many many entries on the support site about Shockwave crashing with the exact same suggested fix. IT DOES NOT WORK. Lets do better ladies and gentlemen.

slywlf54 1 solutions 8 answers

My HP Win7 desktop has been having problems with Shockwave plugin crashes off and on ever since the update to Firefox 25.0.1 and it is getting worse as time goes on. Just about any active media - Youtube, online radio, Pandora, and Spotify - all sound like they have the hiccups - gaps and stops and starts.... then the crashes. On the other hand my ancient Dell laptop, with Win XP and an older version of Firefox is behaving just fine, so the blame cannot be put solely on Adobe.

cor-el
  • Top 10 Contributor
  • Moderator
10738 solutions 96600 answers

Did you try to disable hardware acceleration in Firefox and in the Flash plugin and possibly also disable protected mode in the Flash plugin?

Also make sure that your security software isn't causing problems with the plugin-container process.

slywlf54 1 solutions 8 answers

I have disabled hardware acceleration in FF and the playback on Youtube is marginally improved. However now I am getting frequent "Firefox is non-responsive" messages - usually when I open a new tab or am just starting up.

As for disabling it for Adobe, that has been a wash so far. I read the instructions, went to the "version page" but where instructions indicated I should get a drop down menu for settings all I get is plain text - nothing to click on. I cannot tell if that is because I am using Firefox, and it is simply not giving me the link or if the Adobe page is having issues of its own.

My security is AVG Internet Security 2014 and it has not been interfering with anything as far as I can tell. It was playing nice with all my software before the latest FF upgrade (the same one which wiped out my bookmarks and passwords), so since all my recent tribulations date from that event it seems unlikely that AVG is responsible.

I have been a staunch supporter of Mozilla and Firefox for many years, and I always have felt comfortable recommending it to friends despite the occasional hitch, but while I really don't care much for Chrome - mostly because of privacy issues - I must say I am disheartened by this latest update.

jscher2000
  • Top 10 Contributor
2347 solutions 20809 answers

Hi slywlf54, here is how you can disable the protected mode feature:

(1) In a My Computer or Windows Explorer window, open this folder:

C:\Windows\SysWOW64\Macromed\Flash

If that folder does not exist, then you are using 32-bit Windows, and you can open the following folder instead:

C:\Windows\System32\Macromed\Flash

(Note: This folder exists on both 32-bit and 64-bit Windows, but on 64-bit Windows Firefox uses the Flash player in the SysWOW64 folder instead.)

(2) Check for a file named mms.cfg:

(A) If mms.cfg exists, drag it to your Documents folder where you can edit it without being bothered about administrator privileges

(B) If mms.cfg does not exist, open your Documents folder, right-click > New > Text File and name the new file mms.cfg (if you have Windows set to hide file extensions, this may create a text document instead of a CFG file, in that case, see this article: http://support.microsoft.com/kb/865219)

(3) Open mms.cfg from Documents into a text editor such as Notepad. Add this on its own line (I put it last):

ProtectedMode=0

Save the file and close Notepad.

(4) Hold down the Ctrl key and drag the mms.cfg file back to the Flash folder to make a copy there, keeping the original in Documents

This change should take effect the next time you restart Firefox (allow a few minutes for all the Flash processes in memory to terminate after exiting Firefox).

slywlf54 1 solutions 8 answers

OK - the system would not let me drag that file anywhere, so I copied it to Documents, did as instructed, renamed it and copy/pasted it back in the original folder. Oddly enough the system had no objection to two identically named files, won't let me move the original out of the folder, but seems to be totally ignoring my doctored one. So now I have an old and new version of the cfg file in My Documents and in the Flash folder, and playback issues continue. I am open to suggestion - while my skills are limited I am pretty good at following clear instructions - as yours were, and thank you!

jscher2000
  • Top 10 Contributor
2347 solutions 20809 answers

Hi slywlf54, I'm pretty sure Windows will not tolerate two identically named files in the same folder. There must be some difference. Did you make the change so you're viewing the true file extensions?

Another way to edit a file in that folder is to run Notepad as the administrator. If you open the Start menu to where you can find Notepad, then right-click it and choose Run as administrator, you then should be able to edit the original mms.cfg. (Or perhaps it won't let you edit while Flash is running? I haven't tried it for so long, I can remember.)

cor-el
  • Top 10 Contributor
  • Moderator
10738 solutions 96600 answers

Note that Windows hides some file extensions by default.

Among them are .cfg and .ini and .js and .txt, so you may only see a name without file extension.
You can see the real file extension (type) if you open the Properties of the file via the right-click context menu.

slywlf54 1 solutions 8 answers

That shows me simply a read-only 'file folder' for the original while the notepad file I renamed after editing it shows as a .cfg file Now what?

slywlf54 1 solutions 8 answers

Chosen Solution

OK - I reset my folders to show extensions on all files, renamed the old one to mms2.cfg and then fixed the doctored one to mms.cfg and at least for now that seems to have done the trick - the video I just put on has been playing with only the occasional hiccup. Not perfect but a lot better. Thank you!

Modified by slywlf54