Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

When I launch FF I get a black screen and can't see anything but black. Help!!

  • 11 replies
  • 39 have this problem
  • 15097 views
  • Last reply by jscher2000

more options

I updated Firefox to the latest version 7 rev 25. I've lost my menu, can't see anything but black and a few icons. cannot see bookmarks, menus, etc. I've had to switch to an alternate browser, which works fine.

I think you are going to lose many users over this problem. It is aggravating to say the least. Please help.

All Replies (11)

more options

Try to disable hardware acceleration in Firefox.

You can use one of these to start Firefox in Safe Mode:

  • On Windows, hold down the Shift key while starting Firefox with a double-click on the Firefox desktop shortcut
  • On Mac, hold down the Options key while starting Firefox
  • Help > Restart with Add-ons Disabled
more options

Could you start Firefox in its Safe Mode? Firefox's Safe Mode is a standard diagnostic tool to bypass interference by extensions (and some custom settings). More info: Diagnose Firefox issues using Troubleshoot Mode.

If Firefox is running: Help > Restart with Add-ons Disabled

If Firefox is not running: Hold the Shift key while start Firefox

Then, in the dialog, click "Start in Safe Mode" (not Reset)

The hardware acceleration feature is sensitive to graphics driver incompatibilities. Disable it here:

orange Firefox button (or Tools menu) > Options > Advanced

On the "General" mini-tab, uncheck the box for "Use hardware acceleration when available"

Then exit and restart Firefox normally.

Any improvement?

Assuming you can read the toolbars in Firefox, can you look up your current version using Help > About Firefox?

Edit: I guess version 7 rev 25 may have been a Java update.

Modified by jscher2000

more options

Thank you for the assistance. I can now use Firefox once again. I disabled the hardware acceleration and that did the trick. I have since made other changes that I wanted.

And you are right, I was referencing a java install when I said Version 7 - 25. Sorry I mixed that up.

I appreciate your willingness to help. Kerry

more options

Thank you for your help. Since I couldn't see anything but BLACK on Firefox, I was operating blindly . . . . . not a good thing. I appreciate your willingness to help. Kerry

more options

I have this problem as well. I wish I could use tools but I can't see anything on the menu at all.

more options

I received this information and it works: Try to disable hardware acceleration in Firefox.

Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available" https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes

You can use one of these to start Firefox in Safe Mode:

On Windows, hold down the Shift key while starting Firefox with a double-click on the Firefox desktop shortcut. On Mac, hold down the Options key while starting Firefox Help > Restart with Add-ons Disabled https://support.mozilla.org/kb/Safe+Mode

more options

Her is the 2nd part of the answer:

Could you start Firefox in its Safe Mode? Firefox's Safe Mode is a standard diagnostic tool to bypass interference by extensions (and some custom settings). More info: Troubleshoot Firefox issues using Safe Mode.

If Firefox is running: Help > Restart with Add-ons Disabled

If Firefox is not running: Hold the Shift key while start Firefox

Then, in the dialog, click "Start in Safe Mode" (not Reset)

The hardware acceleration feature is sensitive to graphics driver incompatibilities. Disable it here:

orange Firefox button (or Tools menu) > Options > Advanced

On the "General" mini-tab, uncheck the box for "Use hardware acceleration when available"

Then exit and restart Firefox normally.

Any improvement?

Assuming you can read the toolbars in Firefox, can you look up your current version using Help > About Firefox?

Modified July 16, 2013 4:06:43 AM EDT by jscher2000

more options

Do you still have problems or did disabling hardware acceleration fixed all issues?

more options

There was no hardware acceleration checkbox.

more options

There was no hardware acceleration checkbox. Firefox version 22

I used nightly and the black screen happened. I went back to regular firefox, by installing it after uninstalling nightly using revo unistaller, but black screen remains.

more options

Hi wolbar, the location of the Options/Preferences dialog in the menus depends on your operating system, but once you locate it, there definitely should be a checkbox for hardware acceleration in the Advanced options. Do either of these articles help: