Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox prevents router login

  • 4 replies
  • 2 have this problem
  • 4494 views
  • Last reply by cor-el

more options

WRT120N router Linksys-Cisco, Firefox 22.0

I have discovered that my router rejects all attempts to login (192.168.0.1, 401 authentication failure "browser not authentication-capable or authentication failed") when accessed from Firefox. It allows the login when the attempt is done from Chrome.

I remember long ago having a similar issue with Firefox, but solved that by turning off the 'tell sites don't track me' option, following which logins worked; just looked, and that is still not checked--so that isn't it.

I looked at a packet capture, and the password IS being sent to the router, but it is rejecting the login.

Any ideas?

Chosen solution

"BUT IT WORKS CORRECTLY STARTED IN SAFE MODE. " That prompted me to check extensions. I have one called, guess what...DO NOT TRACK ME.

(Why is there such an extension if it is built in function?)

Disabling that allowed the router to allow the login! I do not know why twice now, attempting to activate Do Not Track has eliminated the ability to log in to the router...but that is the solution.

Read this answer in context 👍 0

All Replies (4)

more options

Clear the cache and the cookies from websites that cause problems.

"Clear the Cache":

  • Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Firefox/Tools > Options > Privacy > Cookies: "Show Cookies"

You can try if it works in Private Browsing mode.

more options

Clear the cache and the cookies from websites that cause problems. "Clear the Cache":

i HAVE FIREFOX SET TO CLEAR ON EVERY EXIT. IT SHOWED 0 BYTES IN THE CACHE.

"Remove Cookies" from sites causing problems: THE ROUTER SETS NO COOKIES

You can try if it works in Private Browsing mode- https://support.mozilla.org/kb/Private+Browsing SAME RESULT.

BUT IT WORKS CORRECTLY STARTED IN SAFE MODE.

Modified by supmozilla

more options

Chosen Solution

"BUT IT WORKS CORRECTLY STARTED IN SAFE MODE. " That prompted me to check extensions. I have one called, guess what...DO NOT TRACK ME.

(Why is there such an extension if it is built in function?)

Disabling that allowed the router to allow the login! I do not know why twice now, attempting to activate Do Not Track has eliminated the ability to log in to the router...but that is the solution.

more options

If it works in Safe Mode and in normal mode with all extensions (Firefox/Tools > Add-ons > Extensions) disabled then try to find which extension is causing it by enabling one extension at a time until the problem reappears.

Close and restart Firefox after each change via "Firefox > Exit" (Windows: Firefox/File > Exit; Mac: Firefox > Quit Firefox; Linux: Firefox/File > Quit)