X
Tap here to go to the mobile version of the site.

Support Forum

I want to activate Java script . How to do it ?

Posted

I activated NoScript feature . But I got a message saying that java script is not available on my PC.

I activated NoScript feature . But I got a message saying that java script is not available on my PC.

Additional System Details

Installed Plug-ins

  • Google Update
  • Next Generation Java Plug-in 10.25.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 11.8 r800
  • Google Talk Plugin Video Accelerator version:0.1.44.29
  • Version 4.2.1.14031
  • npsitesafety
  • VLC media player Web Plugin 2.0.6
  • 5.1.20513.0
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.03
  • Picasa plugin
  • McAfee MSS+ NPAPI Plugin
  • NPWLPG
  • Provides additional functionality on Facebook. See our web site for details.

Application

  • Firefox 22.0
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/20100101 Firefox/19.0
  • Support URL: http://support.mozilla.org/1/firefox/22.0/WINNT/en-US/

Extensions

  • Add Google Search To New Tab Page 1.0.2 (newtabgoogle@graememcc.co.uk)
  • Advanced Cookie Manager 5.2 (cookiemgr@jayapal.com)
  • Ask Toolbar 3.14.0.100013 (toolbar@ask.com)
  • avast! EasyPass Toolbar for Firefox 7.7.8.128 ({22119944-ED35-4ab1-910B-E619EA06A115})
  • avast! Online Security 8.0.1489 (wrc@avast.com)
  • AVG Security Toolbar 15.3.0.11 (avg@toolbar)
  • Babylon Translation Activation 1.1 (ocr@babylon.com)
  • betterFox - Make your browsing experience 15% faster. 1.1.3 (multirevenue@googlemail.com)
  • Blender 0.0.9 (blender@meh.paranoid.pk)
  • Bluhell Firewall 1.3.0 ({6BB5760D-F97E-421B-AF5B-8457A90C3CED})
  • NoScript 2.6.6.7 ({73a6fe31-595d-460b-a920-fcc0f8843232})
  • Test Pilot 1.2.2 (testpilot@labs.mozilla.com)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • AVG Safe Search 12.0.0.2222 ({1E73965B-8B48-48be-9C8D-68B920ABC1C4}) (Inactive)
  • Skype Click to Call 6.9.0.12585 ({82AF8DCA-6DE9-405D-BD5E-43525BDAD38A}) (Inactive)
  • uTorrentBar Community Toolbar 3.18.0.7 ({bf7380fa-e3b4-4db2-af3e-9d8783a45bfc}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Mobile Intel(R) 4 Series Express Chipset Family
  • adapterDescription2:
  • adapterDeviceID: 0x2a42
  • adapterDeviceID2:
  • adapterDrivers: igdumdx32 igd10umd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.16571
  • driverDate: 8-25-2010
  • driverDate2:
  • driverVersion: 8.15.10.2202
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d'}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (Mobile Intel(R) 4 Series Express Chipset Family)
  • windowLayerManagerType: Direct3D 10

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.importBookmarksHTML: False
  • browser.places.smartBookmarksVersion: 4
  • browser.startup.homepage: www.google.com
  • browser.startup.homepage_override.buildID: 20130618035212
  • browser.startup.homepage_override.mstone: 22.0
  • browser.tabs.warnOnClose: False
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 22.0
  • font.internaluseonly.changed: True
  • general.useragent.extra.btrs: BTRS124001
  • general.useragent.override: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/20100101 Firefox/19.0
  • general.useragent.vendor:
  • general.useragent.vendorSub:
  • gfx.direct3d.checkDX10: False
  • gfx.direct3d.last_used_feature_level_idx: 1
  • network.accept-encoding: gzip, deflate
  • network.accept.default: text/html,application/xml,*/*
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1373643107
  • places.history.expiration.transient_current_max_pages: 79498
  • places.history.expiration.transient_optimal_database_size: 127196528
  • places.last_vacuum: 1305695898
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • privacy.donottrackheader.enabled: True
  • privacy.sanitize.migrateFx3Prefs: True
  • security.warn_viewing_mixed: False
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1371455693

Misc

  • User JS: No
  • Accessibility: Yes
ideato 893 solutions 6250 answers

Hello SURYAWANSHIAJ, go from Firefox button(the orange one) > Options > Options > Content > CHECK Enable JavaScript [v] > OK .

for more info : Content Settings

thank you

Hello SURYAWANSHIAJ, go from Firefox button(the orange one) > Options > Options > Content > CHECK Enable JavaScript [v] > OK . for more info : [https://support.mozilla.org/en-US/kb/settings-fonts-languages-pop-ups-javascript#w_content-settings Content Settings] thank you
the-edmeister
  • Top 25 Contributor
  • Moderator
5406 solutions 40224 answers

http://noscript.net/features

You need to learn how to use the NoScript extension properly. By default it blocks all JavaScript from running, so you need to allow JavaScript to run per domain.

http://noscript.net/features You need to learn how to use the NoScript extension properly. By default it blocks all JavaScript from running, so you need to '''allow''' JavaScript to run per domain.

Helpful Reply

How to do it . I could not locate orange button either . Pl guide me step by step .

How to do it . I could not locate orange button either . Pl guide me step by step .
smo 38 solutions 498 answers

To check the setting for Javascript, see the detailed instructions in this article:

JavaScript settings and preferences for interactive web pages

If Javascript use is activated, then possibly the problem is the way Noscript add-on works. Noscript usually asks on the first access of a new interactive page, if you allow (temporarily or forever) the use of Javascript.

See the Noscript homepage for the kick-off information on the use of the extension.

To check the setting for Javascript, see the detailed instructions in this article: [[JavaScript settings and preferences for interactive web pages]] If Javascript use is activated, then possibly the problem is the way Noscript add-on works. Noscript usually asks on the first access of a new interactive page, if you allow (temporarily or forever) the use of Javascript. See the [http://noscript.net/ Noscript homepage ] for the kick-off information on the use of the extension.

Modified by smo

the-edmeister
  • Top 25 Contributor
  • Moderator
5406 solutions 40224 answers

Try the NoScript support forum for step-by-step instructions, if that Features page isn't enough of an explanation for you. Or just skip using that extension if you don't have the patience to learn how to use it!
http://forums.informaction.com/viewforum.php?f=3

NoScript is one of the best documented extensions available for Firefox, and also has its' own support forum, to boot. We're here to support Firefox, it is up to the add-on developers to support their Firefox add-on.

Try the NoScript support forum for step-by-step instructions, if that Features page isn't enough of an explanation for you. Or just skip using that extension if you don't have the patience to learn how to use it! <br /> http://forums.informaction.com/viewforum.php?f=3 NoScript is one of the best documented extensions available for Firefox, and also has its' own support forum, to boot. We're here to support Firefox, it is up to the add-on developers to support their Firefox add-on.
NigelWaring 0 solutions 3 answers

Helpful Reply

I really think that it might be easier to use another browser. Lots of people have the problem of "enabling java script". Those helping might be genuine but the answers really do not mean much at all to the average user who is not a boffin. I just want to turn java script on, learning how it works is way beyond me. people talk of red and orange buttons but many of us just cannot find them. At the moment I cannot get into some simple websites, they all tell me to "enable Java Script". I'm getting to the point of thinking that Mozilla Firefox is not for me or many others like me. I don't have to take a mechanics course to drive my car, don't want to have to do something similar to look at a browser.

I really think that it might be easier to use another browser. Lots of people have the problem of "enabling java script". Those helping might be genuine but the answers really do not mean much at all to the average user who is not a boffin. I just want to turn java script on, learning how it works is way beyond me. people talk of red and orange buttons but many of us just cannot find them. At the moment I cannot get into some simple websites, they all tell me to "enable Java Script". I'm getting to the point of thinking that Mozilla Firefox is not for me or many others like me. I don't have to take a mechanics course to drive my car, don't want to have to do something similar to look at a browser.
cor-el
  • Top 10 Contributor
  • Moderator
17522 solutions 158438 answers

There are other things that need your attention.

Your System Details List shows that you have a lot of modified prefs.
I don't know if a space is allowed in the value of this pref:

network.accept-encoding: "gzip, deflate" -> network.accept-encoding: "gzip,deflate"

You may want to reset some other prefs as well if you made changes in the past or have/had extensions that made the changes.

There are other things that need your attention. Your System Details List shows that you have a lot of modified prefs.<br /> I don't know if a space is allowed in the value of this pref: network.accept-encoding: "gzip, deflate" -> network.accept-encoding: "gzip,deflate" You may want to reset some other prefs as well if you made changes in the past or have/had extensions that made the changes.
NigelWaring 0 solutions 3 answers

Many thanks cor-el. I'm just totally lost and don't think I'll ever understand it. You say that I have a lot of modified prefs, sorry but I do not really understand any of that or the line below that says "network.accept etc."

The problems seem to have started yesterday when I set up Firefox on another PC and then synched it. I can't use Facebook any longer in Mozilla but it works OK in Chrome and some other websites will no longer display, again they all work OK in Chrome.

I get the impression that Mozilla Firefox is becoming very complicated and is getting beyond the scope of the average user.

Many thanks cor-el. I'm just totally lost and don't think I'll ever understand it. You say that I have a lot of modified prefs, sorry but I do not really understand any of that or the line below that says "network.accept etc." The problems seem to have started yesterday when I set up Firefox on another PC and then synched it. I can't use Facebook any longer in Mozilla but it works OK in Chrome and some other websites will no longer display, again they all work OK in Chrome. I get the impression that Mozilla Firefox is becoming very complicated and is getting beyond the scope of the average user.
cor-el
  • Top 10 Contributor
  • Moderator
17522 solutions 158438 answers

The NoScript extension blocks all JavaScript by default, so you need to set it up properly and allow JavaScript for trusted sites that you visit regularly and decide what to do with websites that you haven't visited before or only visit occasionally.

You need to make sure that JavaScript is allowed globally and that the javascript.enabled pref is set to true on the about:config page page (there is no setting in the user interface anymore) also make sure that other extensions or security software aren't blocking content if there are still problems.

The NoScript extension blocks all JavaScript by default, so you need to set it up properly and allow JavaScript for trusted sites that you visit regularly and decide what to do with websites that you haven't visited before or only visit occasionally. You need to make sure that JavaScript is allowed globally and that the javascript.enabled pref is set to true on the <b>about:config</b> page page (there is no setting in the user interface anymore) also make sure that other extensions or security software aren't blocking content if there are still problems. *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes
NigelWaring 0 solutions 3 answers

Thanks cor-el but all that is way beyond me. I just do not understand what most of the terms mean or where to find them within Firefox. I am in my seventies and it is too hard to learn something new when I do not know what most of the terms mean. I prefer products with simple user interfaces that appear in plain English with things like boxes where you tick to enable something or untick to disable it. Many thanks for you help anyway.

Thanks cor-el but all that is way beyond me. I just do not understand what most of the terms mean or where to find them within Firefox. I am in my seventies and it is too hard to learn something new when I do not know what most of the terms mean. I prefer products with simple user interfaces that appear in plain English with things like boxes where you tick to enable something or untick to disable it. Many thanks for you help anyway.