X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox crashes while logged into Lumosity

Posted

This what I related to Lumosity support:

I'm using Mozilla Firefox 22.0 (up to date) with Win7 and IE10 10.0.9200.16618 update version 10.0.6 is in the background (not using it for browsing, etc). I believe Java is involved in gaming, so here is that data: Java Deployment Toolkit 7.0.250.17 10.25.2.17 and Java TM Platform SE7 U25 10.25.2.17 Whether I access Lumosity by email link or directly by the URL, Mozilla is crashing repeatedly, going on days now. It tends to crash with Disillusion very frequently (in other words when I finally get access, it crashes repeatedly). It has crashed on Familiar Faces and Rising Word Bubbles . I wish I could give you a better list - but it seems to crash w/more demanding games. It crashes while loading the game. The progress bar gets one-quarter into the load before it goes down.

I have been sending crash reports to Mozilla. I have looked on line for some answers. Nothing found yet in the way of answers. I have seen that various people (general online chats/forums) are experiencing the crashes and obtaining no answers. If there is more info you need that would help analyze and fix this, please let me know.

I have gone through Mozilla's general help about crashes and have restarted Mozilla in safe mode (no add ons) and I have opted out of using hardware acceleration (permanently). I do not think it's crashed in the safe mode.

My husband uses Lumosity on his computer and his entire computer shuts down. He has the same systems I have only on a PC (mine is a laptop). His Java versions, (Toolkit) - 7.0.60.24 10.6.2.24 Java TM Platform SE7 U610.6.2.24.

I received response from Lumosity and understand that support believes this issue may be due to a compatibility issue with plugins on the new version of Firefox. I also understand that Lumosity depends on Adobe Flash Player, so after discussion w/Lumosity support, I updated my Adobe Flash Player to v. 11.8.800.94. BTW Lumosity support is able to recreate the events w/Firefox and to control them by starting Firefox in safe mode.

I have uninstalled Firefox, deleted the Mozilla folder from the program files as outlined in support info. I did notice that uninstalling Firefox did not uninstall Mozilla Maintenance Service v. 22 7-2-13 333 KB. There were several folders in the Mozilla folder when I deleted it, the Maintenance file being one of them I am sure, and it is now dated today's date, v. 22 at 219kb.

In the process of this, I had notice of Windows updates, so I rebooted the computer to let the updates install. I went back to Mozilla and logged on to Lumosity, opened the game "Disillusion" and it started up fast w/o crashing. However, the very next game I opened, Rising Word Bubbles, it crashed. Twice or so. I opened Mozilla in safe mode and it did not crash when I played one of the games.

I think I have listed everything that I've done. Sure could use some help to fix this. I've even backed up and defragged.

One last thing, I had installed "Memeo Premium Backup" and was having trouble with that program crashing, Windows indicating it would debug and advise (nothing received on that). I am wondering if those problems were also a part of this problem. I have since gone back to "Memeo Instant Backup" which works fine. FYI

Now, I see there is a button to push that will automatically do something. I think I'll copy my notes, just in case. Probably TMI for an auto response anyway.

Help. Thank you! I typically LOVE Mozilla and spread the word ... oh please let there be an answer.  ;)

(Cool, didn't expect the data after I clicked the button and installed. Woo-hoo. Keep on rocking Mozilla.)

Thank you, Jenn

Chosen solution

This seems to be related to the new JIT compiler included with the Firefox 22 release. You can disable this by either using Safe Mode (https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode#w_how-to-start-firefox-in-safe-mode or by manually disabling it in the about:config settings. I recommend Safe Mode, but if you want to do it manually, you can follow these steps:

1. Open a new tab and enter "about:config" in the address bar. You may get a message, "This might void your warranty;" click "I'll be careful, I promise!" 2. Enter "javascript.options.methodjit" into the search bar (directly below the address bar). 3. You should see 3 entries. Double-click the entries "javascript.options.methodjit.chrome" and "javascript.options.methodjit.content" which should toggle them to the "false" setting (if you ever want to enable the JIT again, simply follow these instructions and toggle these 2 entries to the "true" setting).

The changes will take effect without restarting. Simply close the tab and go back to Lumosity.com.

Read this answer in context 3

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.8 r800
  • Next Generation Java Plug-in 10.25.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • SiteAdvisor
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.03
  • iTunes Detector Plug-in
  • A component of your photo software powered by RocketLife
  • McAfee MSC FF plugin DLL
  • NPWLPG
  • 5.1.20125.0

Application

  • Firefox 22.0
  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:22.0) Gecko/20100101 Firefox/22.0
  • Support URL: http://support.mozilla.org/1/firefox/22.0/WINNT/en-US/

Extensions

  • McAfee SiteAdvisor 3.6.2 ({4ED1F68A-5463-4931-9384-8FFF5ED91D92})
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • AVG SafeGuard toolbar 15.3.0.11 (avg@toolbar) (Inactive)
  • HP Smart Web Printing 4.60 (smartwebprinting@hp.com) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Mobile Intel(R) 965 Express Chipset Family
  • adapterDescription2:
  • adapterDeviceID: 0x2a02
  • adapterDeviceID2:
  • adapterDrivers: igdumdx32 igd10umd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'blockedDriver']
  • directWriteEnabled: False
  • directWriteVersion: 6.2.9200.16492
  • driverDate: 9-23-2009
  • driverDate2:
  • driverVersion: 8.15.10.1930
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'none'}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (Mobile Intel(R) 965 Express Chipset Family)
  • windowLayerManagerType: Basic

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.startup.homepage: about:home|http://jennspeacornpopnuts.com/
  • browser.startup.homepage_override.buildID: 20130618035212
  • browser.startup.homepage_override.mstone: 22.0
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 22.0
  • gfx.direct2d.disabled: True
  • layers.acceleration.disabled: True
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1373411628
  • places.history.expiration.transient_current_max_pages: 80280
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • plugin.state.npdeployjava: 2
  • plugin.state.npsitesafety: 0
  • privacy.sanitize.migrateFx3Prefs: True
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1373149396

Misc

  • User JS: No
  • Accessibility: No

Question owner

PS FYI here are the sites I found in a search w/same problems:

Broadband Reports

Broadband DSL

mojo.jojo 1 solutions 1 answers

Chosen Solution

This seems to be related to the new JIT compiler included with the Firefox 22 release. You can disable this by either using Safe Mode (https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode#w_how-to-start-firefox-in-safe-mode or by manually disabling it in the about:config settings. I recommend Safe Mode, but if you want to do it manually, you can follow these steps:

1. Open a new tab and enter "about:config" in the address bar. You may get a message, "This might void your warranty;" click "I'll be careful, I promise!" 2. Enter "javascript.options.methodjit" into the search bar (directly below the address bar). 3. You should see 3 entries. Double-click the entries "javascript.options.methodjit.chrome" and "javascript.options.methodjit.content" which should toggle them to the "false" setting (if you ever want to enable the JIT again, simply follow these instructions and toggle these 2 entries to the "true" setting).

The changes will take effect without restarting. Simply close the tab and go back to Lumosity.com.

cor-el
  • Top 10 Contributor
  • Moderator
10753 solutions 96760 answers

To avoid confusion:

Helpful Reply

Thanks - I'll go the "safe" route and disable add ons.

Question owner

Not really sure what that's all about - over my head ... but I think I get it generally.

Thanks.