X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Why does Firefox remember Social Security numbers?

Posted

I do not think this is normal operation, so I am unsure if this is Firefox's fault or the website's fault. I was just doing something on Paypal.com and when it came time to fill in my social security number, it had "suggestions" pop up under the fields with my SSN that it remembered before. Things like SS# and credit card numbers should not be remembered like this because it's a major security issue for if someone else uses my computer.

I do not want to disable remembering fields entirely because that feature is useful to me. Names, addresses, phone numbers, emails, is all okay to be auto-filled in, but not something as extremely sensitive as SS#'s.

Again, sorry if this is Paypal's fault. I will be contacting them instead if it is.

Thank you for any information you can provide.

Chosen solution

Firefox has a built-in algorithm to check for credit card numbers (Luhn), but not for other privacy sensitive numbers.

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.7 r700
  • Next Generation Java Plug-in 10.25.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Google Talk Plugin Video Accelerator version:0.1.44.29
  • Version 4.1.3.13728
  • Google Update
  • GEPlugin
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.02
  • 5.1.20125.0
  • Happy Cloud Web Plugin
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.4
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers
  • Logitech Harmony Remote Plugin

Application

  • Firefox 22.0
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20100101 Firefox/22.0
  • Support URL: http://support.mozilla.org/1/firefox/22.0/WINNT/en-US/

Extensions

  • Adblock Plus 2.2.4 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Block Site 1.0.3 ({dd3d7613-0246-469d-bc65-2a3cc1668adc})
  • Flash Video Downloader - Youtube Downloader 3.8.8 (artur.dubovoy@gmail.com)
  • Flashblock 1.5.17 ({3d7eb24f-2740-49df-8937-200b1cc08f8a})
  • Show Me More 2.3 (showmemore@suskind)
  • SoundCloud Downloader - Technowise 0.67 ({c8d3bc80-0810-4d21-a2c2-be5f2b2832ac})
  • Status-4-Evar 2013.02.16.23 (status4evar@caligonstudios.com)
  • StumbleUpon 4.16 ({AE93811A-5C9A-4d34-8462-F7B864FC4696})
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Adobe Acrobat - Create PDF 1.2 (web2pdfextension@web2pdf.adobedotcom) (Inactive)
  • avast! Online Security 8.0.1489 (wrc@avast.com) (Inactive)
  • FireFTP 2.0.16 ({a7c6cf7f-112c-4500-a7ea-39801a327e5f}) (Inactive)
  • YouTube Embed2Link 1.9.1 (youtube-e2l@jetpack) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: AMD Radeon HD 7800 Series
  • adapterDescription2:
  • adapterDeviceID: 0x6818
  • adapterDeviceID2:
  • adapterDrivers: aticfx64 aticfx64 aticfx64 aticfx32 aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
  • adapterDrivers2:
  • adapterRAM: 2048
  • adapterRAM2:
  • adapterVendorID: 0x1002
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.16492
  • driverDate: 12-19-2012
  • driverDate2:
  • driverVersion: 9.12.0.0
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d'}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (AMD Radeon HD 7800 Series)
  • windowLayerManagerType: Direct3D 10

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.search.context.loadInBackground: True
  • browser.search.useDBForOrder: True
  • browser.startup.homepage_override.buildID: 20130618035212
  • browser.startup.homepage_override.mstone: 22.0
  • browser.tabs.insertRelatedAfterCurrent: False
  • browser.tabs.onTop: False
  • browser.tabs.warnOnClose: False
  • browser.urlbar.autocomplete.enabled: False
  • browser.urlbar.formatting.enabled: False
  • browser.urlbar.trimURLs: False
  • dom.disable_window_flip: False
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 22.0
  • font.internaluseonly.changed: False
  • font.size.variable.x-western: 18
  • gfx.direct3d.last_used_feature_level_idx: 0
  • gfx.direct3d.prefer_10_1: True
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1372826841
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • privacy.cpd.cookies: False
  • privacy.cpd.downloads: False
  • privacy.cpd.history: False
  • privacy.cpd.sessions: False
  • privacy.donottrackheader.enabled: True
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.timeSpan: 0
  • security.warn_viewing_mixed: False
  • storage.vacuum.last.index: 0
  • storage.vacuum.last.places.sqlite: 1372831479

Misc

  • User JS: No
  • Accessibility: Yes
Andrew
  • Top 25 Contributor
  • Moderator
252 solutions 3020 answers

This is due to cookies stored on your computer.


Many site issues can be caused by corrupt cookies or cache. In order to try to fix these problems, the first step is to clear both cookies and the cache. Note: This will temporarily log you out of all sites you're logged in to. To clear cache and cookies do the following:

  1. Go to Firefox > History > Clear recent history or (if no Firefox button is shown) go to Tools > Clear recent history.
  2. Under "Time range to clear", select "Everything".
  3. Now, click the arrow next to Details to toggle the Details list active.
  4. From the details list, check Cache and Cookies and uncheck everything else.
  5. Now click the Clear now button.

Further information can be found in the Clear your cache, history and other personal information in Firefox article.

Did this fix your problems? Please report back to us!

Thank you.

Question owner

Thank you for your response but you must have misunderstood my inquiry.

I am perfectly aware of how to clear my Firefox cache and cookies and also aware of what they are.

I fully understand the purpose of storing your addresses, names, email addresses, phone numbers, etc. What I do not understand is why Firefox stores social security numbers. This is a security flaw. I never got FF storing my credit card numbers, so why is it storing SS numbers?

Your solution is only a temporary fix. As soon as I next enter my SS number on a website, Firefox will store it again. I want to prevent this from happening.

Again, if Firefox is not able to discern SS numbers and it is the website's job of distinguishing them to not be stored by the browser, please tell me so that I can notify the website instead.


Thank you.

the-edmeister
  • Top 10 Contributor
  • Moderator
3197 solutions 24405 answers

Helpful Reply

SSN's might get stored as part of form history and not recognized as such, depending upon how the Field Name of the on-page form is labeled. Clear your Form and Search History or don't save that data to begin with.

https://support.mozilla.org/en-US/kb/remove-recent-browsing-search-and-download-history

Or get in the habit of opening a New Private Window when confronted with the need to insert SSN's which might get saved in Form History.

cor-el
  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers

Chosen Solution

Firefox has a built-in algorithm to check for credit card numbers (Luhn), but not for other privacy sensitive numbers.

Question owner

Thanks for the insight, cor-el; just the kind of response I was looking for! Thanks everyone else for your responses also.