X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

This Connection is Untrusted

Posted

Every-time when I Google something I get this dang untrusted Connection.

Example google search:

https://www.google.com/search?q=How+do+I+unhide+windows+hidden+folders&ie=utf-8&oe=utf-8&aq=t&rls=org.mozilla:en-US:official&client=firefox-a

Everything I search is blocked until I confirm the certificate twice. Another search: https://www.google.com/search?q=yahoo&ie=utf-8&oe=utf-8&aq=t&rls=org.mozilla:en-US:official&client=firefox-a

That is blocked too. Google was untrusted till I added it to the trusted site in Firefox

Chosen solution

The top solution seemed to work for a few searches. However, it started right back. (could have been a hiccup too).

Second solution under technical details says: www.google.com uses an invalid security certificate. The certificate is not trusted because the issuer certificate is not trusted. (Error code: sec_error_untrusted_issuer)

I also manually hit get certificate and it still does it.

Read this answer in context 14

Additional System Details

Installed Plug-ins

  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 11.7 r700
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.7
  • Adobe Shockwave for Director Netscape plug-in, version 12.0.2.122
  • 5.1.20125.0
  • VMware Remote Console and Client Integration Plug-in
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20100101 Firefox/22.0

More Information

Removed Firefox and re-installed it. Reset Firefox.

smo 45 solutions 498 answers

Hello,

The Reset Firefox feature can fix many issues by restoring Firefox to its factory default state while saving your essential information. Note: This will cause you to lose any Extensions, Open websites, and some Preferences.

To Reset Firefox do the following:

  1. Go to Firefox > Help > Troubleshooting Information.
  2. Click the "Reset Firefox" button.
  3. Firefox will close and reset. After Firefox is done, it will show a window with the information that is imported. Click Finish.
  4. Firefox will open with all factory defaults applied.

Further information can be found in the Reset Firefox – easily fix most problems article.

Did this fix your problems? Please report back to us!

Thank you.

cor-el
  • Top 10 Contributor
  • Moderator
10780 solutions 97024 answers

Check out why the site is untrusted (click "Technical Details to expand that section) and if this is caused by a missing intermediate certificate then see if you can install this intermediate certificate from another source.

You can retrieve the certificate and check details like who issued certificates and expiration dates of certificates.

  • Click the link at the bottom of the error page: "I Understand the Risks"

Let Firefox retrieve the certificate: "Add Exception" -> "Get Certificate".

  • Click the "View..." button and inspect the certificate and check who is the issuer of the certificate.

You can see more Details like intermediate certificates that are used in the Details pane.

If "I Understand the Risks" is missing then this page may be opened in an (i)frame and in that case try the right-click context menu and use "This Frame: Open Frame in New Tab".

Note that some firewalls monitor secure (https) connections and send their own certificate instead of the website's certificate.

Chosen Solution

The top solution seemed to work for a few searches. However, it started right back. (could have been a hiccup too).

Second solution under technical details says: www.google.com uses an invalid security certificate. The certificate is not trusted because the issuer certificate is not trusted. (Error code: sec_error_untrusted_issuer)

I also manually hit get certificate and it still does it.

emailmeviruses 0 solutions 1 answers

Helpful Reply

Hi

Your firewall is configured to 'ALWAYS SCAN ENCRYPTED CONNECTION'

Chose option 'Scan encrypted connections if Parental Control is enabled' to solve the problem.


Regards.

MadEye 0 solutions 1 answers

Helpful Reply

I am running latest Firefox update (v23) and Kapersky Pure 3.0 on an old Windows XP box that is about to be retired.

I had the same Untrusted Connection error and even abandoned Firefox and used Chrome for awhile. After further investigation, it looks like the error is rooted in my firewall/security software inserting its own Issuer certificate

After receiving Untrusted Connection error, check the Technical Details. My error had to do with the issuer certificate not being trusted. Try to bypass the execption and view the certificate it wants to load. The issuer on the error I was getting was always Kapersky.

Searching Mozilla Support some more yielded the chosen solution from philipp to this post...

... which directs to this Kapersky help page

If Kapersky is your internet security solution

  1. Find your way to settings->advanced settings -> network.
  2. Check the option to scan encrypted connections.
  3. Install the certificate Kapersky provides. (I found that Kapersky could install to Chrome and IE, but failed to install the certificate to Firefox.)
  4. I followed the instructions that were then provided to install the certificate by hand.

I no longer have Untrusted Connection error problems using Firefox on this box.

I hope there are enough breadcrumbs on the thread to help you. Good luck.