X
Tap here to go to the mobile version of the site.

Support Forum

how to autohide bookmark sidebar when cursor not on it

Posted

Hey all, I just updated my firefox and there is one thing that is bugging me. I have the bookmark sidebar button on my bookmark menu. Previously i would click the button and the sidebar would show up and then once i removed my cursor from the sidebar the sidebar would go away.

Once i updated it the sidebar stays unless i click the x, hit ctrl+b, or hit the button. Over all this is rather annoying and i enjoyed that once i was not moused over the sidebar it would automatically close the sidebar.

Iv checked through the options and I dont see what I am looking for, unless iv just totally missed it.

Hey all, I just updated my firefox and there is one thing that is bugging me. I have the bookmark sidebar button on my bookmark menu. Previously i would click the button and the sidebar would show up and then once i removed my cursor from the sidebar the sidebar would go away. Once i updated it the sidebar stays unless i click the x, hit ctrl+b, or hit the button. Over all this is rather annoying and i enjoyed that once i was not moused over the sidebar it would automatically close the sidebar. Iv checked through the options and I dont see what I am looking for, unless iv just totally missed it.

Chosen solution

Maybe it's the two-very-similar-buttons problem? In the Customize dialog, you can't tell which is the bookmarks sidebar button and which is the bookmarks drop-down menu button. However, when you drag them to a toolbar, the drop-down menu button has the word Bookmarks next to it. So you might need to drag either or both to find the one you want.

Note that the bookmarks drop-down menu button only appears when you are using the Compact menu (orange Firefox button). If the full menu bar is displayed, that button is hidden (since you have an equivalent Bookmarks menu on the menu bar).

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Next Generation Java Plug-in 10.25.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 11.7 r700
  • VLC media player Web Plugin 2.0.6
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.03
  • 5.1.20125.0
  • Unity Player 4.0.0f7
  • Picasa plugin
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe Shockwave for Director Netscape plug-in, version 11.5.9.620
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:23.0) Gecko/20100101 Firefox/23.0

More Information

jscher2000
  • Top 10 Contributor
8638 solutions 70669 answers

Helpful Reply

Did it also previously auto-hide if you had opened it using Ctrl+b?

I am not aware of a native feature to auto-hide the sidebar. Could it have been a feature of an extension that was disabled as not compatible with Firefox 23?? You can check for disabled extensions at the bottom of this list (on a gray background):

orange Firefox button (or Tools menu) > Add-ons > Extensions category

Did it also previously auto-hide if you had opened it using Ctrl+b? I am not aware of a native feature to auto-hide the sidebar. Could it have been a feature of an extension that was disabled as not compatible with Firefox 23?? You can check for disabled extensions at the bottom of this list (on a gray background): orange Firefox button (or Tools menu) > Add-ons > Extensions category

Question owner

Honestly I never used ctrl+b to open it so i do not know.

I checked my extensions and none of them look like they would do it (its all stuff from my anti virus that i had disabled anyway).

I checked my add ons and none of them have anything to do with my bookmark ( i tried turning them on just in case).

Honestly I never used ctrl+b to open it so i do not know. I checked my extensions and none of them look like they would do it (its all stuff from my anti virus that i had disabled anyway). I checked my add ons and none of them have anything to do with my bookmark ( i tried turning them on just in case).
jscher2000
  • Top 10 Contributor
8638 solutions 70669 answers

Chosen Solution

Maybe it's the two-very-similar-buttons problem? In the Customize dialog, you can't tell which is the bookmarks sidebar button and which is the bookmarks drop-down menu button. However, when you drag them to a toolbar, the drop-down menu button has the word Bookmarks next to it. So you might need to drag either or both to find the one you want.

Note that the bookmarks drop-down menu button only appears when you are using the Compact menu (orange Firefox button). If the full menu bar is displayed, that button is hidden (since you have an equivalent Bookmarks menu on the menu bar).

Maybe it's the two-very-similar-buttons problem? In the Customize dialog, you can't tell which is the bookmarks sidebar button and which is the bookmarks drop-down menu button. However, when you drag them to a toolbar, the drop-down menu button has the word Bookmarks next to it. So you might need to drag either or both to find the one you want. Note that the bookmarks drop-down menu button only appears when you are using the Compact menu (orange Firefox button). If the full menu bar is displayed, that button is hidden (since you have an equivalent Bookmarks menu on the menu bar).

Question owner

I found the drop down menu button. I was only showing one of those buttons in my customize toolbar options. I clicked the restore defaults and both of them showed up.

I must have had an add on i got rid of without realizing it that auto hides when i mouse off of the menu.

Thanks for the help to find the drop down menu, not exactly what i had before but about ten times better than the sidebar.

Ill go ahead and consider this problem solved as you mentioned that autohide is not a native feature.

thanks again.

I found the drop down menu button. I was only showing one of those buttons in my customize toolbar options. I clicked the restore defaults and both of them showed up. I must have had an add on i got rid of without realizing it that auto hides when i mouse off of the menu. Thanks for the help to find the drop down menu, not exactly what i had before but about ten times better than the sidebar. Ill go ahead and consider this problem solved as you mentioned that autohide is not a native feature. thanks again.