X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

This thread was closed and archived. Please ask a new question if you need help.

Firefox display changed, zoomed in on websites

Posted

My Firefox on a windows 7 HP laptop updated today (June 25th) and the zoom adjusted, changing the font size, as well as icons and zoomed in on websites. I noticed in the list of changes for the program it says "improved rendering on high-res displays" is this the problem and is there anyway I can disable this? I was quite happy with the resolution before, and find this tacky and annoying...

Chosen solution

This post has been revised to include information about an add-on. A copy of the original post appears below the horizontal line.

Firefox now adjusts the page zoom level according to your Windows settings, to better support high DPI displays. For example, if Windows is set to 125% font size (120dpi), the content area will be zoomed by 25% compared with Firefox 21 and earlier.

The straightest line back toward the earlier style of display is the following two step approach:

Step 1: Install the Theme Font & Size Changer extension. Why? Because turning off the scaling affects the chrome area (menus, toolbars, and tabs) as well as the content.

After restarting Firefox, click the new "A" icon at the right end of the navigation toolbar and change the font size from Normal to 15.

Step 2: Change your global scaling in the about:config preferences editor.

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the filter box, type or paste pix and pause while the list is filtered

(3) Double-click layout.css.devPixelsPerPx and change its value to 1.0 for Firefox 21-sized fonts in the content area.

This should take effect immediately without another restart.


Original Post

Firefox now tries to adjust the zoom level according to your Windows settings, as well as better supporting high DPI displays. It's not going to be to everyone's liking.

I still have Fx21 on this computer so I can't test it myself, but could you check the following setting and try adjusting it:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the filter box, type or paste pix and pause while the list is filtered

(3) Double-click layout.css.devPixelsPerPx and change its value to 1.0 to restore the appearance from earlier versions of Firefox for smaller fonts, or a larger ratio for larger fonts. For example, 1.25 corresponds to 125% font size in Windows display settings.

Does that help?

More info in this thread: How do I set the default font size to a lower value?

Read this answer in context 25

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.7 r700
  • Google Update
  • Next Generation Java Plug-in 10.21.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe PDF Plug-In For Firefox and Netscape "9.5.5"
  • GEPlugin
  • iTunes Detector Plug-in
  • 5.1.20125.0
  • DivX VOD Helper Plug-in
  • Adobe Shockwave for Director Netscape plug-in, version 11.5
  • NPWLPG
  • The plug-in allows you to open and edit files using Microsoft Office applications

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20100101 Firefox/22.0

More Information

jscher2000
  • Top 10 Contributor
2357 solutions 20872 answers

Chosen Solution

This post has been revised to include information about an add-on. A copy of the original post appears below the horizontal line.

Firefox now adjusts the page zoom level according to your Windows settings, to better support high DPI displays. For example, if Windows is set to 125% font size (120dpi), the content area will be zoomed by 25% compared with Firefox 21 and earlier.

The straightest line back toward the earlier style of display is the following two step approach:

Step 1: Install the Theme Font & Size Changer extension. Why? Because turning off the scaling affects the chrome area (menus, toolbars, and tabs) as well as the content.

After restarting Firefox, click the new "A" icon at the right end of the navigation toolbar and change the font size from Normal to 15.

Step 2: Change your global scaling in the about:config preferences editor.

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the filter box, type or paste pix and pause while the list is filtered

(3) Double-click layout.css.devPixelsPerPx and change its value to 1.0 for Firefox 21-sized fonts in the content area.

This should take effect immediately without another restart.


Original Post

Firefox now tries to adjust the zoom level according to your Windows settings, as well as better supporting high DPI displays. It's not going to be to everyone's liking.

I still have Fx21 on this computer so I can't test it myself, but could you check the following setting and try adjusting it:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the filter box, type or paste pix and pause while the list is filtered

(3) Double-click layout.css.devPixelsPerPx and change its value to 1.0 to restore the appearance from earlier versions of Firefox for smaller fonts, or a larger ratio for larger fonts. For example, 1.25 corresponds to 125% font size in Windows display settings.

Does that help?

More info in this thread: How do I set the default font size to a lower value?

Modified by jscher2000

Question owner

Thank you for your fast response. I tried that, though the 1.0 value was even smaller than the pre update. I left a value of 0 (hopefully that is safe) and it does look somewhat better, the websites are zoomed more so to my liking. The rest I will adjust to, I just have a bad time with change, ha ha. Thank you.

CanuckianOne 0 solutions 2 answers

I'm having this problem as well, and the above solution didn't help.

I'd really hate for this to make me stop using Firefox...

garrywong 0 solutions 1 answers

Helpful Reply

I also updated Firefox today (June 25th) and now having the same problem. My Windows setting is set to be 125% because otherwise the text is too small for me on my 27inch monitor with 1920x1080 resolution.

After the update everything on firefox is bigger. Not just websites, but all the layout and buttons as well. Now the websites I could just zoom-out (although I don't know how to change the default zoom so I don't have to keep doing it all the time), but the firefox interface itself I can't find a way to make smaller how it used to be.

The layout.css.devPixelsPerPx setting mentioned above makes it much too small (smaller than it used to be) when set to 1, so it looks like I'm out of luck.

I don't understand why developers do this... why always change things that aren't broken =/ Time to trawl google for older firefox version. Let's hope that this gets changed or addressed somehow in the new update or few.

jscher2000
  • Top 10 Contributor
2357 solutions 20872 answers

Hi CanuckianOne, I got on Fx22 (beta) and the default value of -1.0 works out to the same as a manually entered value of 1.25 in a quick test. This matches my Windows 7 font set of 125% so I see where that comes from.

If you play around with that setting, can you get closer to what you want?

Are you using any zoom-related extensions (e.g., DefaultFullZoom or NoSquint)? You might need to check for updates and then check their options to see whether they are adjustable to work with this aspect of Firefox 22.

orange Firefox button (or Tools menu) > Add-ons > Extensions category

To check for updates, click the "gear" icon, then Check for Updates

jscher2000
  • Top 10 Contributor
2357 solutions 20872 answers

Hi garrywong, you wrote:

The layout.css.devPixelsPerPx setting mentioned above makes it much too small (smaller than it used to be) when set to 1, so it looks like I'm out of luck.

Try other values. Don't give up.

I don't understand why developers do this... why always change things that aren't broken =/

Maybe this was added to help MacBook retina display users? That's just a wild guess.

jscher2000
  • Top 10 Contributor
2357 solutions 20872 answers

For anyone who wants to have separate control over the menu/toolbar/chrome area, you could try the following extension. It's not new, since people have wanted to enlarge those areas in the past, but perhaps it will be even more relevant now?

https://addons.mozilla.org/firefox/addon/theme-font-size-changer/

CanuckianOne 0 solutions 2 answers

Thank you for the reply, lots of great info but I still can't get it to look how it did before this awful update

I'm not using any zoom adds ons.

I just have Windows setting is set to be 125% because it's too small on my widescreen monitor otherwise. I've never had a problem before now.

It looks so bad now it's pretty much unusable. Everything is WAY too big, and even if I use ctrl and scroll down twice to unzoom, I have to do that on every single page I go to.

I've been at this for an hour and even uninstalled everything Firefox and reinstalled it to try and get this working. I'm about done with it

jscher2000
  • Top 10 Contributor
2357 solutions 20872 answers

Hi CanuckianOne, if you can't find a workable setting, it might be best to roll back to Firefox 21 and then right-click > Reset that preference.

Over the next few days, we'll get a lot more experience with how different text size and DPI settings work with Firefox 22 and you can try again once there is better documentation.

There are some security issues in Firefox 21, but as between those and your sanity, a downgrade might be the right call.

rcterzi 0 solutions 2 answers

After upgrading to Firefox 22 (from 21.0.x) I believe all of the firefox chrome is the same size but the web page content have all been zoomed by one level. If I do a ctrl '-' to decrease the size one level it seems to me that it looks like Pre-Firefox 22

If I change layout.css.devPixelsPerPx, it changes the zoom level of the web content, but also changes the zoom level of all of the firefox chrome making those items too small now.

Is there a way to get the zoom turned off without having to change the size of all the chrome?

Modified by rcterzi

cor-el
  • Top 10 Contributor
  • Moderator
10749 solutions 96724 answers

Code changes regarding HiDPI have landed in Firefox 22 and later (bug #844604).

You can modify the layout.css.devPixelsPerPx and increase or decrease the value in 0.1 or 0.05 steps to adjust the size of fonts and other elements in Firefox.

  • The layout.css.devPixelsPerPx pref is a String value parsed to a float and allows to fine tune the dimensions of all elements (user interface and web pages) more precisely (resolution 0.1 or 0.05).
  • You can use values between 0.05 and 1.0 to reduce elements in size or use values greater than 1.0 to magnify and make elements larger (percentage divided by DPI, % / DPI).

If the web pages needs to be adjusted after changing this pref then you can look at Default FullZoom Level or NoSquint.

Ketzer 0 solutions 1 answers

Thank you! You made my day :) Theme Font & Size Changer works good.

Modified by Ketzer

smorrissey 0 solutions 6 answers

Come on Mozzilla i've used your browser only for the nosquint extension and no blurry images that chrome brings, now with FF 22 you have the same problem as chrome blurry images everywhere!

Do you want me to change to Chrome? i mean that browser is faster...

jscher2000
  • Top 10 Contributor
2357 solutions 20872 answers

Windows Vista, 7, and 8 have a feature called DPI virtualization which might enlarge the display in some applications. This shouldn't happen with Firefox, but to rule this out, DPI virtualization can be disabled globally (in the Display control panel) or just for Firefox (on the Compatibility tab of the Firefox shortcut properties). If anyone experiments with this, please report on your results.

jscher2000
  • Top 10 Contributor
2357 solutions 20872 answers

Hi smorrissey, what is your Windows DPI setting? Since you already use NoSquint, you can adjust the default zoom level downward to counteract the scaling. This screen shot is from the old days, but it gives the general idea. Does that work?

Question owner

I'm still not 100% happy with it. Icons and pictures are still too big and slightly distorted. The zoom level is normal, and the text is tolerable but it's still 'big'. Almost reminds me of web tv back in the day.

cor-el
  • Top 10 Contributor
  • Moderator
10749 solutions 96724 answers

You can modify the layout.css.devPixelsPerPx and increase or decrease the value in 0.1 or 0.05 steps to adjust the size of fonts and other elements in Firefox.

  • The layout.css.devPixelsPerPx pref is a String value parsed to a float and allows to fine tune the dimensions of all elements (user interface and web pages) more precisely (resolution 0.1 or 0.05).
  • You can use values between 0.05 and 1.0 to reduce elements in size or use values greater than 1.0 to magnify and make elements larger (percentage divided by DPI, % / DPI).
  • http://kb.mozillazine.org/about:config

If web pages needs to be adjusted after changing this pref then you can look at Default FullZoom Level or NoSquint.

jscher2000
  • Top 10 Contributor
2357 solutions 20872 answers

Hi dcmartin91, perhaps try setting the value to 1.0 instead of zero; not sure zero is actually a valid value for this preference. That should return the content display to Firefox 21-size, but it will shrink the menu/toolbar/tab area. You can upsize those by choosing a larger font size in this extension:

Theme Font & Size Changer

Now that I think about it, it probably makes sense to install the extension first and increase the font size (e.g., to 17) before changing the internal setting to 1.0. Otherwise it could get hard to see.

Alanyka 0 solutions 3 answers

Your suggestion seems to help a bit, but the zoom level is not consistent across sites. Prior to the update it was. Now, some sites seem true to size while others seem to be around 150%. Not sure why this is happening. Any advice on how to fix this inconsistency issue? I'd like things to be at a 100% zoom.

jscher2000
  • Top 10 Contributor
2357 solutions 20872 answers

Hi Alanyka, because there are so many different prescription in this thread, could you be more specific about what you've tried so far?