X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox keeps changing my address bar search engine from Google to Yahoo.

Posted

Usually when I go to search for something, I type directly into the address bar. Most of the time it'll automatically just perform a Google search. Recently, however, the search engine has been changing to Yahoo, which is god-awful. I've looked around on the internet for answers but the address bar search engine, as well as the actual search box next to the address bar, keep setting themselves to Yahoo.

What I've done so far: Every time it switches from Google to Yahoo, I open about:config. I search for Yahoo and these pop up: [IMG]http://i44.tinypic.com/2rc1gyg.png/IMG

The status of the items in bold say "user set," but I haven't set any of those. Usually I reset them all to default, sometimes I will change the 2nd, 4th, and 5th items to Google.

I've also gone through my search bar settings and deleted every search engine except Google (these include Yahoo, Bing, Wikipedia, Ebay, Amazon, etc.). However Yahoo will randomly pop up.

I don't know what's causing it. But it's getting really annoying.

If you know how to solve this once and for all, please help!

Thanks for reading!

Chosen solution

Hello, restore your prefer search engine come back from yahoo.com, you can follow the below steps: 1. Open Firefox browser. Click on Tools, then Options, select Privacy. 2. Click “Remove individual cookies.” 3. In the Cookies panel, click on “Show Cookies.” Remove a single cookie click on the entry in the list and click on the “Remove Cookie button.” 4. To remove all cookies click on the “Remove All Cookies button.” 5. Click Tools and select Add-ons. On the Extensions and Plugin tabs search for any suspicious add-ons and remove them. 7. Come back Tools again, this time you need click on “Clear Recent History” and you need clear all recent history. 8. Click on the Start menu go to Control Panel, then click Network and Internet. You then click on the Programs tab, then select Set your default programs.If you want to set Mozilla Firefox or Google Chrome, you can select either of them

Read this answer in context 9

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.6 r602
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Displays Java applet content, or a placeholder if Java is not installed.
  • 5.1.10411.0
  • Facebook Video Calling by Skype
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.4
  • DivX Plus Web Player version 2.2.0.55
  • Plugin to display and edit chemical structures.
  • Picasa plugin.
  • Microsoft Office for Mac SharePoint Browser Plug-in
  • iPhoto6

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:21.0) Gecko/20100101 Firefox/21.0

More Information

Amit Kumar Thakur 83 solutions 863 answers

Hello,

The Reset Firefox feature can fix many issues by restoring Firefox to its factory default state while saving your essential information. Note: This will cause you to lose any Extensions, Open websites, and some Preferences.

To Reset Firefox do the following:

  1. Go to Firefox > Help > Troubleshooting Information.
  2. Click the "Reset Firefox" button.
  3. Firefox will close and reset. After Firefox is done, it will show a window with the information that is imported. Click Finish.
  4. Firefox will open with all factory defaults applied.

Further information can be found in the Reset Firefox – easily fix most problems article.

Did this fix your problems? Please report back to us!

Thank you.

the-edmeister
  • Top 10 Contributor
  • Moderator
3195 solutions 24393 answers

You have a good number of Yahoo related prefs which aren't a standard part of Firefox. Any chance that you installed the Yahoo optimized version of Firefox? Look in Help > About Firefox to see if Yahoo is mentioned.

Otherwise, what Yahoo related add-ons (extensions) do you have installed? Or anything involving searchme installed?

cor-el
  • Top 10 Contributor
  • Moderator
10749 solutions 96724 answers

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window or otherwise make changes.

If you do not keep changes after a restart, see:

waTeim 0 solutions 1 answers

Helpful Reply

Yes I also had this problem... It's almost certainly not some generic error or misconfiguration that some propose. It's a specific problem of what is essentially malware written by "Spigot, Inc." that gets installed whenever you run some other programs. I don't know the entire list of other programs, but includes some popular Bittorrent programs (Mainline and Vuse). There are a number of extensions to remove "shopping by spigot" for example. Nor is this problem just limited to Firefox, it also affects Safari, Chrome, and (probably) Explorer.

The behavior and fix for all of them is similar.

Reset you default home page (it will be yahoo/spigot or something like that) to something reasonable.

Reset your default search engine.

Disable and remove all extensions/plugins by Spigot; some may be harder to find as they have innocuous sounding names like "SearchMe"

Restart.

I don't think that plugins in one browser can reinstall into another browser, but might was well do the same thing for the other browsers as well.

Modified by waTeim

Pat Friedl 0 solutions 1 answers

This is what worked for me:

  1. Numbered list itemIn the search bar, click the down arrow and select Manage Search Engines.
  2. Numbered list itemRemove Bing and set Google as your default
  3. Numbered list itemIn your Firefox settings, select Add Ons and then Extensions - remove any trace of Bing
  4. Numbered list itemNext go to about:config in the address bar. Search for Bing.
  5. Numbered list itemThere are three settings: browser.search.defaultenginename, browser.search.order.1, and browser.search.order.3. Double click each one and set them to Google.
  6. Numbered list itemRestart FireFox and it should be all set.

Hope that helps. DEATH TO BING!

Joey567 0 solutions 1 answers

Helpful Reply

>open a new tab >type about:config in the address bar

make sure 1: browser.fixup.alternate.enabled should be false

2: keyword.enabled should be true

3: keyword.URL should be http://www.google.com/search?ie=UTF-8&oe=UTF-8&q=

Modified by Joey567

Voxophone 0 solutions 1 answers

I made an account just to reply to this topic. I have tried everything you guys mentioned and still nothing. One question, do you have Utorrent installed? I recently updated Utorrent and was clicking through screens when I accidentally clicked a window that said "Accept offer" and from that point on I've had Yahoo as my default... Not sure if it's just a coincidence or not. I wasn't able to read what the window read, since i clicked accept to quickly...

soullink 0 solutions 1 answers

For some reason after I installed a few programs (selectively un-ticking or de-selecting all the add-on's they try and provide with them) all of a sudden my address bar searches were going through Yahoo (normally Google - Yahoo must be the trash of search engines based on the results I was getting).

Anyway, I followed the advice by Joey567 and it worked a treat, even after a reboot.

So, if that doesn't work for you, try resetting Firefox to it's default settings by going to the Firefox button, then "Help" > "Troubleshooting Information". At the top right will be a box titled "Reset Firefox to it's default state" and a button saying "Reset Firefox...". Try that and see what happens.

If that does not fix it, then save / export your bookmarks and uninstall Firefox. Download a fresh install from http://www.mozilla.org/ and see if that plays ball.

If it is still reverting to Yahoo after all that, then I'm afraid you either have a virus or some form of malware. Trend micro offers a free trial on their virus software, plus a "House Call" service which installs a small scanner on your PC then scan's it via the web (it just gives you results, it will not fix your PC - but it gives you an idea what's wrong).

Run Trend's House Call software to find the bugs, then get a 30 day free trial to clear any infection. Before the free trial ends, cancel your subscription as they now use a cloud-based scanning engine, which I've found to eat up a HUGE amount of bandwith (I had a 20Mb cable connection, with tested 19.5 Mb download speed, yet with Trend running it was coming in around 6Mb down!). In their favour I must say I've been using Trend for years and have never had a virus / malware / etc. get through (it just won't let you install it!).

Therefore as the new cloud based system slows my system down and hogs bandwidth, I am looking for a new virus checker (non-cloud-based).

Anyway - best of luck solving your problem, I hope I have helped in one way or another! :D

Modified by soullink

thebadone411 0 solutions 1 answers

I encountered the same problem after updating uTorrent.

I uninstalled uTorrent and reinstalled the original download.

uTorrent works fine and my defaults in Firefox are reset back to what I've always had/wanted.

NO MORE YAHOO!! YAY!!

Hope this helps.

hijacked 0 solutions 1 answers

When I open a new window-yahoo-I start typing in my google search box and it flips to yahoo search. Does this have something to do with yahoo now claiming they beat out google in searches? I want google and only google. Bing did this to me for a while and I got rid of it. What can I do? This is in Safari.

analogpursuits 0 solutions 1 answers

rm -rf *mmayer*

r3dBu11 0 solutions 1 answers

You may have inadvertently installed "Yahoo Search Protection." It will continue to set Yahoo as your default. To uninstall, go into userAccount/AppData/Roaming/SearchProtection. Click on the uninstall icon, and restart Firefox.

michaeltestoni70 3 solutions 12 answers

Chosen Solution

Hello, restore your prefer search engine come back from yahoo.com, you can follow the below steps: 1. Open Firefox browser. Click on Tools, then Options, select Privacy. 2. Click “Remove individual cookies.” 3. In the Cookies panel, click on “Show Cookies.” Remove a single cookie click on the entry in the list and click on the “Remove Cookie button.” 4. To remove all cookies click on the “Remove All Cookies button.” 5. Click Tools and select Add-ons. On the Extensions and Plugin tabs search for any suspicious add-ons and remove them. 7. Come back Tools again, this time you need click on “Clear Recent History” and you need clear all recent history. 8. Click on the Start menu go to Control Panel, then click Network and Internet. You then click on the Programs tab, then select Set your default programs.If you want to set Mozilla Firefox or Google Chrome, you can select either of them

rtemp78 0 solutions 1 answers

None of the solutions posted here worked for me. I did find a solution on another site that suggested going to the Firefox Help, Troubleshooting Information, and clicking on the Reset Firefox in the upper left corner. That worked. In my case I wanted Google back as my default search and that is what I got. It also sped up my browsing. My home page is my.yahoo and it had gotten to the point it had to do a slow refresh every time I opened and closed a tab. Now it works great. Hope this helps

Modified by rtemp78