X
Tap here to go to the mobile version of the site.

Support Forum

How do I find & disable the webroot spy sweeper?

Posted

I'm trying to get rid of the "non-responsive scripts" that freeze up my computer. Drives me crazy! I'm not very computer knowledgeable, so telling me to disable the webroot spy sweeper doesn't help. I have no idea what that is, where to find it, or how to do it. Help!

I'm trying to get rid of the "non-responsive scripts" that freeze up my computer. Drives me crazy! I'm not very computer knowledgeable, so telling me to disable the webroot spy sweeper doesn't help. I have no idea what that is, where to find it, or how to do it. Help!

Chosen solution

Hello cypressmd, as the link in John99's second reply said, probably the problem is an installed extension, try Firefox Safe Mode to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • You can open Firefox 4.0+ in Safe Mode by holding the Shift key when you open the Firefox desktop or Start menu shortcut.
  • Or open the Help menu and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

Once you get the pop-up, just select "'Start in Safe Mode"

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.

Thank you.

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.7 r700
  • MindSpark Toolbar Platform Plugin Stub for 32-bit Windows
  • Google Update
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.7
  • GEPlugin
  • 5.1.20125.0
  • iTunes Detector Plug-in
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe Shockwave for Director Netscape plug-in, version 11.5.9.620
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin

Application

  • Firefox 21.0
  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:21.0) Gecko/20100101 Firefox/21.0
  • Support URL: http://support.mozilla.org/1/firefox/21.0/WINNT/en-US/

Extensions

  • avast! Online Security 8.0.1489 (wrc@avast.com)
  • KnowtheBible 2.73.1.10955 (4lffxtbr@BibleTriviaTime_4l.com)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Yahoo! Toolbar 2.6.0.20130418072822 ({635abd67-4fe9-1b23-4f01-e679fa7484c1})

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) 82865G Graphics Controller
  • adapterDescription2:
  • adapterDeviceID: 0x2572
  • adapterDeviceID2:
  • adapterDrivers: ialmrnt5
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'blockedDriver']
  • directWriteEnabled: False
  • directWriteVersion: 0.0.0.0
  • driverDate: 9-20-2005
  • driverDate2:
  • driverVersion: 6.14.10.4396
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'none'}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 1
  • webglRendererMessage: [u'']
  • windowLayerManagerType: Basic

Modified Preferences

  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.display.background_color: #C0C0C0
  • browser.display.use_system_colors: True
  • browser.places.smartBookmarksVersion: 4
  • browser.startup.homepage_override.buildID: 20130511120803
  • browser.startup.homepage_override.mstone: 21.0
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 21.0
  • keyword.URL:
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1371040159
  • places.history.expiration.transient_current_max_pages: 13369
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • privacy.cpd.sessions: False
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.timeSpan: 0
  • security.warn_viewing_mixed: False

Misc

  • User JS: No
  • Accessibility: No
iamjayakumars 475 solutions 5852 answers
Check here for Non-responsive script *https://support.mozilla.org/en-US/kb/warning-unresponsive-script
Phydeux 0 solutions 6 answers

Helpful Reply

If you have Webroot Spy Sweeper, its going to show up in the Notification Tray (that area next to the clock with all the little icons in it). It should look like a tiny round yellow radar screen or rifle target.

If you right click that, it will give you the option to temporarily or permanently disable SpySweeper, or changing its settings. However, I don't recommend disabling it entirely as this would put your entire computer at risk of spyware or malware getting in. If you look through SpySweeper's options, you may find there's a portion that plugs into Firefox. This can probably also be found by clicking the Firefox menu in the browser and choosing Addons and disabling it there. (Two ways to accomplish the same purpose, much like having a light switch at both the top and bottom of a set of stairs.)

Disabling that Firefox plugin may stop the script errors while allowing Spy Sweeper to keep your computer safe in other ways. You might also want to contact SpySweeper's support to see if they have any fixes for the issue.

If you have Webroot Spy Sweeper, its going to show up in the Notification Tray (that area next to the clock with all the little icons in it). It should look like a tiny round yellow radar screen or rifle target. If you right click that, it will give you the option to temporarily or permanently disable SpySweeper, or changing its settings. However, I don't recommend disabling it entirely as this would put your entire computer at risk of spyware or malware getting in. If you look through SpySweeper's options, you may find there's a portion that plugs into Firefox. This can probably also be found by clicking the Firefox menu in the browser and choosing Addons and disabling it there. (Two ways to accomplish the same purpose, much like having a light switch at both the top and bottom of a set of stairs.) Disabling that Firefox plugin may stop the script errors while allowing Spy Sweeper to keep your computer safe in other ways. You might also want to contact SpySweeper's support to see if they have any fixes for the issue.

Question owner

Thanks for the information. I don't see anything like what you described, so maybe I don't have this webroot spy sweeper. Could it be anything else? It just started about three weeks ago. I never know when it will hit, but it takes a long time to get it to stop. Sometimes I just have to turn the computer off.

Thanks for the information. I don't see anything like what you described, so maybe I don't have this webroot spy sweeper. Could it be anything else? It just started about three weeks ago. I never know when it will hit, but it takes a long time to get it to stop. Sometimes I just have to turn the computer off.
John99
  • Top 25 Contributor
  • Moderator
755 solutions 10296 answers
  • What is the error you see ?
  • Does the error mention webroot ?
  • Is there any pattern to this error that you can identify. For instance does it always happen on startup or when playing videos

Shift+Control+J should open the Error console.

*What is the error you see ? *Does the error mention ''webroot'' ? * Is there any pattern to this error that you can identify. For instance does it always happen on startup or when playing videos Shift+Control+J should open the Error console.

Helpful Reply

No, it doesn't mention webroot. I got that from the Firefox help page. The error warning just says I have a non-responsive script working. There doesn't seem to be any pattern as to when it happens. All of a sudden my computer just stops working. Then sometime later, maybe 15 minutes later, an error message box will appear saying that I have a non-responsive script working. I can either let it continue to see if it will complete, or I can end it. I always try to end it, but sometimes that is unresponsive also. If it does respond, I may have to repeat the process a couple of times, and it is very slow to respond.

No, it doesn't mention webroot. I got that from the Firefox help page. The error warning just says I have a non-responsive script working. There doesn't seem to be any pattern as to when it happens. All of a sudden my computer just stops working. Then sometime later, maybe 15 minutes later, an error message box will appear saying that I have a non-responsive script working. I can either let it continue to see if it will complete, or I can end it. I always try to end it, but sometimes that is unresponsive also. If it does respond, I may have to repeat the process a couple of times, and it is very slow to respond.
John99
  • Top 25 Contributor
  • Moderator
755 solutions 10296 answers

If you look at the error console you may get a related message that you would be able to paste into your next post, it could help us to identify the cause.

If you look at the error console you may get a related message that you would be able to paste into your next post, it could help us to identify the cause. * see also http://kb.mozillazine.org/Unresponsive_Script_Warning#Finding_the_source_of_the_problem

Question owner

This is one of them:

Script: resource://gre/modules/XPCOMUtils.jsm:327

Is that helpful?

This is one of them: Script: resource://gre/modules/XPCOMUtils.jsm:327 Is that helpful?
ideato
  • Top 25 Contributor
773 solutions 5542 answers

Chosen Solution

Hello cypressmd, as the link in John99's second reply said, probably the problem is an installed extension, try Firefox Safe Mode to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • You can open Firefox 4.0+ in Safe Mode by holding the Shift key when you open the Firefox desktop or Start menu shortcut.
  • Or open the Help menu and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

Once you get the pop-up, just select "'Start in Safe Mode"

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.

Thank you.

Hello cypressmd, as the link in '''John99's second reply '''said, probably the problem is an installed extension, '''try Firefox Safe Mode''' to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons. ''(If you're not using it, switch to the Default theme.)'' * You can open Firefox 4.0+ in Safe Mode by holding the '''Shift''' key when you open the Firefox desktop or Start menu shortcut. * Or open the Help menu and click on the '''Restart with Add-ons Disabled...''' menu item while Firefox is running. ''Once you get the pop-up, just select "'Start in Safe Mode"'' '''''If the issue is not present in Firefox Safe Mode''''', your problem is probably caused by an extension, and you need to figure out which one. Please follow the [[Troubleshooting extensions and themes]] article for that. ''To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.'' ''When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.'' Thank you.

Question owner

Hi - Thanks for your suggestions. I did try the "Restart with Add-ons Disabled." About two hours later, I had another Unresponsive Script Warning. Any other thoughts?

Hi - Thanks for your suggestions. I did try the "Restart with Add-ons Disabled." About two hours later, I had another Unresponsive Script Warning. Any other thoughts?

Question owner

Hi - For several days I started Firefox in the safe mode with no problems. I tried starting it regular, and I had a problem almost immediately. I reviewed all programs and looked at everything I had on the computer. I remembered something that I had downloaded not to long ago, so I just deleted it. I have not had a problem now for several days, so I think the problem is solved. I really appreciate all of the help and suggestions. Thanks everyone.

Hi - For several days I started Firefox in the safe mode with no problems. I tried starting it regular, and I had a problem almost immediately. I reviewed all programs and looked at everything I had on the computer. I remembered something that I had downloaded not to long ago, so I just deleted it. I have not had a problem now for several days, so I think the problem is solved. I really appreciate all of the help and suggestions. Thanks everyone.
John99
  • Top 25 Contributor
  • Moderator
755 solutions 10296 answers

Thanks for posting back 'cypressmd. Glad we were able to help you.

Safe Mode can be a bit fiddly to use and may result in a user having to try a few steps afterwards, but in almost all cases if a problem does not occur in Safe Mode at least a workaround will be found.

For those with less patience Firefox Reset may get a faster solution, but may cause more information loss.

Yours seems a slightly odd problem, in that it seems it was a plugin causing the problem, and safe mode does not disable plugins, they need to be manually disabled, or in some cases uninstalled.

Thanks for posting back '''cypressmd''. Glad we were able to help you. [[Troubleshoot Firefox issues using Safe Mode|Safe Mode]] can be a bit fiddly to use and may result in a user having to try a few steps afterwards, but in almost all cases if a problem does not occur in Safe Mode at least a workaround will be found. For those with less patience [[Reset Firefox preferences to troubleshoot and fix problems|Firefox Reset]] may get a faster solution, but may cause more information loss. Yours seems a slightly odd problem, in that it seems it was a plugin causing the problem, and safe mode does not disable plugins, they need to be manually disabled, or in some cases uninstalled.