X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

The font is sometimes blurry for part of the text of the webpage or menu. How do i fix this?

Posted

Often part of the text of a webpage or menu is blurry. For instance when i registered on this site, after clicking on the box to fill in my username the text above it became blurred. Another exemple, when scrolling in the menu with open tab pages serveral lines of text become blurred. This only lasts until i do something for instance scrolling or selecting the text or ctrl+ (using ctrl 0 does not help).

I have a screenshot if i can find a way to upload it here.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.7 r700
  • Google Update
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.7
  • Next Generation Java Plug-in 10.21.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • VLC media player Web Plugin 2.0.6
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealPlayer Download Plugin
  • 5.1.20125.0
  • RealNetworks(tm) RealPlayer Chrome Background Extension Plug-In
  • RealPlayer(tm) HTML5VideoShim Plug-In
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.7.637
  • SOE Web Installer
  • Adobe Shockwave for Director Netscape plug-in, version 11.5
  • NPWLPG

Application

  • Firefox 21.0
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:21.0) Gecko/20100101 Firefox/21.0
  • Support URL: http://support.mozilla.org/1/firefox/21.0/WINNT/en-US/

Extensions

  • Adblock Plus 2.2.4 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • avast! Online Security 8.0.1489 (wrc@avast.com)
  • British English Dictionary 1.19.1 (en-GB@dictionaries.addons.mozilla.org)
  • Delicious Bookmarks 2.3.4 ({2fa4ed95-0317-4c6a-a74c-5f3e3912c1f9})
  • Delicious Extension 2.3.1 (delicious@vjkarunapg.com)
  • Dictionnaire français «Moderne» 4.3 (fr-moderne@dictionaries.addons.mozilla.org)
  • DownThemAll! 2.0.16 ({DDC359D1-844A-42a7-9AA1-88A850A938A8})
  • feedly 14.0.482 (feedly@devhd)
  • gTranslate 0.9 ({aff87fa2-a58e-4edd-b852-0a20203c1e17})
  • HttpFox 0.8.11 ({4093c4de-454a-4329-8aff-c6b0b123c386})
  • Personas Plus 1.7.2.1 (personas@christopher.beard)
  • Pocket 3.0.1 (isreaditlater@ideashower.com)
  • Search Assistant 2.0.1 ({B3834E60-12A8-11E0-A289-939FDFD72085})
  • SOE Web Installer 1.0.3.151 ({000F1EA4-5E08-4564-A29B-29076F63A37A})
  • TinEye Reverse Image Search 1.1 (tineye@ideeinc.com)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: ATI Mobility Radeon HD 4650
  • adapterDescription2:
  • adapterDeviceID: 0x9480
  • adapterDeviceID2:
  • adapterDrivers: aticfx64 aticfx64 aticfx32 aticfx32 atiumd64 atidxx64 atiumdag atidxx32 atiumdva atiumd6a atitmm64
  • adapterDrivers2:
  • adapterRAM: 1024
  • adapterRAM2:
  • adapterVendorID: 0x1002
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.16492
  • driverDate: 4-5-2012
  • driverDate2:
  • driverVersion: 8.961.0.0
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d'}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (ATI Mobility Radeon HD 4650)
  • windowLayerManagerType: Direct3D 10

Modified Preferences

  • accessibility.typeaheadfind: True
  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.cache.memory.capacity: 65536
  • browser.display.show_image_placeholders: True
  • browser.history_expire_days.mirror: 180
  • browser.places.importBookmarksHTML: False
  • browser.places.smartBookmarksVersion: 4
  • browser.privatebrowsing.dont_prompt_on_enter: True
  • browser.search.useDBForOrder: True
  • browser.startup.homepage_override.buildID: 20130511120803
  • browser.startup.homepage_override.mstone: 21.0
  • browser.urlbar.autocomplete.enabled: True
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 21.0
  • gfx.direct3d.prefer_10_1: True
  • network.cookie.prefsMigrated: True
  • network.http.max-connections: 48
  • network.http.max-connections-per-server: 16
  • network.http.max-persistent-connections-per-proxy: 16
  • network.http.max-persistent-connections-per-server: 8
  • network.http.pipelining.maxrequests: 8
  • network.http.request.max-start-delay: 0
  • places.database.lastMaintenance: 1370966493
  • places.history.expiration.transient_current_max_pages: 104858
  • places.history.expiration.transient_optimal_database_size: 167772160
  • places.last_vacuum: 1300613725
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.expose_full_path: True
  • privacy.donottrackheader.enabled: True
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.timeSpan: 4
  • security.warn_viewing_mixed: False

Misc

  • User JS: Yes
  • Accessibility: No

Helpful Reply

Here is an exemple:

Question owner

an exemple of a webpage:

ideato
  • Top 25 Contributor
617 solutions 4263 answers

Helpful Reply

Hello jozeph, try disabling graphics hardware acceleration. Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches.

You might need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.).

Then perform these steps:

  • Click the orange Firefox button at the top left, then select the "Options" button, or, if there is no Firefox button at the top, go to Tools > Options.
  • In the Firefox options window click the Advanced tab, then select "General".
  • In the settings list, you should find the Use hardware acceleration when available checkbox. Uncheck this checkbox.
  • Now, restart Firefox and see if the problems persist.

Additionally, please check for updates for your graphics driver by following the steps mentioned in the following Knowledge base articles:

Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems

Upgrade your graphics drivers to use hardware acceleration and WebGL

Did this fix your problems? Please report back to us!


  • you can also try to set in about:config the gfx.content.azure.enabled pref to false or if this didn't work set the gfx.direct2d.disabled pref to true and leave hardware acceleration otherwise enabled.


Thank you.

cor-el
  • Top 10 Contributor
  • Moderator
10754 solutions 96779 answers

Try to set the gfx.content.azure.enabled pref to false or if this didn't help disable Direct2D by setting the gfx.direct2d.disabled pref to true on the about:config page and leave hardware acceleration otherwise enabled.

That way you still have the benefit from hardware acceleration, but may not suffer from rendering issues.

You can also try to uninstall Windows update KB2670838 if you have this update.


Modified by cor-el

Question owner

I've been using the gfx.direct2d.disabled setting for several days now. I haven't seen anymore blurry text so far. So this seems to have done the trick. Thank you for that.

I had read about the gfx.content.azure.enabled somewhere before. I assumed it was a joke. What it does is turn the right click menu into a back box.

Disabling graphics hardware acceleration crashed my firefox and after restarting it i couldn't get the "save my windows and tabs from last time" feature to work anymore. So i had to use the "reset firefox" button.

RyanJW 0 solutions 1 answers

I was experiencing this too, I've attached an example.

Setting gfx.content.azure.enabled to false as described above fixed it without causing any apparent difference to performance — pages still seem lovely and smooth due to the hardware acceleration.

Interestingly, Firefox isn't the only application where I've encountered this. My code editor (Komodo Edit) suffers from the same issue at times. Anyone know what underlying cause is at play here?

FWIW, my GPU is an ageing AMD 4850. This is probably relevant.