X
Tap here to go to the mobile version of the site.

Support Forum

How to get the 'x' close button by hovering over unselected tabs.

Posted

I miss being able to close tabs without having to select them first. Is there a way to get the old functionality back of having the 'x' close button appear with mouse-over?

I miss being able to close tabs without having to select them first. Is there a way to get the old functionality back of having the 'x' close button appear with mouse-over?

Chosen solution

You could try right-clicking which gives you a menu that lists a 'close tab' option.

Read this answer in context 2

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.7 r700
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Displays Java applet content, or a placeholder if Java is not installed.
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • 5.1.20125.0

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:21.0) Gecko/20100101 Firefox/21.0

More Information

Gingerbread Man 403 solutions 1537 answers

By default the Close buttons appear on all tabs.

  1. Type about:config into the address bar and press Enter.
  2. Press the big button to bypass the warning.
  3. In the search bar, paste browser.tabs.closeButtons
  4. In the search results, double-click browser.tabs.closeButtons and set its value to 1

If you want to hide the Close button on inactive tabs and show it only on mouseover,
1. Install the Stylish add-on.

2. Open the Add-ons Manager, User Styles category and click the Write a New Style link at the top.
3. Paste the following in the style editor box and click the Save button.


@namespace url(http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul);

.tabbrowser-tab:not([selected]) .tab-close-button {
  visibility: hidden !important
}

.tabbrowser-tab:not([selected]):hover .tab-close-button {
  visibility: visible !important
}

If I'm not mistaken, this is also an option in the Tab Mix Plus add-on.

By default the Close buttons appear on all tabs. # Type ''about:config'' into the address bar and press Enter. # Press the big button to bypass the warning. # In the search bar, paste ''browser.tabs.closeButtons'' # In the search results, double-click ''browser.tabs.closeButtons'' and set its value to '''1''' * http://kb.mozillazine.org/Browser.tabs.closeButtons If you want to hide the Close button on inactive tabs and show it only on mouseover, <br>1. Install the Stylish add-on. * https://addons.mozilla.org/firefox/addon/stylish/ 2. Open the Add-ons Manager, User Styles category and click the Write a New Style link at the top. <br>3. Paste the following in the style editor box and click the Save button. ---- <pre><nowiki>@namespace url(http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul); .tabbrowser-tab:not([selected]) .tab-close-button { visibility: hidden !important } .tabbrowser-tab:not([selected]):hover .tab-close-button { visibility: visible !important }</nowiki></pre> ---- If I'm not mistaken, this is also an option in the Tab Mix Plus add-on. * https://addons.mozilla.org/firefox/addon/tab-mix-plus/
cor-el
  • Top 10 Contributor
  • Moderator
12507 solutions 115364 answers

Note that Firefox hides the close button on inactive tabs if there are enough tabs open to make them shrunk below a specific minimum.

Note that Firefox hides the close button on inactive tabs if there are enough tabs open to make them shrunk below a specific minimum. *http://kb.mozillazine.org/browser.tabs.tabClipWidth
Uptown22 4 solutions 23 answers

Chosen Solution

You could try right-clicking which gives you a menu that lists a 'close tab' option.

You could try right-clicking which gives you a menu that lists a 'close tab' option.
cor-el
  • Top 10 Contributor
  • Moderator
12507 solutions 115364 answers

Helpful Reply

The easiest way to close a tab is to middle-click the tab with the mouse scroll wheel.

The easiest way to close a tab is to middle-click the tab with the mouse scroll wheel.

Question owner

Thanks for all your help, everyone!

Thanks for all your help, everyone!
jabcka 0 solutions 1 answers

In about:config change the value of browser.tabs.tabClipWidth to 50.

In about:config change the value of browser.tabs.tabClipWidth to 50.
BigLib 0 solutions 5 answers

You said by default the close button appears on all tabs. Well, now it doesn't. It's been moved to one singular close button on the right that does nothing but slow the work process down.

How do I get a close button to appear on each tab again?

You said by default the close button appears on all tabs. Well, now it doesn't. It's been moved to one singular close button on the right that does nothing but slow the work process down. How do I get a close button to appear on each tab again?
cor-el
  • Top 10 Contributor
  • Moderator
12507 solutions 115364 answers

Helpful Reply

Sounds that the browser.tabs.closeButtons pref has been changed to 3, see:

Sounds that the browser.tabs.closeButtons pref has been changed to 3, see: * http://kb.mozillazine.org/browser.tabs.closeButtons
BigLib 0 solutions 5 answers

Thank you for your reply.

However, I did the about:config thing, and the value for Browser.tabs.closeButtons was already set on 1, which is the default, which should display a button on each tab. I've enclosed a screen shot.

I don't know why this went sideways. FF asked for an update a couple of nights ago, so I let it do the update and then shut it down, because I was done for the night. When I turned it on the next day, that's when the problem appeared, and I hate this browser more and more every day it stays this way.

What else can I try?

Thank you for your reply. However, I did the about:config thing, and the value for Browser.tabs.closeButtons was already set on 1, which is the default, which should display a button on each tab. I've enclosed a screen shot. I don't know why this went sideways. FF asked for an update a couple of nights ago, so I let it do the update and then shut it down, because I was done for the night. When I turned it on the next day, that's when the problem appeared, and I hate this browser more and more every day it stays this way. What else can I try?
cor-el
  • Top 10 Contributor
  • Moderator
12507 solutions 115364 answers

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window.
Start Firefox in <u>[[Safe Mode|Safe Mode]]</u> to check if one of the extensions (Firefox/Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Firefox/Tools > Add-ons > Appearance). *Do NOT click the Reset button on the Safe Mode start window. *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes
BigLib 0 solutions 5 answers

Thank you so much for showing me how to troubleshoot this.

The problem was the "Hide Tab Bar With One Tab 1.2beta" extension. I disabled that, but now I have that annoying single tab when it's the only one open.

Is there a way to resolve that, please?

Thank you so much for showing me how to troubleshoot this. The problem was the "Hide Tab Bar With One Tab 1.2beta" extension. I disabled that, but now I have that annoying single tab when it's the only one open. Is there a way to resolve that, please?
cor-el
  • Top 10 Contributor
  • Moderator
12507 solutions 115364 answers

Install the latest update (beta 3) of the extension.

Install the latest update (beta 3) of the extension. *https://addons.mozilla.org/firefox/addon/hide-tab-bar-with-one-tab/
BigLib 0 solutions 5 answers

You are an absolute genius! Everything is working perfectly again. Thank you so much for all your time today!

I'm back in love with FireFox!

You are an absolute genius! Everything is working perfectly again. Thank you so much for all your time today! I'm back in love with FireFox!
cor-el
  • Top 10 Contributor
  • Moderator
12507 solutions 115364 answers

You're welcome.

You're welcome.