X
Tap here to go to the mobile version of the site.

Support Forum

Popups aren't being blocked

Posted

The last couple of versions of Firefox have seemingly been more permissive in the popup allowing. If I go to http://www.popuptest.com/popuptest12.html, all three popups open with a simple window.open() JavaScript call. The only one that gets blocked is when I click the back button. Shouldn't the ones that open automatically be the ones that get blocked? I've gotten quite a few ad popups, and it's making me wonder if window.open() is being ignored now.

The last couple of versions of Firefox have seemingly been more permissive in the popup allowing. If I go to http://www.popuptest.com/popuptest12.html, all three popups open with a simple window.open() JavaScript call. The only one that gets blocked is when I click the back button. Shouldn't the ones that open automatically be the ones that get blocked? I've gotten quite a few ad popups, and it's making me wonder if window.open() is being ignored now.

Chosen solution

Restart in Safe Mode then back to Normal Mode and once again popups are being blocked. That was really odd.

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.7 r700
  • Version 3.19.1.13088
  • Version 3.18.3.12840
  • Google Talk Plugin Video Accelerator version:0.1.44.28
  • Displays Java applet content, or a placeholder if Java is not installed.
  • Microsoft Office for Mac SharePoint Browser Plug-in
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Plugin that detects installed Citrix Online products (visit www.citrixonline.com).

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:21.0) Gecko/20100101 Firefox/21.0

More Information

Gingerbread Man 403 solutions 1537 answers

window.open(); is not ignored altogether — otherwise harmless pop-ups would be blocked — but it's only honored when triggered by certain events¹, like clicking a link or submitting a form. Pop-ups shouldn't open without any action on your part.

Make sure the "Block pop-up windows" option is checked, and that the site is not on the Exceptions list.

If the problem persists, check if the issue occurs when you start Firefox in Safe Mode.


¹ change click dblclick mouseup reset submit

''window.open();'' is not ignored altogether — otherwise harmless pop-ups would be blocked — but it's only honored when triggered by certain events¹, like clicking a link or submitting a form. Pop-ups shouldn't open without any action on your part. Make sure the "Block pop-up windows" option is checked, and that the site is not on the Exceptions list. * [[Pop-up blocker settings, exceptions and troubleshooting]] If the problem persists, check if the issue occurs when you start Firefox in Safe Mode. * [[Troubleshoot Firefox issues using Safe Mode]] ---- ¹ change click dblclick mouseup reset submit

Question owner

Popup blocker is on because as I said, when I click the back button on that site, the popup window gets blocked. So there's no exceptions for that site either.

Popup blocker is on because as I said, when I click the back button on that site, the popup window gets blocked. So there's no exceptions for that site either.
Gingerbread Man 403 solutions 1537 answers

Which leaves us with my previous question:

If the problem persists, check if the issue occurs when you start Firefox in Safe Mode.
Which leaves us with my previous question: If the problem persists, check if the issue occurs when you start Firefox in Safe Mode. * [[Troubleshoot Firefox issues using Safe Mode]]

Chosen Solution

Restart in Safe Mode then back to Normal Mode and once again popups are being blocked. That was really odd.

Restart in Safe Mode then back to Normal Mode and once again popups are being blocked. That was really odd.
FredMcD
  • Top 10 Contributor
4230 solutions 59038 answers

Go to the Firefox add-ons web page; https://addons.mozilla.org/en-US/firefox/ Search for pop-up or add blockers.

Go to the Firefox add-ons web page; '''''https://addons.mozilla.org/en-US/firefox/''''' Search for '''pop-up''' or '''add''' blockers.
ivanovnegro 1 solutions 12 answers

Adblock Plus could indeed help. That is what I use to block ad popups with just a right click.

Adblock Plus could indeed help. That is what I use to block ad popups with just a right click.
puppydog12 0 solutions 3 answers

Another neat addin is "request policy" . Back to using this and will try to see if it gives any relief. I will report back later. All this happened to me after upgrading to Firefox 22 so i might go back to version 21. Didn't have the problem until the upgrade.

Well changing the about:config didn't work, but so far the "request policy" addin is working just great. Don't allow or give the site permission and the popups are stopped. Some sites you may have to allow because of content but the majority you don't. My popups are gone. Hopefully this changes in version 23 but until my popups are gone for now. Have a look at it and see if it would be suitable for you. Geat addin.


T

Another neat addin is "request policy" . Back to using this and will try to see if it gives any relief. I will report back later. All this happened to me after upgrading to Firefox 22 so i might go back to version 21. Didn't have the problem until the upgrade. Well changing the about:config didn't work, but so far the "request policy" addin is working just great. Don't allow or give the site permission and the popups are stopped. Some sites you may have to allow because of content but the majority you don't. My popups are gone. Hopefully this changes in version 23 but until my popups are gone for now. Have a look at it and see if it would be suitable for you. Geat addin. T

Modified by puppydog12

TonyNemo 0 solutions 4 answers

There are quite a few "extensions" (all ending in 's') but none followed by "tbutton.block.popups;" true or false.

There are quite a few "extensions" (all ending in 's') but none followed by "tbutton.block.popups;" true or false.
TonyNemo 0 solutions 4 answers

With every mouse click I get a window with the message, "Firefox prevented this page from automatically redirecting to another page" but it doesn't prevent the popup. In addition, forums that I visit are peppered with orange highlighted and underlined words that have become links to spam messages. To see if this was a malware issue on my PC, I opened IE and was blessedly free of this maddening phenomena.

This became an issue with the last update. Also, the image loader simply shows the image in isolation and when you use the back arrow, this reply window is empty (having experienced this once, I saved this reply to my clipboard).

With every mouse click I get a window with the message, "Firefox prevented this page from automatically redirecting to another page" but it doesn't prevent the popup. In addition, forums that I visit are peppered with orange highlighted and underlined words that have become links to spam messages. To see if this was a malware issue on my PC, I opened IE and was blessedly free of this maddening phenomena. This became an issue with the last update. Also, the image loader simply shows the image in isolation and when you use the back arrow, this reply window is empty (having experienced this once, I saved this reply to my clipboard).
Gingerbread Man 403 solutions 1537 answers

The person who asked this question has already chosen a solution, and your problems are unrelated. Ask a new question instead of continuing to reply here.


TonyNemo wrote:

There are quite a few "extensions" (all ending in 's') but none followed by "tbutton.block.popups;" true or false. 

Preferences whose names begin with extensions. belong to extensions (which are a type of add-on). You're not going to find them if you don't have the respective add-on installed. Specifically, preferences beginning with extensions.tbutton. belong to the Toolbar Buttons add-on.

TonyNemo wrote:

With every mouse click I get a window with the message, "Firefox prevented this page from automatically redirecting to another page" but it doesn't prevent the popup.

That has nothing to do with pop-ups. It's an accessibility feature that's disabled by default. Though if you're getting the message on every single link, something is wrong. Turn it off under Options - Advanced - General: "Warn me when websites try to redirect or reload the page".

TonyNemo wrote:

In addition, forums that I visit are peppered with orange highlighted and underlined words that have become links to spam messages.

These are usually just regular ads, which you can get rid of with Adblock Plus. If you don't get them in Internet Explorer, then you could have an ad-blocking solution there that you don't have in Firefox, or the ads could be inserted by a Firefox add-on.
To check your computer for malware, install, update then perform a full system scan with MalwareBytes' Antimalware.

TonyNemo wrote:

Also, the image loader simply shows the image in isolation and when you use the back arrow, this reply window is empty (having experienced this once, I saved this reply to my clipboard).

Use the Reset Firefox feature. Verify that the problems have disappeared before beginning to reinstall any add-ons.

The person who asked this question has already chosen a solution, and your problems are unrelated. [https://support.mozilla.org/questions/new Ask a new question] instead of continuing to reply here. ---- ''TonyNemo wrote:'' There are quite a few "extensions" (all ending in 's') but none followed by "tbutton.block.popups;" true or false. Preferences whose names begin with ''extensions.'' belong to extensions (which are a type of add-on). You're not going to find them if you don't have the respective add-on installed. Specifically, preferences beginning with ''extensions.tbutton.'' belong to the [https://addons.mozilla.org/firefox/addon/toolbar-buttons/ Toolbar Buttons] add-on. ''TonyNemo wrote:'' With every mouse click I get a window with the message, "Firefox prevented this page from automatically redirecting to another page" but it doesn't prevent the popup. That has nothing to do with pop-ups. It's an accessibility feature that's disabled by default. Though if you're getting the message on every single link, something is wrong. Turn it off under Options - Advanced - General: "Warn me when websites try to redirect or reload the page". * [[Advanced settings for accessibility, browsing, system defaults, network, updates, and encryption]] ''TonyNemo wrote:'' In addition, forums that I visit are peppered with orange highlighted and underlined words that have become links to spam messages. These are usually just regular ads, which you can get rid of with [https://addons.mozilla.org/firefox/addon/adblock-plus/ Adblock Plus]. If you don't get them in Internet Explorer, then you could have an ad-blocking solution there that you don't have in Firefox, or the ads could be inserted by a Firefox add-on.<br> To check your computer for malware, install, update then perform a full system scan with [http://www.malwarebytes.org MalwareBytes' Antimalware].<br><br> ''TonyNemo wrote:'' Also, the image loader simply shows the image in isolation and when you use the back arrow, this reply window is empty (having experienced this once, I saved this reply to my clipboard). Use the Reset Firefox feature. Verify that the problems have disappeared before beginning to reinstall any add-ons. *[[Reset Firefox – easily fix most problems]]
TonyNemo 0 solutions 4 answers

Reset Firefox eliminated both problems.

Reset Firefox eliminated both problems.
Saad Shamsaee 3 solutions 67 answers
You need to learn this tutorial: http://www.ghacks.net/2013/05/27/how-to-block-mouse-click-popups-in-firefox/

Modified by Saad Shamsaee

TonyNemo 0 solutions 4 answers

I'll certainly refer to it in future but resetting Firefox not only eliminated popups but now (for some reason) links in Thunderbird are opened rapidly in Firefox where there had formerly been a delay.

I'll certainly refer to it in future but resetting Firefox not only eliminated popups but now (for some reason) links in Thunderbird are opened rapidly in Firefox where there had formerly been a delay.
andy33 0 solutions 5 answers

I just discovered this string. I am having pop-ups opening as well. The blocker is on but they still open up. I did a Firefox reset and it didn't help. I was just on a site and a window opens up for lowermybills.com. At the same time, Firefox told me that it prevented this site from opening a pop-up window.

Obviously something isn't working. Can anyone help?

I just discovered this string. I am having pop-ups opening as well. The blocker is on but they still open up. I did a Firefox reset and it didn't help. I was just on a site and a window opens up for lowermybills.com. At the same time, Firefox told me that it prevented this site from opening a pop-up window. Obviously something isn't working. Can anyone help?
nsew45 0 solutions 3 answers

I was having similar problems with popups dropdowns and whole new windows opening. I ran all the malware and rootkit tools. I did a Firefox reset. When I went to the addons page extensions right after the reset I noted an addon titled Linkcsicle. I removed Linksickle from the extensions. I then went to Control Panel, Programs and features and removed Linksickle. It gets installed when doing a download of other programs. It won't be identified as a malware, virus, etc. except that it bypasses Firefox adblock, popup blockers. Once I removed Linksickle as an add-on and from Windows 8.1 as a program, the pop-ups and unwanted new windows problem went away.

I was having similar problems with popups dropdowns and whole new windows opening. I ran all the malware and rootkit tools. I did a Firefox reset. When I went to the addons page extensions right after the reset I noted an addon titled Linkcsicle. I removed Linksickle from the extensions. I then went to Control Panel, Programs and features and removed Linksickle. It gets installed when doing a download of other programs. It won't be identified as a malware, virus, etc. except that it bypasses Firefox adblock, popup blockers. Once I removed Linksickle as an add-on and from Windows 8.1 as a program, the pop-ups and unwanted new windows problem went away.