X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

recent documents entry while in privacy mode, lubuntu 12.04

Posted

I'm running FF 21 under Lubuntu 12.04. FF is in privacy mode (history - never). When downloading and saving a file, Firefox adds an entry to the recent documents list stored under ~/.local/share/recently-used.xbel

After recognizing I went to about:config and searched for "recent" I found that the browser.download.manager.addToRecentDocs switch was on. After turning it off and restarting nothing changed, the entry is still attached

IMO FF shouldn't add this entry in privacy mode.

An example entry in recently-used.xbel is attached.

Additional System Details

Installed Plug-ins

  • Version 2.0.3 Twoflower, copyright 1996-2011 VideoLAN and Authorshttp://www.videolan.org/vlc/
  • Gecko Media Player 1.0.4Video Player Plug-in for QuickTime, RealPlayer and Windows Media Player streams using MPlayer

Application

  • User Agent: Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:21.0) Gecko/20100101 Firefox/21.0

More Information

<bookmark href="file:///home/fakeusername/download/firefox-21.0.tar.bz2" added="2013-05-29T21:24:15Z" modified="2013-05-29T21:24:15Z" visited="2013-05-29T21:24:15.147656Z">
<info>
<metadata owner="http://freedesktop.org">
<mime:mime-type type="application/x-bzip-compressed-tar"/>
<bookmark:applications>
<bookmark:application name="Firefox" exec="&apos;firefox %u&apos;" modified="2013-05-29T21:24:15Z" count="1"/>
</bookmark:applications>
</metadata>
</info>
</bookmark>

Question owner

Anyway, here is the entry:

 <bookmark href="file:///home/jack_shark_mack/download/firefox-21.0.tar.bz2" added="2013-05-29T21:24:15Z" modified="2013-05-29T21:24:15Z" visited="2013-05-29T21:24:15.147656Z">
   <info>
     <metadata owner="http://freedesktop.org">
       <mime:mime-type type="application/x-bzip-compressed-tar"/>
       <bookmark:applications>
         <bookmark:application name="Firefox" exec="'firefox %u'" modified="2013-05-29T21:24:15Z" count="1"/>
       </bookmark:applications>
     </metadata>
   </info>
 </bookmark>
Waka_Flocka_Flame
  • Top 25 Contributor
529 solutions 5045 answers

Yes I have noticed that running Lubuntu 13.04 , it is likely a bug and I feel as there is no direct resolution to this but to find a way to turn off recent documents if possible?

cor-el
  • Top 10 Contributor
  • Moderator
10753 solutions 96760 answers

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window or otherwise make changes.

Question owner

No, Safe Mode is no solution. The entry is still added to the recent documents.

Sure, a workaround would be to turn off recent documents system-wide. But that's not what users expect, and not what I want to do.

What is the "browser.download.manager.addToRecentDocs" switch for? The developer page tells us

"A boolean value that indicates whether or not new downloads should be added to the recent documents list. Default value is true."

Which is contrary to the behavior described here. And has already been discovered two years ago and not yet been solved:

https://bugzilla.mozilla.org/show_bug.cgi?id=646351