Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Site's context menu overrides Firefox's, so there is no built-in spell-checking

  • 2 replies
  • 2 have this problem
  • 107 views
  • Last reply by sachss

more options

When I right-click within a text box, the client program's context menu comes up, not Firefox's, therefore, I can't use Firefox's built-in spell checker options, such as suggested corrections and "add to dictionary." Which is frustrating because the spell checker does find mistakes and new words, but I can't do anything with them because the client program's context menu gets in the way.

Is there some way to either change the built-in spell checker's menu from right-click to say, left-click, or a button on the main browser?

When I right-click within a text box, the client program's context menu comes up, not Firefox's, therefore, I can't use Firefox's built-in spell checker options, such as suggested corrections and "add to dictionary." Which is frustrating because the spell checker does find mistakes and new words, but I can't do anything with them because the client program's context menu gets in the way. Is there some way to either change the built-in spell checker's menu from right-click to say, left-click, or a button on the main browser?

Chosen solution

hello sachss, you can disable the possibility for websites to override the context menu of the browser - enter about:config into the firefox address bar (confirm the info message in case it shows up) & search for the preference named dom.event.contextmenu.enabled. double-click it and change its value to false.

Read this answer in context 👍 3

All Replies (2)

more options

Chosen Solution

hello sachss, you can disable the possibility for websites to override the context menu of the browser - enter about:config into the firefox address bar (confirm the info message in case it shows up) & search for the preference named dom.event.contextmenu.enabled. double-click it and change its value to false.

more options

Thanks, that solved my issue.