X
Tap here to go to the mobile version of the site.

Support Forum

This thread was closed and archived. Please ask a new question if you need help.

My websites and UI have suddenly become huge. How can I get them back to a normal, smaller size?

Posted

Yesterday all of a sudden my webpages and UI appeared to be magnified. While I can zoom out on websites, I cannot find any option to adjust the size of the UI.

I noticed that Firefox 22 (which I am running) has a new feature: "Windows: Firefox now follows display scaling options to render text larger on high-res displays". Is it possible to adjust how Firefox responds to the display scaling options perhaps?

07-27-13 - moderator locked this due to the length of this two month old thread - please post in one of the other threads discussing this issue

Yesterday all of a sudden my webpages and UI appeared to be magnified. While I can zoom out on websites, I cannot find any option to adjust the size of the UI. I noticed that Firefox 22 (which I am running) has a new feature: "Windows: Firefox now follows display scaling options to render text larger on high-res displays". Is it possible to adjust how Firefox responds to the display scaling options perhaps? ''07-27-13 - moderator locked this due to the length of this two month old thread - please post in one of the other threads discussing this issue''

Modified by the-edmeister

Chosen solution

Code changes regarding HiDPI support for high resolution displays have landed in Firefox 22 and later (bug #844604).

You can modify the layout.css.devPixelsPerPx and increase or decrease the value in 0.1 or 0.05 steps to adjust the size of fonts and other elements in Firefox.

  • The layout.css.devPixelsPerPx pref is a String value parsed to a float and allows to fine tune the dimensions of all elements (user interface and web pages) more precisely (resolution 0.1 or 0.05).
  • Change the default value -1 to 1 to make it work like in previous Firefox versions (100%)

Start with a value of 1 and adjust this value with 0.1 steps or 0.05 for finer adjustments.

  • Use values between 1.0 and about 0.5 to reduce elements in size (do NOT go all the way to 0.05!)
  • Use values greater than 1.0 to magnify and make elements larger (percentage divided by DPI, % / DPI).
  • http://kb.mozillazine.org/about:config

If web pages needs to be adjusted after changing this pref then you can look at the Default FullZoom Level or NoSquint extension.

Use this extension to adjust the font size for the user interface:

Read this answer in context 5

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.7 r700
  • Google Update
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.03
  • VLC media player Web Plugin 2.0.6
  • iTunes Detector Plug-in
  • McAfee MSS+ NPAPI Plugin
  • 5.1.20125.0
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Unity Player 3.5.6f4
  • McAfee MSC FF plugin DLL
  • Plugin for Wacom tablets.
  • Wacom Dynamic Link Library
  • NPWLPG
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • Firefox 22.0
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20100101 Firefox/22.0
  • Support URL: http://support.mozilla.org/1/firefox/22.0/WINNT/en-GB/

Extensions

  • Adblock Plus 2.2.4 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Add Bookmark Here ² 17.0.20121128 (abhere2@moztw.org)
  • BetterPrivacy 1.68 ({d40f5e7b-d2cf-4856-b441-cc613eeffbe3})
  • Clipboard 0.4 (clipper-prod@clipboard.com)
  • Firebug 1.11.3 (firebug@software.joehewitt.com)
  • Flagfox 4.2.8 ({1018e4d6-728f-4b20-ad56-37578a4de76b})
  • Ghostery 2.9.5 (firefox@ghostery.com)
  • Integrated Google Calendar 1.2.0 (intgcal@egarracingteam.com.ar)
  • Like.fm Social Music Tracker 1.0.13 (likefm@like.fm)
  • Microsoft .NET Framework Assistant 1.3.1 ({20a82645-c095-46ed-80e3-08825760534b})
  • Muter 0.9.8 (muter@yxl.name)
  • Pocket 3.0.1 (isreaditlater@ideashower.com)
  • Restartless Restart 9 (restartless.restart@erikvold.com)
  • Test Pilot 1.2.2 (testpilot@labs.mozilla.com)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • X-notifier 3.3.1 ({37fa1426-b82d-11db-8314-0800200c9a66})
  • YSlow 3.1.4 (yslow@yahoo-inc.com)
  • Zootool 0.4 (extension@zootool.com)
  • Diigo Toolbar 5.1.0.38 ({fc2b8f80-d9a5-4f51-8076-7c7ce3c67ee3}) (Inactive)
  • feedly 14.0.482 (feedly@devhd) (Inactive)
  • Grooveshark Remote Control 0.3.3 (jid0-louF1d9B6fCB9aYNBoUJcV7HSHw@jetpack) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics Family
  • adapterDescription2: NVIDIA GeForce GT 525M
  • adapterDeviceID: 0x0126
  • adapterDeviceID2: 0x0df5
  • adapterDrivers: igdumd64 igd10umd64 igd10umd64 igdumdx32 igd10umd32 igd10umd32
  • adapterDrivers2: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
  • adapterRAM: Unknown
  • adapterRAM2: 2048
  • adapterVendorID: 0x8086
  • adapterVendorID2: 0x10de
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'']
  • directWriteEnabled: False
  • directWriteVersion: 6.2.9200.16492
  • driverDate: 7-19-2011
  • driverDate2: 12-29-2012
  • driverVersion: 8.15.10.2455
  • driverVersion2: 9.18.13.1090
  • info: {u'AzureContentBackend': u'none', u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo'}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics Family)
  • windowLayerManagerType: Basic

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 1048576
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size_cached_value: 1048576
  • browser.places.smartBookmarksVersion: 4
  • browser.search.useDBForOrder: True
  • browser.startup.homepage: about:home
  • browser.startup.homepage_override.buildID: 20130514181517
  • browser.startup.homepage_override.mstone: 22.0
  • browser.tabs.warnOnClose: False
  • browser.urlbar.default.behavior: 2
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 22.0
  • font.internaluseonly.changed: True
  • general.useragent.extra.microsoftdotnet: ( .NET CLR 3.5.30729; .NET4.0E)
  • gfx.direct2d.disabled: True
  • gfx.direct3d.prefer_10_1: True
  • layers.acceleration.disabled: True
  • network.cookie.lifetimePolicy: 2
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1368858291
  • places.history.enabled: False
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • privacy.clearOnShutdown.offlineApps: True
  • privacy.clearOnShutdown.sessions: False
  • privacy.donottrackheader.enabled: True
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.sanitizeOnShutdown: True
  • security.warn_viewing_mixed: False
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1368369518

Misc

  • User JS: No
  • Accessibility: No

Question owner

JUST TO BE CLEAR:

Before posting this question I did an extensive search on how to solve this problem without finding a permanent fix, so I assumed that it was merely a bug of the Firefox Beta I was running, and that I would just have to wait till the next Firefox update for an actual solution.

In the meantime, I still wanted to view my pages the way I was used to. Therefore I explicitly asked for a way to adjust the display settings, instead of an actual fix.

I hope people will take this into account when reading my initial post and the solution I chose.

JUST TO BE CLEAR: Before posting this question I did an extensive search on how to solve this problem without finding a permanent fix, so I assumed that it was merely a bug of the Firefox Beta I was running, and that I would just have to wait till the next Firefox update for an actual solution. In the meantime, I still wanted to view my pages the way I was used to. Therefore I ''explicitly '' asked for a way to adjust the display settings, instead of an actual fix. I hope people will take this into account when reading my initial post and the solution I chose.
NiklasHall 0 solutions 1 answers

I've just updated to version 22 & it is messing everything up in FF. Everything is zoomed. Wasn't like this before. I agree with MatsSvensson. FF has really messed up big time... It seems like the browser has better performance but who cares if websites gets messed up like this? Since I'm a webdesigner I have several browsers installed. I've always used FF as default browser but was leaning towards moving to Chrome because of performance. Was at first really happy the perfromance boost of FF update but now I'm moving to Chrome...

I've just updated to version 22 & it is messing everything up in FF. Everything is zoomed. Wasn't like this before. I agree with MatsSvensson. FF has really messed up big time... It seems like the browser has better performance but who cares if websites gets messed up like this? Since I'm a webdesigner I have several browsers installed. I've always used FF as default browser but was leaning towards moving to Chrome because of performance. Was at first really happy the perfromance boost of FF update but now I'm moving to Chrome...
buggaz123 0 solutions 3 answers

You guys really screwed up big time. Way to alienate the 95% nongeek population using FF by a senseless modification.

Not only are webpages affected, onthefly corrected though extremely annoying by SHIFT-SCROLL, but the whole aspect of FF is zoomed, including icons, menus, add-ons.

I approximated the prior web page display my adjusting the string in :config but it's still not pleasing, and does very little to also affect the overall look of the program.

You guys really screwed up big time. Way to alienate the 95% nongeek population using FF by a senseless modification. Not only are webpages affected, onthefly corrected though extremely annoying by SHIFT-SCROLL, but the whole aspect of FF is zoomed, including icons, menus, add-ons. I approximated the prior web page display my adjusting the string in :config but it's still not pleasing, and does very little to also affect the overall look of the program.

Modified by James

jscher2000
  • Top 10 Contributor
8582 solutions 70191 answers

Hi NiklasHall and buggaz123, so that we can get a better understanding of how Firefox 22 is working on different Windows setups, could you reply with:

  • Windows OS version (e.g., XP, Vista, 7, 8)
  • Windows DPI setting (e.g., 125% text size, or 120ppi)
  • Firefox layout.css.devPixelsPerPx setting (e.g., default of -1.0 or another setting)

My understanding is that the chrome area (menu, toolbar, tabs) should look like other applications at the default setting (-1.0), while the content area should be zoomed exactly as set in your Windows DPI setting. However, if you do not get that, it would be really helpful to get more detail on where it doesn't work that way.

Hi NiklasHall and buggaz123, so that we can get a better understanding of how Firefox 22 is working on different Windows setups, could you reply with: * Windows OS version (e.g., XP, Vista, 7, 8) * Windows DPI setting (e.g., 125% text size, or 120ppi) * Firefox layout.css.devPixelsPerPx setting (e.g., default of -1.0 or another setting) My understanding is that the chrome area (menu, toolbar, tabs) should look like other applications at the default setting (-1.0), while the content area should be zoomed exactly as set in your Windows DPI setting. However, if you do not get that, it would be really helpful to get more detail on where it doesn't work that way.
jscher2000
  • Top 10 Contributor
8582 solutions 70191 answers

Hi MatsSvensson, thank you for the screen shots.

Do you think the difference in the chrome area (menu, tabs, toolbars) is the 5% difference between 120% and 125%? It may be that Firefox rounds 115.2ppi to 120ppi; I haven't checked the code.

Obviously the content area looks quite different...

Hi MatsSvensson, thank you for the screen shots. Do you think the difference in the chrome area (menu, tabs, toolbars) is the 5% difference between 120% and 125%? It may be that Firefox rounds 115.2ppi to 120ppi; I haven't checked the code. Obviously the content area looks quite different...
MatsSvensson 0 solutions 11 answers

@jscher2000

I don't think that's it. Here are screen-grabs @ 120% (same as before) & 125%

Looks like the same difference as with the other browsers.

@jscher2000 I don't think that's it. Here are screen-grabs @ 120% (same as before) & 125% Looks like the same difference as with the other browsers.

Modified by MatsSvensson

buggaz123 0 solutions 3 answers

jscher2000 :

In my case, the update affected not only the web page display but also the UI in general.

Win XP nvidia graphics 1600x1200 (native) font displaying 120 DPI (125% normal size).

Modifying layout.css.devPixelsPerPx 1.11 helps with web page display and approximates my prior display but not entirely and the UI still looks magnified and icons, tabs etc are fuzzy.

The upgrade on my Win 7 PC has no discernible UI or other display changes.

Notice the indistinct icons, large text.

'''jscher2000''' : In my case, the update affected not only the web page display but also the UI in general. Win XP nvidia graphics 1600x1200 (native) font displaying 120 DPI (125% normal size). Modifying layout.css.devPixelsPerPx 1.11 helps with web page display and approximates my prior display but not entirely and the UI still looks magnified and icons, tabs etc are fuzzy. The upgrade on my Win 7 PC has no discernible UI or other display changes. Notice the indistinct icons, large text.

Modified by buggaz123

jscher2000
  • Top 10 Contributor
8582 solutions 70191 answers

Hi buggaz123, thank you for the report. I don't have any systems with Nvidia, I don't think. Do you already disable hardware graphics acceleration in Firefox? If not could you try that? It works around problems that Firefox has with updated display drivers the developers are not able to test.

You usually need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.).

orange Firefox button (or Tools menu) > Options > Advanced

On the "General" mini-tab, uncheck the box for "Use hardware acceleration when available"

If you restart Firefox, is the toolbar area any less fuzzy?

If not, you might need to go to layout.css.devPixelsPerPx=1.0 and use one of the content zooming extensions to upsize the content area to your preference. cor-el's solution post links to the two best known.

Hi buggaz123, thank you for the report. I don't have any systems with Nvidia, I don't think. Do you already disable hardware graphics acceleration in Firefox? If not could you try that? It works around problems that Firefox has with updated display drivers the developers are not able to test. You usually need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.). orange Firefox button (or Tools menu) > Options > Advanced On the "General" mini-tab, uncheck the box for "Use hardware acceleration when available" If you restart Firefox, is the toolbar area any less fuzzy? If not, you might need to go to layout.css.devPixelsPerPx=1.0 and use one of the content zooming extensions to upsize the content area to your preference. cor-el's solution post links to the two best known.
jscher2000
  • Top 10 Contributor
8582 solutions 70191 answers

Hi SomeDude1212, did you find a solution (and just want to vent) or do you have a question?

Hi SomeDude1212, did you find a solution (and just want to vent) or do you have a question?
cor-el
  • Top 10 Contributor
  • Moderator
17346 solutions 156805 answers

Adjust the layout.css.devPixelsPerPx pref and start with 1.0 and increase or decrease its value from 1.0 in 0.05 or 0.1 steps to get the appearance of the user interface correct (icons and text).

Use this extension to adjust the font size for the user interface.

Use this extension to get the appearance of the web pages correct.

Adjust the layout.css.devPixelsPerPx pref and start with 1.0 and increase or decrease its value from 1.0 in 0.05 or 0.1 steps to get the appearance of the user interface correct (icons and text). *http://kb.mozillazine.org/about:config Use this extension to adjust the font size for the user interface. *Theme Font & Size Changer: https://addons.mozilla.org/firefox/addon/theme-font-size-changer/ *Big Buttons: https://addons.mozilla.org/firefox/addon/big-buttons/ Use this extension to get the appearance of the web pages correct. *Default FullZoom Level: https://addons.mozilla.org/firefox/addon/default-fullzoom-level/
jjan23 0 solutions 9 answers

John31415: How exactly did you revert back to firefox 21. I tried that, but still had the same problem. When you installed it, did it go back to how it was. If so...I'm not sure what I'm doing wrong.

John31415: How exactly did you revert back to firefox 21. I tried that, but still had the same problem. When you installed it, did it go back to how it was. If so...I'm not sure what I'm doing wrong.
john31415 0 solutions 3 answers

When I downgraded to 21 things went from bad to worse, presumably because I'd changed the value of layout.css.devPixelsPerPx and couldn't find the correct setting for it.

Fortunately I had a backup of 21 which I was able to revert to and get back to normal. The default setting in 21 for layout.css.devPixelsPerPx is 1.0 Hope this helps.

When I downgraded to 21 things went from bad to worse, presumably because I'd changed the value of layout.css.devPixelsPerPx and couldn't find the correct setting for it. Fortunately I had a backup of 21 which I was able to revert to and get back to normal. The default setting in 21 for layout.css.devPixelsPerPx is 1.0 Hope this helps.
jjan23 0 solutions 9 answers

Thanks, it seems to be better, not exactly how it was, but pretty close. Thanks alot for your help, and for firefox...you need to fix this...high resolution is the future, it was a mistake to change the DPI settings, and ruin the experience for us high res users, to accommodate those lagging behind the times.

Thanks, it seems to be better, not exactly how it was, but pretty close. Thanks alot for your help, and for firefox...you need to fix this...high resolution is the future, it was a mistake to change the DPI settings, and ruin the experience for us high res users, to accommodate those lagging behind the times.
jscher2000
  • Top 10 Contributor
8582 solutions 70191 answers

Hi jjan23, I think the idea was to help those with higher DPI settings by automatically zooming the content for us. Those who use 100% in Windows are not affected.

Obviously different users have very different preferences for how much their browser content is zoomed, so many people are finding it to be too much.

Hi jjan23, I think the idea was to ''help'' those with higher DPI settings by automatically zooming the content for us. Those who use 100% in Windows are not affected. Obviously different users have very different preferences for how much their browser content is zoomed, so many people are finding it to be too much.
MatsSvensson 0 solutions 11 answers

I for one, put down the cash for a high rez 27" monitor to fit more content on the screen, so I wouldn't have to scroll around so much.

Not to view the same content, only HUGER.

If i wanted that, i could have just bought a regular 1080p monitor for 1/4 of the price.

I for one, put down the cash for a high rez 27" monitor to fit more content on the screen, so I wouldn't have to scroll around so much. '''Not '''to view the same content, only '''HUGER'''. If i wanted that, i could have just bought a regular 1080p monitor for 1/4 of the price.
cor-el
  • Top 10 Contributor
  • Moderator
17346 solutions 156805 answers

Adjust the layout.css.devPixelsPerPx pref and start with 1.0 and increase or decrease its value from 1.0 in 0.05 or 0.1 steps to get the appearance of the user interface correct (icons and text).

Use this extension to adjust the font size for the user interface.

Use this extension to get the appearance of the web pages correct.

Adjust the layout.css.devPixelsPerPx pref and start with 1.0 and increase or decrease its value from 1.0 in 0.05 or 0.1 steps to get the appearance of the user interface correct (icons and text). *http://kb.mozillazine.org/about:config Use this extension to adjust the font size for the user interface. *Theme Font & Size Changer: https://addons.mozilla.org/firefox/addon/theme-font-size-changer/ *Big Buttons: https://addons.mozilla.org/firefox/addon/big-buttons/ Use this extension to get the appearance of the web pages correct. *Default FullZoom Level: https://addons.mozilla.org/firefox/addon/default-fullzoom-level/
jscher2000
  • Top 10 Contributor
8582 solutions 70191 answers

Hi MatsSvensson, that's an excellent point: device pixels come in a wide range of sizes, and what's helpful on my 14" laptop panel may look silly on your 27" panel. Not sure there is a way for Firefox to know that and respond accordingly.

Hi SomeDude1212, as had been said in many posts, if a single value compromise doesn't give you the result you want, you can work around it using an extension. For now, that's the best we can offer you. Please use Help > Submit Feedback to add your voice on how you would prefer Firefox to work.

Hi MatsSvensson, that's an excellent point: device pixels come in a wide range of sizes, and what's helpful on my 14" laptop panel may look silly on your 27" panel. Not sure there is a way for Firefox to know that and respond accordingly. Hi SomeDude1212, as had been said in many posts, if a single value compromise doesn't give you the result you want, you can work around it using an extension. For now, that's the best we can offer you. Please use Help > Submit Feedback to add your voice on how you would prefer Firefox to work.
MatsSvensson 0 solutions 11 answers

"Not sure there is a way for Firefox to know that and respond accordingly. "

Then DONT!

It worked just fine until this half-assed crap was rolled out.

"Not sure there is a way for Firefox to know that and respond accordingly. " Then DONT! It worked just fine until this half-assed crap was rolled out.

Modified by MatsSvensson

mamefox 0 solutions 18 answers

Firefox 22 has a problem with the zoom-function. The standard is now too big. I cannot understand, why Mozilla talkes about addons as a solution of this problem. I think, that mozilla has to solve the problem!

By the way: I have sent screenshots from 4 Browsers. I did not get an answer, only the link to the discussio here. Here I repeat my screenshots.

Mozilla has a problem. Not the firefox-users have to solve the problem, but Mozilla must solve it!

The screenshots show one homepage in Firefox 22, Internet Explorer 10, Google Chrome 26, Safari 5, Opera 12. And now the same homepage again in Firefox 21. The letter-size is in Firefox 22 14 px and in Firefox 16 px. The width of this homepage is 1003 px, so it must look identical in different browsers. Mozilla do not like the picture of the Firefox 21!

Firefox 22 has a problem with the zoom-function. The standard is now too big. I cannot understand, why Mozilla talkes about addons as a solution of this problem. I think, that mozilla has to solve the problem! By the way: I have sent screenshots from 4 Browsers. I did not get an answer, only the link to the discussio here. Here I repeat my screenshots. Mozilla has a problem. Not the firefox-users have to solve the problem, but Mozilla must solve it! The screenshots show one homepage in Firefox 22, Internet Explorer 10, Google Chrome 26, Safari 5, Opera 12. And now the same homepage again in Firefox 21. The letter-size is in Firefox 22 14 px and in Firefox 16 px. The width of this homepage is 1003 px, so it must look identical in different browsers. Mozilla do not like the picture of the Firefox 21!

Modified by mamefox

Blacklisted 1 solutions 27 answers

@ Cor-El:

Quote: "Change the default value -1 to 1 to make it work like in previous Firefox versions (100%)"

When I did that, the result was a miniaturized UI that was worse than the one on steroids. First, the editor wanted to change it from a negative integer (-1) to a decimal floating-point number (1.0). When I modified it again to a positive integer (1), the outcome remained the same.

If the user must restart FF to revert to the previous-version display scaling after setting the value to a positive integer 1, then you need to say that.

Note: if this setting does function as an on/off switch, then a separate setting should have been implemented for the floating-point scaling multiplier. Overloading configuration controls eventually proves to be a very bad practice for a software designer to adopt. Unfortunately, few if any of them will ever read comments posted here.

@ Cor-El: Quote: "Change the default value -1 to 1 to make it work like in previous Firefox versions (100%)" When I did that, the result was a miniaturized UI that was worse than the one on steroids. First, the editor wanted to change it from a negative integer (-1) to a decimal floating-point number (1.0). When I modified it again to a positive integer (1), the outcome remained the same. If the user must restart FF to revert to the previous-version display scaling after setting the value to a positive integer 1, then you need to say that. ''Note:'' if this setting does function as an on/off switch, then a separate setting should have been implemented for the floating-point scaling multiplier. Overloading configuration controls eventually proves to be a very bad practice for a software designer to adopt. Unfortunately, few if any of them will ever read comments posted here.