Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Mozilla is not recognizing Adobe Flash even if I am in the latest version11.7. Other browsers recognize

  • 4 replies
  • 12 have this problem
  • 3 views
  • Last reply by drbob01

more options

I have installed the latest version of adobe flash player available in Adobe site. But the firefox doesnt recognize any flash file and displays"Please install the latest flash player". I have uninstalled and reinstalled several times, but with no help.

Other browsers work perfectly fine and all the flash files are displayed.

My folder C:\Windows\System32\Macromed\Flash contains only 3 files activex.vch Flash32_11_7_700_202.ocx FlashInstall.log

Any help in this regard will be appreciated.

All Replies (4)

more options

Check here, whether your plugin installed or not

manually copy the contents of the

  • C:\WINDOWS\SYSTEM32\Macromed\Flash

folder into

  • C:\Program Files\Mozilla Firefox\plugins
more options

You need to install the Flash Player plugin for Firefox (NPSWF32_11_X_XXX_XXX.dll) if this file is missing in C:\Windows\System32\Macromed\Flash

Latest Flash player versions here:

Modified by cor-el

more options

There are 2 versions of Flash required on Windows systems when you have IE and another browser installed. IE uses the ActiveX version (.ocx) and most other browsers use the Plugin version. On Windows systems with IE and another browser installed, you should always update both.

You can download, SAVE the files to your hard drive, close all browsers, run the installers you just downloaded. Download the "EXE" installers for IE and Plugin based browsers from the following:


You also need to update your installation of VLC Player to the current version. Download, SAVE to hard drive, close all browsers, run the installer.

Modified by TheOldFox

more options

I asked a question about this a couple of days ago and someone gave an answer which I cannot seem to find today... They said (for windows 7 64bit processor) "Go to C:\Windows\SysWOW64\Macromed\Flash and open up mms subdirectory. Open up notepad and add the line ProtectedMode=0 to the mms and save it on your desktop as mms.cfg. Then rename the current mms.cfg to mms.cfgBAK and save it to your desktop for backup if there is a real fix and then copy the saved cfg file to replace the previous one...." This worked for me! I hope it continues to work===Good Luck!