X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How do I remove Bing from my computer?

Posted

I do not like the search engine Bing - it posts nasty images automatically when I pull up my Mozilla Firefox. How can I remove it completely from showing up with Mozilla and if possible how do I make Google automatically be the search engine that accompanies Mozilla?

Chosen solution

Hello,

The Reset Firefox feature can fix many issues by restoring Firefox to its factory default state while saving your essential information. Note: This will cause you to lose any Extensions, Open websites, and some Preferences.

To Reset Firefox do the following:

  1. Go to Firefox > Help > Troubleshooting Information.
  2. Click the "Reset Firefox" button.
  3. Firefox will close and reset. After Firefox is done, it will show a window with the information that is imported. Click Finish.
  4. Firefox will open with all factory defaults applied.

Further information can be found in the Reset Firefox – easily fix most problems article.

Did this fix your problems? Please report back to us!

Thank you.

Read this answer in context 42

Additional System Details

Installed Plug-ins

  • Google Update
  • Shockwave Flash 11.7 r700
  • NPWLPG
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:21.0) Gecko/20100101 Firefox/21.0

More Information

iamjayakumars
  • Top 10 Contributor
412 solutions 4877 answers

Helpful Reply

To Remove the Bing

  1. Move the mouse cursor inside the search box at the top right of the Firefox window and click the down arrow next to the provider's logo.
  2. From the dropdown list, select Manage Search Engines....
  3. Choose the "BING" and click Remove
  4. Click OK to save
lchampeon 0 solutions 2 answers

I tried removing Bing from my search bar - it still shows up as my default search engine!

iamjayakumars
  • Top 10 Contributor
412 solutions 4877 answers

Chosen Solution

Hello,

The Reset Firefox feature can fix many issues by restoring Firefox to its factory default state while saving your essential information. Note: This will cause you to lose any Extensions, Open websites, and some Preferences.

To Reset Firefox do the following:

  1. Go to Firefox > Help > Troubleshooting Information.
  2. Click the "Reset Firefox" button.
  3. Firefox will close and reset. After Firefox is done, it will show a window with the information that is imported. Click Finish.
  4. Firefox will open with all factory defaults applied.

Further information can be found in the Reset Firefox – easily fix most problems article.

Did this fix your problems? Please report back to us!

Thank you.

lchampeon 0 solutions 2 answers

Thank you! It worked like a charm.

zakbas 0 solutions 4 answers

What in the world are you referring to? I see no such items on my Firefox screen. You ought to be a LOT more specific.

the-edmeister
  • Top 10 Contributor
  • Moderator
3195 solutions 24389 answers

zakbas,

Please post a screenshot of your screen.

https://support.mozilla.org/en-US/kb/how-do-i-create-screenshot-my-problem

It is best to use a compressed image type like PNG or JPG to save the screenshot and make sure that you do not exceed a maximum file size of 1 MB.

Then use the Browse .... button below the Post a Reply text box to upload the screenshot.

jaroc4 0 solutions 1 answers

hi, there is a simple way to to it: close to the search window (right top) , there is a "bing" icon click on it to activate a sub_menu.

you get "Manage Search Engines" 

from there you can delete all search engines you don't like and select a default one.

zakbas 0 solutions 4 answers

Helpful Reply

Sorry, I did that and I STILL got some Bing crud. Finally I found a nasty program AND website called CONDUIT, that some crummy company oughta-be-in-JAIL-for-tampering-with-a-computer-system illegally infested my computer with. I removed that program, and made Firefox ignore that web site, and my problem was solved. I don't know why all you guys thought the "Change Search Engine" thing would help... am I the only one who actually had this problem, or did you never have the problem and merely wrote what is SUPPOSED to work?

Modified by zakbas

the-edmeister
  • Top 10 Contributor
  • Moderator
3195 solutions 24389 answers

zakbas,

  1. You made no mention of "Conduit" in your first posting.
  2. You didn't post a screenshot as I asked, and didn't mention which of the three search areas - search bar, URL bar, or default homepage was affected.
  3. My diagnostic crystal ball took an extended holiday around the 4th of July, and was sunning itself at the shore.
  4. Personally, I have never installed any programs which carried malware like Conduit, and I was involved in the user movement to get "Conduit" banned from the official Add-ons Mozilla Org 5 or 6 years ago. You need to be careful what you install on your PC, and where you download programs - the official add-ons website is the safest place to download Firefox add-ons. https://addons.mozilla.org/en-US/firefox/
zakbas 0 solutions 4 answers

Sorry, I had no indication that Conduit was anything at all in the entire universe until I finally saw it on my computer. After my post. So what you are saying is that, indeed, as I suspected, I am the only victim of this garbage here.

I still don't see how Conduit is connected to Bing, but if it is, I blame Microsoft. After Conduit.com, of course.

davec020 0 solutions 1 answers

Bing is a P*ss Take it came and took over, not that I am enamored with Google but I hate having something I haven't asked for being forced on me especially when it is an inferior product like Bing but trying to get rid of it is a nightmare in itself but is possible.

After restoring Google as my home page search engine I was still being directed to Bing for the search results, after much searching for a solution to this I found this method to work.

type

about:config

into the location bar accept the warning and look for

keyword url

right click and choose

modify

find the address of your search engine i.e.

http://www.google.co.uk/

type it in and press OK

This restores Firefox back to Google no more Bing as home page or search results

Hope this helps

Modified by davec020

banglamovieonline 0 solutions 1 answers

I have follow this but when i am restart my PC it works again ..can anybody tell me the solution ..

[link(s) removed by Moderator]

Modified by cor-el

iamjayakumars
  • Top 10 Contributor
412 solutions 4877 answers

Hello,

The Reset Firefox feature can fix many issues by restoring Firefox to its factory default state while saving your essential information. Note: This will cause you to lose any Extensions, Open websites, and some Preferences.

To Reset Firefox do the following:

  1. Go to Firefox > Help > Troubleshooting Information.
  2. Click the "Reset Firefox" button.
  3. Firefox will close and reset. After Firefox is done, it will show a window with the information that is imported. Click Finish.
  4. Firefox will open with all factory defaults applied.

Further information can be found in the Reset Firefox – easily fix most problems article.

Did this fix your problems? Please report back to us!

Thank you.

JoeZyzyx 0 solutions 6 answers

I have the same problem using FF22 on Linux Mint 14. Is a Reset the only option to get rid of this full page BING popup? Mine started after loading Elite Screen Capture from Grizzly Ape, but I did it from the "other versions" link to get the 2.0.0.2 latest version. I have since "disabled" it, but the popups continue about every 5-10 pages I open. I'm hoping something can be removed from "about:config" page to stop this. I removed Bing as my third search engine setting in it, but that didn't make it quit.

JosephLapinski 0 solutions 3 answers

if you want google, got to the site. then you will see at the top it will ask if you want google as you home page. Then if you want yahoo, you will see the same thing to. please rate me.

lindzay18 0 solutions 1 answers

i had the same problem with evil bing i tried everything to get rid of it nothing worked until i reset my firefox and finally bing is gone :) and when i reset firefox it kept my bookbarks cookies and password the only the thing i had redo was my persona which took all of ten seconds so happy

JoeZyzyx 0 solutions 6 answers

I discovered if you completely remove the add-on (not just disable) that gave the BING virus to you, it goes away too. If you know the add-on, also do "about:config" on a page and find what's left of it in there and for each line do right clk and "reset" which will clear it's value box and FF will remove the line, which you can check by refresh of the "about:config" page. It will keep you from the nuclear option of a doing a RESET on FF, keep the extensions and add-ons you already have that are OK. I got my infection from Elite Screen Capture version 2.0.0.2 which does run on FF 22, but not worth those full page BING <iframe> inserts popping up constantly.

zakbas 0 solutions 4 answers

Good one. In my case, even the Reset did not work, I had to remove Conduit.com from my computer... not just an add-on.

pfsoto 0 solutions 5 answers

I have the same problem; i believe the Bing bar & Conduit came with the latest version of ImgBurn, which i recently downloaded :-(

Still haven't gotten rid of the Bing bar...

ianmorison 0 solutions 1 answers

Bing had taken over my homepage , even after it was reset through Tools/Options/General.

To Fix:

Step1 ) In Tools/Options/general change "when Firefox starts " option to " show a blank page"


Re-open a new firefox , Bing has disappeared.

Step 2) Next restore "when firefox starts " back to "show my homepage" , the correct homepage is showing and not bing.

Sounds too simple but its working at the moment.

Modified by ianmorison