X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox doesn't ask what to do with MP3 or video files

Posted

Ever since I upgraded to Firefox 21, Firefox stopped asking me what to do with MP3 or video files. The default action now is to play them in Firefox. I've previously set Firefox to ask what to do with these files. When I go to Applications settings, the setting I made is still there but gets ignored.

I know that I could set media.windows-media-foundation.enabled to false to disable playback for these type of files completely. That's not what I want. I want to be able to play these files in HTML5 audio and video tags.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.7 r700

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:21.0) Gecko/20100101 Firefox/21.0

More Information

philipp
  • Top 10 Contributor
  • Moderator
2054 solutions 8922 answers

Helpful Reply

hello, there seems to be an open bug report for this issue but it hasn't seen much attention yet: https://bugzilla.mozilla.org/show_bug.cgi?id=861090

Question owner

Thank you for the link! I've voted for the bug.

cor-el
  • Top 10 Contributor
  • Moderator
10783 solutions 97065 answers

Can't you right-click the link and use "Save Link as"?

You can also set the browser.altClickSave pref to true on the about:config page.

Then you can hold down the alt key and left-click a link to get an open with dialog.

Question owner

"Save Link as" is the workaround I'm trying to get used to for saving. Always ask still had some benefits for me (DownThemAll integration, "Open with").

With browser.altClickSave set to true, Firefox downloads the file for me (no open with dialog).

Thank you for answering. I guess I'll turn off the playback for now and wait for a fix.

mojomonkey 0 solutions 1 answers

Helpful Reply

I had the same problem. You can disable "windows media foundation"

about:config ------media.windows-media-foundation.enabled = false

-set to 'false'

Now 'mime type' set to 'always ask' works for me.

Modified by mojomonkey

ander111 0 solutions 2 answers

Thanks! Changing that setting's value to "false" fixed it for me—now FF asks me what to do with MP3 files, rather than automatically playing them in the browser.