X
Tap here to go to the mobile version of the site.

Support Forum

Suddenly all mp3s are playing in my browser instead of asking me to save or open my mp3 player.

Posted

This just happened today after a restart. When I click on an mp3 file it now plays internally in the browser. I don't want this.

What I want is what I used to have: I click on an mp3 file and a dialog box opens up asking if I want to play it in my default application (mp3directcut) or save the file.

My Firefox settings are still set to play in mp3directcut for mp3s. I tried changing them to "always ask" and that had no effect. What in Hell is going on? I went for YEARS without problems before today and I changed absolutely nothing, Frustrating!

This just happened today after a restart. When I click on an mp3 file it now plays internally in the browser. I don't want this. What I want is what I used to have: I click on an mp3 file and a dialog box opens up asking if I want to play it in my default application (mp3directcut) or save the file. My Firefox settings are still set to play in mp3directcut for mp3s. I tried changing them to "always ask" and that had no effect. What in Hell is going on? I went for YEARS without problems before today and I changed absolutely nothing, Frustrating!

Chosen solution

cor-el said

You can set media.play-stand-alone to false on the about:config page. You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

Thanks a million! That solved it. I wonder why it changed on me?

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • CANON iMAGE GATEWAY Album Plugin Utility Module for IJ
  • GEPlugin
  • Google Update
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.71.2 for Mozilla browsers
  • Picasa plugin
  • 6.0.12.448
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • Shockwave Flash 20.0 r0
  • 5.1.41212.0
  • NPWLPG

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:44.0) Gecko/20100101 Firefox/44.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
15460 solutions 140015 answers

Helpful Reply

You can set media.play-stand-alone to false on the about:config page.

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

You can set <b>media.play-stand-alone</b> to false on the <b>about:config</b> page. You can open the <b>about:config</b> page via the location/address bar. You can accept the warning and click "I'll be careful" to continue. *http://kb.mozillazine.org/about:config

Chosen Solution

cor-el said

You can set media.play-stand-alone to false on the about:config page. You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

Thanks a million! That solved it. I wonder why it changed on me?

''cor-el [[#answer-846707|said]]'' <blockquote> You can set <b>media.play-stand-alone</b> to false on the <b>about:config</b> page. You can open the <b>about:config</b> page via the location/address bar. You can accept the warning and click "I'll be careful" to continue. *http://kb.mozillazine.org/about:config </blockquote> Thanks a million! That solved it. I wonder why it changed on me?
cor-el
  • Top 10 Contributor
  • Moderator
15460 solutions 140015 answers

You're welcome.

Playing MP3 files via the built-in HTML5 media player is the default.

Note that this pref was previously named media.windows-media-foundation.play-stand-alone, but a lot of media prefs got a shorter name in Firefox 44.

You're welcome. Playing MP3 files via the built-in HTML5 media player is the default. Note that this pref was previously named media.windows-media-foundation.play-stand-alone, but a lot of media prefs got a shorter name in Firefox 44.