X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Why does goolgeearth work with Safari & Chrome but not Firefox

Posted

When in firefox using Google maps and click on "EARTH" I receive a window indicating that to use 3D I need to install 21.0 Google Earth Plug-in with a "Download" option to click on. Note: Firefox 21.0 and MAC OS 10.7.5 have all current software updates installed. Safari & Chrome do not request for any plug-ins and 3D Earth option works fine. ANY HELP?

PS. my MAC does have an Intel HD Graphics 3000 installed but my MAC, Safari & Chrome work fine.

Chosen solution

Google Earth requires a graphics plug-in which comes pre-installed with Chrome and Safari. If Google Earth works on other browsers, installing the Firefox plug-in is the solution. To install this on Firefox, either download it from the prompt window, or go to https://www.google.com/earth/explore/products/plugin.html.

Read this answer in context 3

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.7 r700
  • Displays Java applet content, or a placeholder if Java is not installed.
  • 5.1.20125.0
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.

Application

  • Firefox 21.0
  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:21.0) Gecko/20100101 Firefox/21.0
  • Support URL: http://support.mozilla.org/1/firefox/21.0/Darwin/en-US/

Extensions

  • Awesome screenshot: Capture and Annotate 2.4.0 (jid0-GXjLLfbCoAx0LcltEdFrEkQdQPI@jetpack)
  • New Tab Homepage 0.4.3 ({66E978CD-981F-47DF-AC42-E3CF417C1467})
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription:
  • adapterDeviceID: 0x 116
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: 0x8086
  • driverDate:
  • driverVersion:
  • info: {u'AzureCanvasBackend': u'quartz', u'AzureFallbackCanvasBackend': u'none', u'AzureContentBackend': u'none'}
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Intel Inc. -- Intel HD Graphics 3000 OpenGL Engine
  • windowLayerManagerType: OpenGL

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.startup.homepage: http://www.google.com/
  • browser.startup.homepage_override.buildID: 20130511120803
  • browser.startup.homepage_override.mstone: 21.0
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 21.0
  • gfx.blacklist.webgl.msaa: 4
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1368399492
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • privacy.cpd.cache: False
  • privacy.cpd.cookies: False
  • privacy.cpd.sessions: False
  • privacy.donottrackheader.enabled: True
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.timeSpan: 0
  • security.warn_viewing_mixed: False

Misc

  • User JS: No
  • Accessibility: No
Mike 1 solutions 2 answers

Chosen Solution

Google Earth requires a graphics plug-in which comes pre-installed with Chrome and Safari. If Google Earth works on other browsers, installing the Firefox plug-in is the solution. To install this on Firefox, either download it from the prompt window, or go to https://www.google.com/earth/explore/products/plugin.html.

Question owner

THIS SOLVED MY ISSUE. Google Earth now works in Firefox. Thank you very much

jkellett 0 solutions 4 answers

I did what dolinsky296 suggested, got exactly the same result (will not display in Firefox, will in Chrome and Safari). Google Earth web plug-in.plugin IS in my library/internet plugins folder.

Helpful Reply

JKELLETT, That initially happen to me also. When you go to dolinsky296's suggested website https://www.google.com/earth/explore/products/plugin.html I saw "Download plug-in" box in the middle of the globe. When I click it the download executed but the plug-in never got installed. Then I clicked on "Download Google Earth" in the upper right corner of the website and life was good. Google Earth now works in Firefox.

jkellett 0 solutions 4 answers

At last!! jidzelis suggstion worked. Still weird, though . . .

llangberg2 0 solutions 3 answers

I tried to do the same thing, but there was nothing in the upper-right corner for me to click on to download Google Earth! When I go on Google Maps in Safari, it says the plugin is already installed - In other words, this is NOT a Firefox plugin, and in fact when I look up details, all I found had to do with Internet Explorer!

I went through Firefox and looked up / searched available plugins, and there was nothing for Google Earth even though there were lots of plugins having to do with Google! I don't know what to do about this - I think Mozilla needs to work something out with Google to make a plugin available specifically for Firefox or else to make the existing plugin more compatible with Firefox. I would like to see a response here from Mozilla itself if possible.

Mike 1 solutions 2 answers

llangberg2, you said you were able to use Google Maps in Safari, but Google Earth and Google Maps are separate entities. They may share the same database, but the difference is that Google Earth is rendered in 3D and includes a more extensive JS API. The link in my above solution includes a package or executable, depending on your OS, that installs the Google Earth plug-in. This is only required if a page you're trying to view uses Earth instead of Maps, so make sure JavaScript is enabled in your browser first, as this can cause problems with embedded instances of Maps. The plug-in is universal, so it should work in Safari and Firefox.

llangberg2 0 solutions 3 answers

I appreciate that. However, this happened on Google Maps but still required the Google Earth plugin to see the 3D images (that's what it said). Again, apparently the plugin is already on my computer but is not working right with Firefox. When I go on exactly the same kind of page in Safari, yes it works fine, and when I attempted to install the plugin anyway, I got a message on there stating that it was already installed on my computer.

I understand that maybe there SHOULDN'T be any difference with Firefox, but for some reason, at least on my system, there is.

Question owner

llangberg2 1. bring up Firefox 2. Enter https://www.google.com/earth/explore/products/plugin.html in the address line (not in a search box) then hit "enter or return" key 3. once Google Earth comes up you should see in the upper right corner of the website "Download Google Earth" --- click it.

This is what I did to make Google Earth work on my MAC using Firefox. Good luck ... John

Question owner

llangberg2 -- If you are using the new beta version of the "Google Maps - Lite mode" it does not include the 3D Earth. you can return to the original Maps by selecting to option wheel in the upper left corner. John

Question owner

sorry, my meant my other left. The upper "right" corner.

llangberg2 0 solutions 3 answers

Thank you!!!

It's really weird to me that the install seemed to go pretty much as before, but as you stated, now it does work in Firefox! I'm amazed!