Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Google Earth plug in is not recognized by Firefox (works in Safari and Chrome)

  • 13 replies
  • 23 have this problem
  • Last reply by Kyzer

more options

For some reason Google Earth has stopped working in Firefox, and I get a note that I have to download the plug in. (It works fine in Chrome and Safari.)

I followed the 'solution' in the forum without any success.

When I search for "Google Earth Browser plugin" in Finder, I find SEVEN matching that search under "Kind" in Macintosh HD/Library/Internet Plugins . . .but that "Kind" is associated with plugins that are "Named" something else - e.g., Adobe, DivX, Flash, Flip4Mac, etc. (Weird).

Chosen solution

Hi jscher 2000

Thanks for your information fortunately it's only one app that is effected so can work around it.

Apologies for the late acknowledgment have been out of comms range.

Read this answer in context 👍 1

All Replies (13)

more options

When you say you followed the "solution," do you recall what you tried? Was it this:

Firefox 21 changed the location of the "shared" plugin folder. To force Firefox to scan the old location for plugins languishing there, you can change a Firefox preference. Here's how:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the filter box, type or paste plugins and pause while the list is filtered

(3) Double-click plugins.load_appdir_plugins to switch its value from false to true.

This will take effect after you restart Firefox.

I don't know whether we've had anyone confirm this works on MacOS X, so please report back, yea or nay.

more options

Sorry, didn't change a thing. . . thanx for trying, though.

more options

As a Windows user, I'm not sure I can help further. In case you don't have them handy:

more options

I too had this issue, solved by updating Java to 7u25 and reinstalling Google Earth.

1. Search the web using "java se download", select "Java SE Downloads - Oracle" which took me to "" I wish to thank the company "Secunia" for directing me the Oracle page.

2. Search the web using "google earth plugin reinstall" to reinstall, which took me to "" where there is a message and a link to the reinstall.

I retraced my steps, going back to the "" and still gives me the "error"; not to worry, look at your plugins and google earth plugin is up-to-date.

Re-posted from "Plugin check 'Update Now' link redirects to itself" with updated info.

more options

I was doing a google search for the google earth plugin and took notice of a comment that the Google Earth plugin wasn't working in Firefox. I just checked it this very moment and it is working absolutely fine in Firefox . July 11,2013

more options

You are correct, Google Earth does work with Firefox.

My comment related to what I encountered prior to the java update and the Google Earth reinstall. After the reinstall, Google Earth worked.

Sorry if my writing was confusing; I wanted others know what I did to correct the issue and where I got the files.

more options

It was no trouble at all. Even so, getting to see your user name was reward enough.

Greetings from Planet Mongo msavoy

more options

I am running win 7 64 bit 64 bit Nightly. Have tried all of the above suggestion to no avail I have nil Google add ons in my manager. Still get the response to download Google earth plugin Chrome and IE 10 both 32 bit are working fine. Appreciate any further assistance

Modified by spada01

more options

Hi spada01, because plugins are binary components, different executable files may be needed for 32-bit and 64-bit applications. If you are comfortable using regedit, you could check the following keys to see whether the Google Earth installer lists both a 32-bit AND a 64-bit plugin for Firefox to discover:

  • 32-bit plugins on 64-bit Windows:
  • 64-bit plugins on 64-bit Windows:

You should see various Adobe entries under each, for example.

more options

Hi jscher2000 regedit HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\MozillaPlugins

has 6 entries total 1 adobe 2java 1 mcafe 2 microsoft

The java plugins are the version with a straight \program files\ pathway

HKEY_LOCAL_MACHINE\SOFTWARE\MozillaPlugins Has 20 entries including google earth with an \x86\ pathway Are you sure wow6432 is 64 bit it looks like you might have transposed 64/32 labels

I'm not that familiar with regedit entries I presume this means i don't have a 64 bit version of geplugin can Nightly not use the 32bit version?
more options

Hi spada01, the longer "Wow6432Node\MozillaPlugins" list is used by 32-bit Firefox on 64-bit Windows, while the shorter list is used by 64-bit Firefox. That probably explains the discrepancy between your 64-bit Nightly and the other builds.

One of the limitations on 64-bit browsers is the requirement for 64-bit builds of plugins (because they are binary/executable components). So, unless something has changed since I looked into this last, you can't use 32-bit plugins with 64-bit browsers.

more options

Chosen Solution

Hi jscher 2000

Thanks for your information fortunately it's only one app that is effected so can work around it.

Apologies for the late acknowledgment have been out of comms range.

more options

I too had this problem. I installed Google Earth plugin and Firefox did not recognise it and show it in the list of installed plugins, even though I quit and restarted Firefox.

The first thing I did was follow this plugin troubleshooting guide. It recommended I quit Firefox, delete the pluginreg.dat file, and restart Firefox. I found I had to delete two of these files - one in the top level folder that contains all profiles (~/Library/Application Support/Firefox) and one in my profile folder itself.

Once I did this, the Google Earth plugin appeared in the list of installed plugins. I'm not sure why Firefox couldn't realise there had been a new plugin without this step.