Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Bookmarks toolbar playing hide-and-seek

  • 11 replies
  • 78 have this problem
  • 17287 views
  • Last reply by geckohale

more options

I had my bookmarks toolbar enabled (View - Toolbars - Bookmarks Toolbar). Yesterday, the toolbar disappeared. On the View-Toolbars menu, Bookmarks Toolbar was still selected. I unselected it and the toolbar appeared. Although now, Bookmarks Toolbar on the menu was unselected. Next time I started Firefox, the toolbar was gone again. I selected it from the menu and it reappeared. But next time I started it, it was gone again and Bookmarks Toolbar on the menu was showing as selected.

How do I fix this?

Firefox 20.0.1 on XP SP3

Chosen solution

I really didn't have any interest in finding the exact source of the problem, so I went with the nuclear option (the Reset button) and I think that has fixed the problem. I am restoring a few minor customizations I had made over the years (such as turning off the awful built-in PDF reader that appeared a couple releases back).

Read this answer in context 👍 1

All Replies (11)

more options

You can check for problems with the localstore.rdf file.


Make sure that toolbars like the "Navigation Toolbar" and the "Bookmarks Toolbar" are visible.

  • Firefox menu button > Options
  • View > Toolbars (press F10 to display the menu bar)
  • right-click empty toolbar area

Use Toolbar Layout (Customize) to open the Customize window and set which toolbar items to display.

  • check that "Bookmarks Toolbar items" is on the Bookmarks Toolbar
  • if "Bookmarks Toolbar items" is not on the Bookmarks Toolbar then drag it back from the toolbar palette into the customize window to the Bookmarks Toolbar
  • if missing items are in the toolbar palette then drag them back from the Customize window on the toolbar
  • if you do not see an item on a toolbar and in the toolbar palette then click the "Restore Default Set" button to restore the default toolbar set up
more options

Deleting the localstore.rdf and restarting Firefox, did not solve the problem.

I will also note that simply opening the View - Toolbars - Customize window, and then closing it without changing anything, will cause the Bookmarks Toolbar Items to appear again.

more options

Hello??? No one else has reported this problem?

more options

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window or otherwise make changes.

You can check for problems with preferences and rename or delete the prefs.js file and possible numbered prefs-##.js files and a possible user.js file to reset all prefs to the default values.

more options

Chosen Solution

I really didn't have any interest in finding the exact source of the problem, so I went with the nuclear option (the Reset button) and I think that has fixed the problem. I am restoring a few minor customizations I had made over the years (such as turning off the awful built-in PDF reader that appeared a couple releases back).

more options

I cannot figure it out. Sometimes the bookmarks toolbar will be half "submerged", sometimes it's not even there and sometimes it works fine.

Can't get rid of this bug. Disabling Roomy bookmarks toolbar, hardware acceleration, webgl, etc and it still does it without fail.

Mozilla really need to fix this, because it started happening in 19 and now it's even worse in 21.0. No amount of troubleshooting has found a suitable solution to the problem.

Resetting Firefox is NOT a solution. Seems I have to do this every new version because it's constantly being broken.

The only time the bookmarks toolbar behaves properly is when Firefox is in Safe Mode.

Modified by raffieltiger

more options

Are you using the default theme?

Try to disable hardware acceleration in Firefox.

more options

Makes absolutely no difference.

I don't know why people keep suggesting the SAME THING.

Turn off hardware acceleration, disable webgl, troubleshoot extensions and IT STILL DOES IT.

more options

I had this same problem, I just fixed it by disabling Tab Mix Plus.

more options

I discovered that by running Firefox as administrator solved all ills. In Win 7 pro, navigate to Firefox.exe, right mouse and select 'run as administrator'.

more options

I have had the disappearing toolbar problem randomly but repeatedly since last year. It works for a while, then it disappears never to return.

I finally found an answer that works for me, although it is irritating that I have to do work-arounds after all this time!! And doing RESET is not an option as I have too many customizations. That's like telling me to delete all my cookies or bookmarks!!

Anyway, I have never tried just deleting the localstore.rdf file and restarting ... but I have an old, old copy dated back in January that I copy over the existing one whenever the toolbar goes away. So far it has always worked to restore it. I don't even have to restart FF.

Wonder if I could do a batch file to delete the localstore.rdf after every FF and see if that would prevent the problem in the first place?? It obviously doesn't keep current info, so why doesn't FF just get rid of it when they close?

Now if they would fix the damn problem ....

Modified by geckohale