X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Drop-down menu cannot be selected by mouse-clicking

Posted

I'm running FF 20.2 on Mac OS X 10.8.3. I recently found that item in drop-down menu cannot be selected by clicking, although it can be selected by hitting "enter" on keyboard. I have no add-ons installed so that shouldn't be the problem. Like go to http://www.newegg.com/ and click search menu, I can't select any options. Thanks for your help in advance.

Chosen solution

Updated to FF 22 and problem solvered.

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Displays Java applet content, or a placeholder if Java is not installed.
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 11.6 r602
  • Microsoft Office for Mac SharePoint Browser Plug-in

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:20.0) Gecko/20100101 Firefox/20.0

More Information

ideato
  • Top 25 Contributor
617 solutions 4263 answers

Hello diandian23,

Try to turning off hardware acceleration, and check it again.


thank you.

Question owner

Thanks ideato for the quick help. Unfortunately turning of the hardware acceleration didn't help with the issue.

ideato
  • Top 25 Contributor
617 solutions 4263 answers

If you already checked the safe mode, then try a clean re-install. Certain Firefox problems can be solved by performing a Clean reinstall. This means you remove Firefox program files and then reinstall Firefox. Please follow these steps:

Note: You might want to print these steps or view them in another browser.

  1. Download the latest Desktop version of Firefox from http://www.mozilla.org and save the setup file to your computer.
  2. After the download finishes, close all Firefox windows (click Exit from the Firefox or File menu).
  3. Delete the Firefox installation folder, which is located in one of these locations, by default:
    • Windows:
      • C:\Program Files\Mozilla Firefox
      • C:\Program Files (x86)\Mozilla Firefox
    • Mac: Delete Firefox from the Applications folder.
    • Linux: If you installed Firefox with the distro-based package manager, you should use the same way to uninstall it - see Install Firefox on Linux. If you downloaded and installed the binary package from the Firefox download page, simply remove the folder firefox in your home directory.
  4. Now, go ahead and reinstall Firefox:
    1. Double-click the downloaded installation file and go through the steps of the installation wizard.
    2. Once the wizard is finished, choose to directly open Firefox after clicking the Finish button.

Please report back to see if this helped you!


thank you

ndemoreau 0 solutions 4 answers

Helpful Reply

I'm having the same issue. Tried reset, reinstall, deleted all addons.

Nothing changed.

Quite a pain. I'm a developer and Firefox is my primary browser...

Dron Rathore 5 solutions 46 answers

This problem has been answered earlier Fx Mouse Scroll Try Resetting your firefox: New Tab > Type about:support > Click on Reset Firefox and you are done! Cheers!

ndemoreau 0 solutions 4 answers

I did a reset but it didn't help.

For now, I rolled back to version 19 and I'm happy again.

Hope it will be fixed in version 21.

Manachi 0 solutions 1 answers

Helpful Reply

I have this same problem too on FireFox 20.0 on OSX 10.7.5 and none of the above solutions fixed it. This is an extremely critical bug. Select/dropdown lists not working? Really?

ndemoreau 0 solutions 4 answers

It automatically upgraded back to v20 without even asking me... :-(((

KU13 0 solutions 2 answers

I am also having this problem. None of the above tips helped. I have FF version 21.

Another problem I'm having (is it related?) is that I can't minimize or maximize the window.

I also can't click the "x" to close down pop-up windows either.

Any help would be appreciated.

cor-el
  • Top 10 Contributor
  • Moderator
10752 solutions 96760 answers

Do a clean reinstall and delete the Firefox program folder before (re)installing a fresh copy of the current Firefox release.

Download a fresh Firefox copy and save the file to the desktop.

Uninstall your current Firefox version, if possible, to cleanup the Windows registry and settings in security software.

  • Do NOT remove personal data when you uninstall your current Firefox version, because all profile folders will be removed and you will lose all personal data like bookmarks and passwords from profiles of other Firefox versions.

Remove the Firefox program folder before installing that newly downloaded copy of the Firefox installer.

  • (32 bit Windows) "C:\Program Files\Mozilla Firefox\"
  • (64 bit Windows) "C:\Program Files (x86)\Mozilla Firefox\"

Your bookmarks and other personal data are stored in the Firefox profile folder and won't be affected by an uninstall and (re)install, but make sure that "remove personal data" is NOT selected when you uninstall Firefox.

If you keep having problems then also create a new profile.


KU13 0 solutions 2 answers

Thanks. I was able to get my husband to help me and the above suggestion didn't work. However, that's because it was a problem with my mouse driver. I guess an update from Windows 8 made my mouse be incompatible. He was able to fix it somehow and I am no longer having issues.

So, this turned out to not be related to FF.

holmesc1111 0 solutions 1 answers

We are using Firefox 21 and Mac OS 10.8.3 and have the same issue.

ejsteven 1 solutions 2 answers

Firefox 21 OSX 10.8.4

Have issue. Tried all of the above. No luck.

ejsteven 1 solutions 2 answers

Chosen Solution

Updated to FF 22 and problem solvered.

gozerdozer 0 solutions 1 answers

I just updated to Firefox 22 and this is happening to me now. I check my email at mail.aol.com and for some reason the menus are not working after I login to check my mail. This does not happen in IE or Chrome, only Firefox. I tried a fresh re-install and it worked the first time but then when I logged out and logged in to my mail again it happened again. I also tried running in safe mode, reinstalling again, and all of the suggestions above. Nothing is working. I am thinking it may have something to do with Java, but not sure what the issue is as other menus on other websites work just fine. Please fix this as I need to be able to check my mail and use Firefox...I really don't want to use IE.

jscher2000
  • Top 10 Contributor
2365 solutions 20922 answers

Hi gozerdozer, could you try Firefox's Safe Mode? That's a standard diagnostic tool to bypass interference by extensions (and some custom settings). More info: Troubleshoot Firefox issues using Safe Mode.

You can restart Firefox in Safe Mode using

Help > Restart with Add-ons Disabled

In the dialog, click "Start in Safe Mode" (not Reset)

Any difference? See you tried that


More generally, when you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Bypass Firefox's Cache

Use Ctrl+Shift+r to reload the page fresh from the server.

Alternately, you also can clear Firefox's cache completely using:

orange Firefox button (or Tools menu) > Options > Advanced

On the Network mini-tab > Cached Web Content : "Clear Now"

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site:

  • right-click and choose View Page Info > Security > "View Cookies"
  • Alt+t (open the classic Tools menu) > Page Info > Security > "View Cookies"

In the dialog that opens, you can remove your aol.com cookies individually.

Then try reloading the page. Does that help?

Modified by jscher2000

Ahmedk218 0 solutions 2 answers

same problem

a new windows 8

and new pale moon x64 - base on firefox 24.0

first tab ^_^ fresh clean

no use hardware acceleration when available

the drop down list in asp.net websites is not clickable

working fine in IE and chrome

Modified by Ahmedk218

jscher2000
  • Top 10 Contributor
2365 solutions 20922 answers

Hi Ahmedk218, can you give a link to an example website that has this problem and describe which drop-down it is?

Windows 8 systems sometimes have issues with "touch" support blocking mouse access, so you might want to try disabling that as described in this thread: When trying to click on menus on USAA, it shows "javascript:;" in the bottom left hand corner and the menu won't work in FF 21. But the menus work in IE 10.

Ahmedk218 0 solutions 2 answers

http://reg.ppu.edu/Default.aspx

you need a login that's a problem but in that page i got 2 other problems i think its related to each others

first - you cant highlight words but you can in chrome

2nd - is that i cant move from textboxs to other by mouse to login but you can in chrome

Modified by Ahmedk218