X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

There are weird line/marks above the buttons randomly. (Picture)

Posted

It started happening randomly in Firefox 19 I believe. Also, the Google homepage scrolls vertically, about an inch, and it's annoying. Picture: http://oi36.tinypic.com/2jaxa9.jpg

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.7 r700

Application

  • Firefox 20.0.1
  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:20.0) Gecko/20100101 Firefox/20.0
  • Support URL: http://support.mozilla.org/1/firefox/20.0.1/WINNT/en-US/

Extensions

  • Adblock Plus 2.2.3 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • FlashGot 1.5.5.2 ({19503e42-ca3c-4c27-b1e2-9cdb2170ee34})
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Mobile Intel(R) 4 Series Express Chipset Family
  • adapterDescription2:
  • adapterDeviceID: 0x2a42
  • adapterDeviceID2:
  • adapterDrivers: igdumdx32 igd10umd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • clearTypeParameters: Gamma: 2200 Pixel Structure: RGB ClearType Level: 100 Enhanced Contrast: 50
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.16492
  • driverDate: 10-13-2011
  • driverDate2:
  • driverVersion: 8.15.10.2555
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d'}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (Mobile Intel(R) 4 Series Express Chipset Family)
  • windowLayerManagerType: Direct3D 10

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.search.useDBForOrder: True
  • browser.startup.homepage: https://www.google.com/
  • browser.startup.homepage_override.buildID: 20130409194949
  • browser.startup.homepage_override.mstone: 20.0.1
  • browser.tabs.warnOnClose: False
  • browser.tabs.warnOnOpen: False
  • browser.urlbar.autocomplete.enabled: False
  • browser.urlbar.autoFill: False
  • dom.disable_window_move_resize: True
  • dom.event.contextmenu.enabled: False
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 20.0.1
  • font.name.serif.x-western: Arial
  • gfx.direct3d.checkDX10: False
  • keyword.URL: http://google.com/search?btnI=1&q=
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1366162276
  • places.history.expiration.transient_current_max_pages: 79492
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • privacy.donottrackheader.enabled: True
  • privacy.sanitize.migrateFx3Prefs: True
  • security.warn_viewing_mixed: False

Misc

  • User JS: No
  • Accessibility: No
philipp
  • Top 10 Contributor
  • Moderator
2048 solutions 8916 answers

hello, please try updating your graphics driver, or in case this doesn't solve the issue or there is no new version available at the moment, disable hardware acceleration in firefox > options > advanced > general.

Question owner

Now they appear only when a page is loading and go away only when the page is done loading.

cor-el
  • Top 10 Contributor
  • Moderator
10778 solutions 97002 answers

Did you disable hardware acceleration in Firefox?

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window or otherwise make changes.

Question owner

I only have two add-ons installed and one plug-in enabled. Disabling all of them does nothing. Running in safe mode fixes the problem. Disabling hardware acceleration was not a good fix. Although it made the lines go away, it made all of the fonts render in low resolution. I didn't add or change any hardware or software when this started happening around Firefox 19.

cor-el
  • Top 10 Contributor
  • Moderator
10778 solutions 97002 answers

Helpful Reply

Try to set the gfx.content.azure.enabled pref to false or if this didn't help disable Direct2D by setting the gfx.direct2d.disabled pref to true on the about:config page and leave hardware acceleration otherwise enabled.

You can also try to uninstall Windows update KB2670838 if you have this update.

Helpful Reply

"Try to set the gfx.content.azure.enabled pref to false"

This did the trick, thanks. But, what is this setting used for?

cor-el
  • Top 10 Contributor
  • Moderator
10778 solutions 97002 answers

See http://blog.mozilla.org/joe/2011/04/26/introducing-the-azure-project/

Question owner

Are there any side effects of setting that preference to false?