X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

On a web page with an editable table, the delete row function no longer works (the little circle with X button)

Posted

When you try to delete a row in an editable table using the built-in functions, it no longer works. We use this function regularly and just noticed this problem today. The "create row above" and "create row below" functions work, just not the delete. The delete column button does work however, so it's a bit baffling why this one function does not work. (The pages are located on our internal server so are not publicly accessible but the functionality is built into firefox.)

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.6 r602
  • Next Generation Java Plug-in 10.17.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • GEPlugin
  • Google Update
  • 5.1.20125.0
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe PDF Plug-In For Firefox and Netscape "9.5.1"
  • DivX Web Player version 2.0.3.4
  • Foxit Reader Plug-In For Firefox and Netscape
  • Reader Library Helper Plugin

Application

  • Firefox 20.0.1
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20100101 Firefox/20.0
  • Support URL: http://support.mozilla.org/1/firefox/20.0.1/WINNT/en-US/

Extensions

  • Java Console 6.0.34 ({CAFEEFAC-0016-0000-0034-ABCDEFFEDCBA})
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: ATI Radeon HD 4350
  • adapterDescription2:
  • adapterDeviceID: 0x954f
  • adapterDeviceID2:
  • adapterDrivers: atiumd64 atidxx64 atiumdag atidxx32 atiumdva atiumd6a atitmm64
  • adapterDrivers2:
  • adapterRAM: 512
  • adapterRAM2:
  • adapterVendorID: 0x1002
  • adapterVendorID2:
  • clearTypeParameters: DISPLAY4 [ Gamma: 1800 Pixel Structure: RGB ] DISPLAY5 [ Gamma: 2200 Pixel Structure: RGB ]
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'tryNewerDriver', u'10.6']
  • directWriteEnabled: False
  • directWriteVersion: 6.1.7600.16972
  • driverDate: 8-17-2009
  • driverDate2:
  • driverVersion: 8.632.1.2000
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'cairo', u'AzureFallbackCanvasBackend': u'none', u'AzureContentBackend': u'none'}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (ATI Radeon HD 4350)
  • windowLayerManagerType: Direct3D 9

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.history_expire_days.mirror: 180
  • browser.places.importBookmarksHTML: False
  • browser.places.smartBookmarksVersion: 4
  • browser.privatebrowsing.autostart: True
  • browser.startup.homepage_override.buildID: 20130409194949
  • browser.startup.homepage_override.mstone: 20.0.1
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 20.0.1
  • gfx.blacklist.suggested-driver-version: 10.6
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1365695658
  • places.history.expiration.transient_current_max_pages: 103796
  • places.history.expiration.transient_optimal_database_size: 166073138
  • places.last_vacuum: 1301408566
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • privacy.cpd.downloads: False
  • privacy.cpd.history: False
  • privacy.popups.showBrowserMessage: False
  • privacy.sanitize.migrateFx3Prefs: True
  • security.warn_viewing_mixed: False

Misc

  • User JS: Yes
  • Accessibility: No
Amit Kumar Thakur 83 solutions 863 answers

Hello,

The Reset Firefox feature can fix many issues by restoring Firefox to its factory default state while saving your essential information. Note: This will cause you to lose any Extensions, Open websites, and some Preferences.

To Reset Firefox do the following:

  1. Go to Firefox > Help > Troubleshooting Information.
  2. Click the "Reset Firefox" button.
  3. Firefox will close and reset. After Firefox is done, it will show a window with the information that is imported. Click Finish.
  4. Firefox will open with all factory defaults applied.

Further information can be found in the Reset Firefox – easily fix most problems article.

Did this fix your problems? Please report back to us!

Thank you.

Question owner

Unfortunately, resetting Firefox factory defaults did not solve this problem. Still cannot delete rows in editable tables. (Uploaded image shows which function I'm talking about.)

cor-el
  • Top 10 Contributor
  • Moderator
10751 solutions 96760 answers

Any errors in the "Web Developer > Web Console" (Ctrl+Shift+K) or Error Console (Ctrl+Shift+J)?

Question owner

No errors in either console when attempt to delete row.

thrunx 0 solutions 1 answers

Helpful Reply

Same problem here. I found out that when you have a table with only 1 row, it works fine, but when you have multiple rows, it doesn't work on any row.

Micmark, do you have that too?

P.S. I also tried this outside our CMS, by using Firebug to add a contenteditable="true" on a DIV in a normal font-end template, and that has the same problem.

Question owner

Yes, the one row table will allow you to delete that one row. Appears to be the same problem. We've been having to delete the rows manually by going into the html for now. It hasn't worked properly since the last Firefox update.

hadrianoliver 0 solutions 1 answers

Same issue for me. For what it's worth, it is working fine in Firefox 19.0.