Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Why can't I navigate with my arrows in Firefox 20.0.1?


After I downloaded 20.0.1, I found that I my cursors and tab key no longer functioned within Firefox (they function everywhere else on my laptop). This wasn't a problem until the latest version, but I can't find any solution. I made sure that my Accessibility options were set to make sure my cursor keys would navigate, but it still won't work. This is more than annoying. Help?

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.6 r602
  • Next Generation Java Plug-in 10.17.2 for Mozilla browsers
  • iTunes Detector Plug-in
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.6
  • 5.1.20125.0
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe Shockwave for Director Netscape plug-in, version
  • The plug-in allows you to open and edit files using Microsoft Office applications


  • Firefox 20.0.1
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20100101 Firefox/20.0
  • Support URL: http://support.mozilla.org/1/firefox/20.0.1/WINNT/en-US/


  • Forecastfox 2.2.2 ({0538E3E3-7E9B-4d49-8831-A227C80A7AD3})
  • Norton Toolbar 2013.3.4.3 ({2D3F3651-74B9-4795-BDEC-6DA2F431CB62})
  • Norton Vulnerability Protection - 4 ({BBDA0591-3099-440a-AA10-41764D9DB4DB})
  • SEO Blogger 1.0.8 (seo-blogger@wordtracker.com)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Java Console 6.0.33 ({CAFEEFAC-0016-0000-0033-ABCDEFFEDCBA}) (Inactive)
  • Java Console 6.0.35 ({CAFEEFAC-0016-0000-0035-ABCDEFFEDCBA}) (Inactive)
  • Java Console 6.0.37 ({CAFEEFAC-0016-0000-0037-ABCDEFFEDCBA}) (Inactive)


  • incrementalGCEnabled: True


  • adapterDescription: AMD Radeon HD 6320 Graphics
  • adapterDescription2:
  • adapterDeviceID: 0x9806
  • adapterDeviceID2:
  • adapterDrivers: aticfx64 aticfx64 aticfx64 aticfx32 aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
  • adapterDrivers2:
  • adapterRAM: 384
  • adapterRAM2:
  • adapterVendorID: 0x1002
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'blockedGfxCard']
  • directWriteEnabled: False
  • directWriteVersion: 6.2.9200.16492
  • driverDate: 7-5-2011
  • driverDate2:
  • driverVersion: 8.861.1.2000
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'cairo', u'AzureFallbackCanvasBackend': u'none', u'AzureContentBackend': u'none'}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'blockedGfxCard']
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (AMD Radeon HD 6320 Graphics)
  • windowLayerManagerType: Basic

Modified Preferences

  • accessibility.browsewithcaret: True
  • accessibility.typeaheadfind: True
  • accessibility.typeaheadfind.casesensitive: 1
  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.display.background_color: #C0C0C0
  • browser.display.use_system_colors: True
  • browser.places.smartBookmarksVersion: 4
  • browser.privatebrowsing.dont_prompt_on_enter: True
  • browser.startup.homepage: http://home.verizon.yahoo.com/
  • browser.startup.homepage_override.buildID: 20130409194949
  • browser.startup.homepage_override.mstone: 20.0.1
  • browser.tabs.warnOnClose: False
  • dom.disable_open_during_load: False
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 20.0.1
  • font.name.serif.x-western: Verdana
  • font.size.variable.x-western: 14
  • gfx.blacklist.direct2d: 4
  • gfx.blacklist.layers.direct3d9: 4
  • gfx.direct3d.prefer_10_1: True
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1365512049
  • places.history.expiration.transient_current_max_pages: 96755
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • privacy.clearOnShutdown.cookies: False
  • privacy.clearOnShutdown.formdata: False
  • privacy.clearOnShutdown.sessions: False
  • privacy.cpd.formdata: False
  • privacy.cpd.sessions: False
  • privacy.donottrackheader.enabled: True
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.sanitizeOnShutdown: True
  • privacy.sanitize.timeSpan: 0
  • security.warn_viewing_mixed: False


  • User JS: Yes
  • Accessibility: No
  • Top 10 Contributor
  • Moderator
2043 solutions 8897 answers

Helpful Reply

hello aklein22, please press F7 in order to leave caret browsing mode - then the behaviour should be back to normal...

Question owner

Thanks, When I press Fn7 I'm asked if I want to turn on Caret Browsing, Yes or No. When I press No, nothing happens, unless I'm supposed to restart?

  • Top 10 Contributor
  • Moderator
2043 solutions 8897 answers

yes, caret browsing should stay switched off - your configuration you've submitted orignially shows that it was turned on (accessibility.browsewithcaret: True ) what will interfere with the arrow keys...

  • Top 10 Contributor
  • Moderator
10753 solutions 96760 answers

If caret browsing is enabled ([X] "Always use the cursor keys to navigate within pages") then the cursor keys behave differently.

Question owner

Sorry to belabor this issue, and thanks to all who helped, but...

It seems whether "Allow cursor..." is selected or not, or if I choose "Yes" or "No" on F7 prompts, nothing changes. I probably have the wrong combination chosen, or have/haven't restarted in the right sequence.

You've been great, but this is getting frustrating on my end. This only happened AFTER I downloaded 20.0.1, was fine before. Should I revert FF, which could kill some data, or can I go back a version or two? Or throw my laptop in the ocean?

  • Top 10 Contributor
  • Moderator
10753 solutions 96760 answers

What happens if you use the cursor keys?

When caret browsing is enabled then you get a cursor key if you click with the left mouse button on a web page.
If you see this cursor the cursor key behave differently.

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window or otherwise make changes.

Question owner

And there you go! Thanks, cor-el. I opened in Safe Mode and everything worked. After troubleshooting, found a bad extension (SEO Blogger 1.0.8), which I will now remove and try another version. This was NOT what I expected, but problem solved nonetheless.Thanks again.

  • Top 10 Contributor
  • Moderator
10753 solutions 96760 answers

You're welcome!