X
Tap here to go to the mobile version of the site.

Support Forum

how to remove bing toolbar and prevent it from searching for anything you type in the goto URL box

Posted

This isn't really a question, but I hope it will help some people. I had the bing toolbar appear at the top of firefox, and I tried every suggestion I found to delete it, in addition to ways I already knew. Nothing worked...until I searched through tools/options and found my home page had been changed. I simply changed it back to what it was before bing took over. Now everything is back to normal.

This isn't really a question, but I hope it will help some people. I had the bing toolbar appear at the top of firefox, and I tried every suggestion I found to delete it, in addition to ways I already knew. Nothing worked...until I searched through tools/options and found my home page had been changed. I simply changed it back to what it was before bing took over. Now everything is back to normal.

Chosen solution

Hi I don't know if I'm at the right place or not, but this thread seems to be the closest to my problem, which is this (see image):

Every time I type in something into the URL (location/address) bar, the first options shown are search results by Bing.

Now the funny thing is, that it is the ONLY symptom that my system exhibits in connection with the blasted Bing. There is no extra toolbar, no default search engine change, no default homepage change, it's not taking over my new tabs; it is not anywhere among the add-ons etc. (I guess you'd say I'm lucky for that, but "just ignore it" is definitely not the answer I'm looking for.)

I have tried about 8-10 different solutions posted on different forums, but nothing helped. I did the "Manage Search Engines" thing; I looked around the Add-ons & Extensions for anything remotely suspicious; I tried the keyword.URL solution; I went to System32 folder to change the hosts file (hell, I don't even know what that is); I even reinstalled Firefox from the Mozilla homepage (!), and nothing happened.

So what now...? Can anyone help me? Thanks in advance.

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Next Generation Java Plug-in 10.17.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Facebook Desktop Plugin
  • GEPlugin
  • Google Update
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.02
  • 5.1.20125.0
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealPlayer Download Plugin
  • RealNetworks(tm) RealDownloader Chrome Background Extension Plug-In
  • RealNetworks(tm) RealDownloader PepperFlashVideoShim Plug-In
  • RealNetworks(tm) RealDownloader HTML5VideoShim Plug-In
  • RealDownloader Plugin
  • McAfee Virtual Technician plugin
  • RealNetworks(tm) RealPlayer Chrome Background Extension Plug-In
  • RealPlayer(tm) HTML5VideoShim Plug-In
  • McAfee MSC FF plugin DLL
  • NPWLPG
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Yahoo Application State Plugin version 1.0.0.7
  • Adobe Shockwave for Director Netscape plug-in, version 11.5.8.612
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • npdnupdater2
  • npdnu

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/20100101 Firefox/19.0

More Information

marlsrsoftball 0 solutions 11 answers

Worked for me also.

Worked for me also.
kobe 441 solutions 5048 answers

marlsrsoftball,

Have you tried the Search Reset Tool and deleting the possible user.js file in your profile folder.

marlsrsoftball, Have you tried the [https://addons.mozilla.org/en-US/firefox/addon/searchreset/ Search Reset Tool] and deleting the possible user.js file in your profile folder. * https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save#w_user-js-file-overriding-preferences
marlsrsoftball 0 solutions 11 answers

There is no user.js file.

There is no user.js file.