X
Tap here to go to the mobile version of the site.

Support Forum

Firefox loading pages really slow

Posted

So a lot of pages are loading really slow like minutes, like youtube and hot.ee mail service and a lot more. It started to happen when i updated to 20.0. Looked up some suggestions and found that about:config network.http.keep-alive to false help. And so i did it and it worked, but next time i opened firefox again it was slow loading again, but keep-alive is false still, disabled all not nessecary plugins and extensions and i dont seem to find a solution. Been a firefox user for a long time and dont want to change my browser.

So a lot of pages are loading really slow like minutes, like youtube and hot.ee mail service and a lot more. It started to happen when i updated to 20.0. Looked up some suggestions and found that about:config network.http.keep-alive to false help. And so i did it and it worked, but next time i opened firefox again it was slow loading again, but keep-alive is false still, disabled all not nessecary plugins and extensions and i dont seem to find a solution. Been a firefox user for a long time and dont want to change my browser.

Chosen solution

The new profile seems to work fine - not sure for how long but we will see how it goes.

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Next Generation Java Plug-in 10.17.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 11.6 r602
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.02
  • Allows digital signing with Estonian ID cards
  • 5.1.20125.0

Application

  • Firefox 21.0
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:21.0) Gecko/20100101 Firefox/21.0
  • Support URL: http://support.mozilla.org/1/firefox/21.0/WINNT/en-US/

Extensions

  • Adblock Plus 2.2.3 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Adobe Flash Player 3.7 (hoverst@facebook.com)
  • Estonian ID Card PKCS11 module loader 3.7.0.877 ({aa84ce40-4253-a00a-8cd6-0800200f9a66})
  • Logitech Flow Scroll 4.00.33 ({5D3F3872-91E9-4d59-AD9F-AA174A3145DD})
  • Lonua MakeFaster 1.10 (info@ovterion.com)
  • SearchIMDB 1.2.0 (searchimdb@sogame.cat)
  • Test Pilot 1.2.2 (testpilot@labs.mozilla.com)
  • TinEye Reverse Image Search 1.1 (tineye@ideeinc.com)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • avast! WebRep 7.0.1426 (wrc@avast.com) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: NVIDIA GeForce GT 440
  • adapterDescription2:
  • adapterDeviceID: 0x0de0
  • adapterDeviceID2:
  • adapterDrivers: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
  • adapterDrivers2:
  • adapterRAM: 2047
  • adapterRAM2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • clearTypeParameters: Gamma: 2200 Pixel Structure: RGB ClearType Level: 100 Enhanced Contrast: 100
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.1.7601.17789
  • driverDate: 3-14-2013
  • driverDate2:
  • driverVersion: 9.18.13.1422
  • driverVersion2:
  • info: {u'AzureContentBackend': u'direct2d', u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo'}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (NVIDIA GeForce GT 440 )
  • windowLayerManagerType: Direct3D 10

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.startup.homepage: www.google.com
  • browser.startup.homepage_override.buildID: 20130408165307
  • browser.startup.homepage_override.mstone: 21.0
  • browser.tabs.onTop: False
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 21.0
  • gfx.direct3d.prefer_10_1: True
  • keyword.URL: http://search.conduit.com/ResultsExt.aspx?ctid=CT3072253&SearchSource=2&q=
  • network.cookie.prefsMigrated: True
  • network.http.keep-alive: false
  • network.http.max-persistent-connections-per-server: 4
  • network.http.pipelining: True
  • network.http.pipelining.maxrequests: 8
  • network.http.pipelining.ssl: True
  • places.database.lastMaintenance: 1365601943
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • privacy.donottrackheader.enabled: True
  • privacy.sanitize.migrateFx3Prefs: True
  • security.warn_viewing_mixed: False

Misc

  • User JS: Yes
  • Accessibility: Yes
Darcey_Mckelvey 0 solutions 3 answers

Reset Firefox – easily fix most problems Over time firefox can develope problems such as slowness, crashing, unwanted toolbars and more. Trouble shooting and fixing these problems can be very time consuming and trouble-some. The reset firefox feature can fix many issues by restoring Firefox to its factory default state while saving your essential information.

What does the reset feature do? All of your Firefox settings and personal information is stored in your profile folder. The reset feature go and creates a new profile for you while saving your: •Bookmarks •Browsing history •Passwords •Cookies •Web form auto-fill information

Warning: When using the reset feature, the following items are either NOT SAVED or set to their defaults. •Extensions and themes •Open tabs, windows and tab groups •Site-specific preferences, search engines, personal dictionary, download history, DOM storage, security certificate settings, security device settings, download actions, plugin MIME types, toolbar customizations and user styles

After the reset is finished, your old Firefox profile information will be placed on your desktop in a folder named "Old Firefox Data." If the reset didn't fix your problem you can restore some of the information not saved by copying files to the new profile that was created.

How do I reset Firefox to its default state?

1.At the top of the Firefox window, click the Firefox button, go over to the Help sub-menu (on Windows XP, click the Help menu at the top of the Firefox window) and select Troubleshooting Information.

2.Click the Reset Firefox button in the upper-right corner of the Troubleshooting Information page.

3.To continue, click Reset Firefox in the confirmation window that opens.

4.Firefox will close and be reset. When it's done, a window will list the information that was imported. Click Finish and Firefox will open. That's it – you're done!

See pictures for a visual on how to reset.

Reset Firefox – easily fix most problems Over time firefox can develope problems such as slowness, crashing, unwanted toolbars and more. Trouble shooting and fixing these problems can be very time consuming and trouble-some. The reset firefox feature can fix many issues by restoring Firefox to its factory default state while saving your essential information. What does the reset feature do? All of your Firefox settings and personal information is stored in your profile folder. The reset feature go and creates a new profile for you while saving your: •Bookmarks •Browsing history •Passwords •Cookies •Web form auto-fill information Warning: When using the reset feature, the following items are either NOT SAVED or set to their defaults. •Extensions and themes •Open tabs, windows and tab groups •Site-specific preferences, search engines, personal dictionary, download history, DOM storage, security certificate settings, security device settings, download actions, plugin MIME types, toolbar customizations and user styles After the reset is finished, your old Firefox profile information will be placed on your desktop in a folder named "Old Firefox Data." If the reset didn't fix your problem you can restore some of the information not saved by copying files to the new profile that was created. How do I reset Firefox to its default state? 1.At the top of the Firefox window, click the Firefox button, go over to the Help sub-menu (on Windows XP, click the Help menu at the top of the Firefox window) and select Troubleshooting Information. 2.Click the Reset Firefox button in the upper-right corner of the Troubleshooting Information page. 3.To continue, click Reset Firefox in the confirmation window that opens. 4.Firefox will close and be reset. When it's done, a window will list the information that was imported. Click Finish and Firefox will open. That's it – you're done! See pictures for a visual on how to reset.

Question owner

thank you it helped

thank you it helped
John99
  • Top 25 Contributor
  • Moderator
685 solutions 9487 answers

kass,

Thanks for posting back. Glad we helped. I have marked Darcey's answer as the solution.

If you still have problems on the same subject post back again, unmark the solution and someone will try to offer further help if required.

kass, Thanks for posting back. Glad we helped. I have marked Darcey's answer as the solution. If you still have problems on the same subject post back again, unmark the solution and someone will try to offer further help if required.
swordie 0 solutions 1 answers

this may sound very primative, yet, my up to date firefox was slow as heck too. however before I went ahead with "resetting my firefox" and many other further extents. I got curious if perhaps my download list could literally be bogging down the overall speed. Guess what? i hit "clear list" on the download window of firefox during my super slow surf and download experience, and as soon as it got around to processing my command, the list was cleared up to my active download and download speed jumped from 240kbps to 1.6mbps. also my surf and scroll abilities instantly went back to optimal speeds. Try it, much easier than doing all that other stuff right? Let me know if it worked for you too, k? :) thanks

this may sound very primative, yet, my up to date firefox was slow as heck too. however before I went ahead with "resetting my firefox" and many other further extents. I got curious if perhaps my download list could literally be bogging down the overall speed. Guess what? i hit "clear list" on the download window of firefox during my super slow surf and download experience, and as soon as it got around to processing my command, the list was cleared up to my active download and download speed jumped from 240kbps to 1.6mbps. also my surf and scroll abilities instantly went back to optimal speeds. Try it, much easier than doing all that other stuff right? Let me know if it worked for you too, k? :) thanks
geezette 0 solutions 2 answers

Rats. Didn't work. Would installing Spybot slow things down?

Rats. Didn't work. Would installing Spybot slow things down?
alastair_gordon 0 solutions 3 answers

Helpful Reply

I tried every suggestion, and still had VERY slow page loads (minutes!) for some websites.

The strange part was that Clickster.COM would load quickly if I typed clickster.com into the address bar, but would take minutes if loading from a link or bookmark whose url was http://clickster.com.

After trying everything, here was the still slightly unsatisfactory solution (Firefox 22.0):

(1) Type about:config in Firefox address bar. (2) Promise to be good. (3) Change network.http.keep-alive.timeout from 115 to 0 (4) Change the link or bookmark url to www.clickster.com

Note that neither Chrome or IE have this bizarre behavior, and load instantly from a link, bookmark, typed-in url, with or without the www. There is still a serious Firefox bug.

I tried every suggestion, and still had VERY slow page loads (minutes!) for some websites. The strange part was that [http://www.clickster.com Clickster.COM] would load quickly if I typed '''clickster.com''' into the address bar, but would take minutes if loading from a link or bookmark whose url was '''http://clickster.com'''. After trying everything, here was the still slightly unsatisfactory solution (Firefox 22.0): (1) Type '''about:config''' in Firefox address bar. (2) Promise to be good. (3) Change '''network.http.keep-alive.timeout''' from 115 to '''0''' (4) Change the link or bookmark url to [http://www.clickster.com www.clickster.com] Note that neither Chrome or IE have this bizarre behavior, and load instantly from a link, bookmark, typed-in url, with or without the '''www'''. There is still a serious Firefox bug.

Modified by alastair_gordon

John99
  • Top 25 Contributor
  • Moderator
685 solutions 9487 answers

Hi Alastair,
If you consider you have found a serious Firefox bug start your own thread using /questions/new and follow the prompts to give full troubleshooting information. Then try to demonstrate to us how to reproduce the problem so that some one will be able to look at it to decide if something in Firefox does need fixing.

If you are finding a problem only on one specific site there is of course a possibility that it is the site itself at fault.

Hi Alastair, <br />If you consider you have found a serious Firefox bug start your own thread using [/questions/new] and follow the prompts to give full troubleshooting information. Then try to demonstrate to us how to reproduce the problem so that some one will be able to look at it to decide if something in Firefox does need fixing. If you are finding a problem only on one specific site there is of course a possibility that it is the site itself at fault.

Modified by John99

Richard9632 0 solutions 2 answers

recently changed from 3 Mpbs to 20 Mpbs and Foxfire was running very slow. (after updating) Don't know why. Tried your solution 115 to 0 and seems to have corrected problem. Thanks a million!! Richard - rvlukens@msn.com

recently changed from 3 Mpbs to 20 Mpbs and Foxfire was running very slow. (after updating) Don't know why. Tried your solution 115 to 0 and seems to have corrected problem. Thanks a million!! Richard - rvlukens@msn.com
John99
  • Top 25 Contributor
  • Moderator
685 solutions 9487 answers

Something else to consider is turning on telemetry.That sends anonymised data that developers may look at. It helps developers spot problems especially with startup times.

Something else to consider is turning on telemetry.That sends anonymised data that developers may look at. It helps developers spot problems especially with startup times. *see [[Send performance data to Mozilla to help improve Firefox]]
Tamalkrishna 0 solutions 2 answers

When you change any configuration on Firefox using about:config, it's highly recommended to restart your browser to see expected changes. If you don't restart it, it might sometimes create problems. It may have happened for you as well. Firefox is not a slow browser, but it's quite fast. You need to optimize it in the correct way. You need to clearly know what you are changing and why you are doing that. Read this article : Make Mozilla Browsing Faster Easily Make Mozilla Browsing Faster Easily. It will make your browser quite faster. If it doesn't solve your problems, i would suggest you to reinstall Firefox and use a fresh version. Hope your problem will be solved.

When you change any configuration on Firefox using about:config, it's highly recommended to restart your browser to see expected changes. If you don't restart it, it might sometimes create problems. It may have happened for you as well. Firefox is not a slow browser, but it's quite fast. You need to optimize it in the correct way. You need to clearly know what you are changing and why you are doing that. Read this article : [http://webmuss.com/make-browsing-faster-mozilla/ Make Mozilla Browsing Faster Easily] Make Mozilla Browsing Faster Easily. It will make your browser quite faster. If it doesn't solve your problems, i would suggest you to reinstall Firefox and use a fresh version. Hope your problem will be solved.
Richard9632 0 solutions 2 answers

Seems to improve the situation. Thanks for the info.

Seems to improve the situation. Thanks for the info.
cor-el
  • Top 10 Contributor
  • Moderator
12006 solutions 111552 answers

Note that enabling HTTP pipelining can cause problem with servers that do not support this feature properly, so it may be better to leave this disabled.

See the Caveats:

Note that enabling HTTP pipelining can cause problem with servers that do not support this feature properly, so it may be better to leave this disabled. See the Caveats: *http://kb.mozillazine.org/network.http.pipelining
Kelstra 1 solutions 3 answers

Helpful Reply

Resetting Firefox worked for me but lasted about 1 day before the problems returned. I have a very fast computer and fast internet connection but nobody has told Firefox. Pages that take ages to load in FF load instantly in IE. None of the fixes work except one - use another browser.

Resetting Firefox worked for me but lasted about 1 day before the problems returned. I have a very fast computer and fast internet connection but nobody has told Firefox. Pages that take ages to load in FF load instantly in IE. None of the fixes work except one - use another browser.
alastair_gordon 0 solutions 3 answers

As I mentioned above, the following seems to have been a permanent fix for me for Firefox 22.0:

(1) Type about:config in Firefox address bar. (2) Promise to be good. (3) Change network.http.keep-alive.timeout from 115 to 0

With that, Firefox behaves like all the other browsers. Good luck!

As I mentioned above, the following seems to have been a permanent fix for me for Firefox 22.0: (1) Type about:config in Firefox address bar. (2) Promise to be good. (3) Change network.http.keep-alive.timeout from 115 to 0 With that, Firefox behaves like all the other browsers. Good luck!
cor-el
  • Top 10 Contributor
  • Moderator
12006 solutions 111552 answers

Do you have any other network.http prefs that aren't the default, i.e. appear bold (user set)?

Do you have any other network.http prefs that aren't the default, i.e. appear bold (user set)?

Modified by cor-el

alastair_gordon 0 solutions 3 answers

Yes, there are dozens of settings in "about:config" that are not the default (shown in bold).

Any in particular?

Yes, there are dozens of settings in "about:config" that are not the default (shown in bold). Any in particular?
Kelstra 1 solutions 3 answers

Thanks for your input but unfortunately it made no difference at all. Internet Explorer loads everything instantly (even though I loath it) but FF doesn't want to know about it. Everything was fine until release 22. Google Chrome is a fix of course but I do prefer to solve problems rather than just running away from them.

Thanks for your input but unfortunately it made no difference at all. Internet Explorer loads everything instantly (even though I loath it) but FF doesn't want to know about it. Everything was fine until release 22. Google Chrome is a fix of course but I do prefer to solve problems rather than just running away from them.
cor-el
  • Top 10 Contributor
  • Moderator
12006 solutions 111552 answers

Create a new profile as a test to check if your current profile is causing the problems.

See "Creating a profile":

If the new profile works then you can transfer some files from an existing profile to the new profile, but be careful not to copy corrupted files.

It is possible that your security software (firewall, anti-virus) blocks or restricts Firefox or the plugin-container process without informing you, possibly after detecting changes (update) to the Firefox program.

Remove all rules for Firefox and the plugin-container from the permissions list in the firewall and let your firewall ask again for permission to get full unrestricted access to internet for Firefox and the plugin-container process and the updater process.

See:

Create a new profile as a test to check if your current profile is causing the problems. See "Creating a profile": *https://support.mozilla.org/kb/profile-manager-create-and-remove-firefox-profiles *http://kb.mozillazine.org/Standard_diagnostic_-_Firefox#Profile_issues If the new profile works then you can transfer some files from an existing profile to the new profile, but be careful not to copy corrupted files. *http://kb.mozillazine.org/Transferring_data_to_a_new_profile_-_Firefox It is possible that your security software (firewall, anti-virus) blocks or restricts Firefox or the plugin-container process without informing you, possibly after detecting changes (update) to the Firefox program. Remove all rules for Firefox and the plugin-container from the permissions list in the firewall and let your firewall ask again for permission to get full unrestricted access to internet for Firefox and the plugin-container process and the updater process. See: *https://support.mozilla.org/kb/Server+not+found *https://support.mozilla.org/kb/Firewalls *https://support.mozilla.org/kb/fix-problems-connecting-websites-after-updating
Kelstra 1 solutions 3 answers

Chosen Solution

The new profile seems to work fine - not sure for how long but we will see how it goes.

The new profile seems to work fine - not sure for how long but we will see how it goes.