Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

After installing Mozilla Firefox 20.0 with Adobe Flash Player 11.6, YouTube videos won't load properly.

  • 4 replies
  • 26 have this problem
  • 1 view
  • Last reply by phantoms

more options

YouTube videos worked fine before installing Adobe Flash Player. When installed the screen flickers after one second, rewinds to the beginning, then plays normally. This doesn't occur when I use Internet Explorer. I have reinstalled both Mozilla Firefox and Adobe Flash Player many times but nothing seems to work . Downgrading Adobe Flash Player didn't work either. It seems like Firefox is the problem but I'm not completely sure.

Chosen solution

You can check for problems with current Flash plugin versions and try these:

  • disable a possible RealPlayer Browser Record Plugin extension for Firefox and update the RealPlayer if installed
  • disable protected mode in Flash 11.3 and later
  • disable hardware acceleration in the Flash plugin
Read this answer in context 👍 7

All Replies (4)

more options

Sometimes a problem with Firefox may be a result of malware installed on your computer, that you may not be aware of.

You can try these free programs to scan for malware, which work with your existing antivirus software:

Microsoft Security Essentials is a good permanent antivirus for Windows 7/Vista/XP if you don't already have one.


Further information can be found in the Troubleshoot Firefox issues caused by malware article.

Did this fix your problems? Please report back to us!

more options

Chosen Solution

You can check for problems with current Flash plugin versions and try these:

  • disable a possible RealPlayer Browser Record Plugin extension for Firefox and update the RealPlayer if installed
  • disable protected mode in Flash 11.3 and later
  • disable hardware acceleration in the Flash plugin
more options

Hi All,

Thanks a lot "cor-el". I also suffered from the above issue. And after I disabled the protected mode by editing "mms.cfg" file the issue got resolved. Now flash player is working fine.

Please use this link for more details : http://kb.mozillazine.org/Flash#Troubleshooting

more options

Plug in a set of headphones and see if it works. I know it sounds funny, but I've been dealing with this problem for months on a work computer that has no speakers. Plugging in a set of headphones fixed the problem.