X
Tap here to go to the mobile version of the site.

Support Forum

This thread was closed and archived. Please ask a new question if you need help.

Can I disable or move the Firefox menu that appears when I right click? (The Firefox menu blocks my Yahoo, Box, and application menus.)

Posted

The context-sensitive Firefox menu that appears when I right click on a link appears exactly over the context-sensitive application menus that come up in Yahoo, Box, and other sites, so the Firefox menu blocks me from seeing or clicking on the Yahoo or Box menu options. Is there a way to prevent the Firefox menu from appearing on top when another menu is active? or a way to disable the Firefox menu when on certain web sites? Even having the Firefox menu appear in a different location (to the left, for example, instead of to the right), would enable me to see and access the website's application menu.

The context-sensitive Firefox menu that appears when I right click on a link appears exactly over the context-sensitive application menus that come up in Yahoo, Box, and other sites, so the Firefox menu blocks me from seeing or clicking on the Yahoo or Box menu options. Is there a way to prevent the Firefox menu from appearing on top when another menu is active? or a way to disable the Firefox menu when on certain web sites? Even having the Firefox menu appear in a different location (to the left, for example, instead of to the right), would enable me to see and access the website's application menu.

Chosen solution

See:

  • Tools > Options > Content : JavaScript > Advanced > Allow Scripts to: [X] "Disable or replace context menus"

Read this answer in context 4

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.6 r602
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.6
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers
  • Citrix ICA Client Plugin (Win32)

Application

  • Firefox 19.0.2
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/20100101 Firefox/19.0
  • Support URL: http://support.mozilla.org/1/firefox/19.0.2/WINNT/en-US/

Extensions

  • Adblock Plus 2.2.3 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • SmartPrintButton 1.0 (quickprint@hp.com) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: AMD Radeon HD 6290 Graphics
  • adapterDescription2:
  • adapterDeviceID: 0x9807
  • adapterDeviceID2:
  • adapterDrivers: aticfx64 aticfx64 aticfx64 aticfx32 aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
  • adapterDrivers2:
  • adapterRAM: 256
  • adapterRAM2:
  • adapterVendorID: 0x1002
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'blockedGfxCard']
  • directWriteEnabled: False
  • directWriteVersion: 6.1.7601.17789
  • driverDate: 5-24-2011
  • driverDate2:
  • driverVersion: 8.861.0.0
  • driverVersion2:
  • info: {u'AzureContentBackend': u'none', u'AzureCanvasBackend': u'cairo', u'AzureFallbackCanvasBackend': u'none'}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'blockedGfxCard']
  • numTotalWindows: 2
  • webglRenderer: Google Inc. -- ANGLE (AMD Radeon HD 6290 Graphics )
  • windowLayerManagerType: Basic

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 1048576
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size_cached_value: 1048576
  • browser.display.background_color: #C0C0C0
  • browser.display.use_system_colors: True
  • browser.places.smartBookmarksVersion: 4
  • browser.search.update: False
  • browser.startup.homepage_override.buildID: 20130307023931
  • browser.startup.homepage_override.mstone: 19.0.2
  • browser.tabs.warnOnOpen: False
  • dom.disable_open_during_load: False
  • dom.disable_window_flip: False
  • dom.event.contextmenu.enabled: False
  • extensions.lastAppVersion: 19.0.2
  • font.minimum-size.x-western: 11
  • font.name.monospace.x-western: Lucida Console
  • font.size.fixed.x-western: 16
  • gfx.blacklist.direct2d: 4
  • gfx.blacklist.layers.direct3d9: 4
  • gfx.direct3d.prefer_10_1: True
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1365229273
  • places.history.enabled: False
  • places.history.expiration.transient_current_max_pages: 46424
  • places.history.expiration.transient_optimal_database_size: 74277026
  • plugin.disable_full_page_plugin_for_types: application/pdf,application/vnd.adobe.xfdf,application/vnd.fdf,application/vnd.adobe.xdp+xml
  • privacy.clearOnShutdown.cookies: False
  • privacy.clearOnShutdown.offlineApps: True
  • privacy.clearOnShutdown.passwords: True
  • privacy.cpd.downloads: False
  • privacy.cpd.formdata: False
  • privacy.cpd.history: False
  • privacy.cpd.sessions: False
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.sanitizeOnShutdown: True
  • security.disable_button.openCertManager: False
  • security.warn_viewing_mixed: False
  • security.warn_viewing_mixed.show_once: False

Misc

  • User JS: No
  • Accessibility: No
cor-el
  • Top 10 Contributor
  • Moderator
17521 solutions 158427 answers

Chosen Solution

See:

  • Tools > Options > Content : JavaScript > Advanced > Allow Scripts to: [X] "Disable or replace context menus"

See: * Tools > Options > Content : JavaScript > Advanced > Allow Scripts to: [X] "Disable or replace context menus" ----- *http://kb.mozillazine.org/JavaScript#Advanced_JavaScript_settings *http://kb.mozillazine.org/Prevent_websites_from_disabling_new_window_features

Helpful Reply

Thank you!!! I went into Firefox "Options", then clicked on the "Content" tab. "Enable Javascript" was already checked. I clicked on the "Advanced" button to the right, and then clicked the remaining checkbox to Allow scripts to "Disable or replace context menus" (the other two options were already checked). (Then I restarted Firefox before testing it out.) That solved the problem!

Thank you!!! I went into Firefox "Options", then clicked on the "Content" tab. "Enable Javascript" was already checked. I clicked on the "Advanced" button to the right, and then clicked the remaining checkbox to Allow scripts to "Disable or replace context menus" (the other two options were already checked). (Then I restarted Firefox before testing it out.) That solved the problem!
gsravan4 0 solutions 5 answers

The Solution is here...i tired it out sucessfully

https://addons.mozilla.org/en-US/firefox/addon/menu-editor/

The Solution is here...i tired it out sucessfully https://addons.mozilla.org/en-US/firefox/addon/menu-editor/