X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

have an error saying 'Firefox can't establish a connection to the server at localhost:50972. '

Posted

I bought a product called 'Helium Music Streamer' and downloaded it. I registered the product and went to launch it..

only it wouldnt launch.

It had the error 'Firefox can't establish a connection to the server at localhost:50972.'

I would be glad for some help




 '

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.6 r602
  • Google Update
  • iTunes Detector Plug-in
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.02
  • 5.1.20125.0
  • BT Management plug-in for Mozilla Browsers
  • BT DesktopHelp plug-in for Mozilla Browsers
  • Amazon MP3 Downloader Plugin 1.0.17
  • Picasa plugin
  • NPWLPG
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20100101 Firefox/14.0.1

More Information

{
"application": {
"name": "Firefox",
"version": "14.0.1",
"userAgent": "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20100101 Firefox/14.0.1",
"supportURL": "http://support.mozilla.org/1/firefox/14.0.1/WINNT/en-US/"
},
"modifiedPreferences": {
"browser.cache.disk.capacity": 1048576,
"browser.cache.disk.smart_size.first_run": false,
"browser.cache.disk.smart_size_cached_value": 1024000,
"browser.places.smartBookmarksVersion": 4,
"browser.startup.homepage_override.mstone": "14.0.1",
"browser.startup.homepage_override.buildID": "20120713134347",
"extensions.lastAppVersion": "14.0.1",
"font.minimum-size.x-western": 16,
"font.size.variable.x-western": 20,
"font.size.fixed.x-western": 17,
"font.name.monospace.x-western": "Times New Roman",
"gfx.direct3d.prefer_10_1": true,
"network.cookie.prefsMigrated": true,
"places.history.expiration.transient_current_max_pages": 104858,
"places.database.lastMaintenance": 1364309750,
"privacy.sanitize.migrateFx3Prefs": true,
"security.warn_viewing_mixed.show_once": false
},
"graphics": "Troubleshoot data provider failed: graphics\nTypeError: ext is null",
"javaScript": {
"incrementalGCEnabled": true
},
"accessibility": {
"isActive": false
},
"libraryVersions": {
"NSPR": {
"minVersion": "4.9",
"version": "4.9"
},
"NSS": {
"minVersion": "3.13.5.0 Basic ECC",
"version": "3.13.5.0 Basic ECC"
},
"NSSUTIL": {
"minVersion": "3.13.5.0",
"version": "3.13.5.0"
},
"NSSSSL": {
"minVersion": "3.13.5.0 Basic ECC",
"version": "3.13.5.0 Basic ECC"
},
"NSSSMIME": {
"minVersion": "3.13.5.0 Basic ECC",
"version": "3.13.5.0 Basic ECC"
}
},
"userJS": {
"exists": false
},
"extensions": [
{
"name": "BetterPrivacy",
"version": "1.68",
"isActive": true,
"id": "{d40f5e7b-d2cf-4856-b441-cc613eeffbe3}"
},
{
"name": "InvisibleHand",
"version": "3.8.28",
"isActive": true,
"id": "canitbecheaper@trafficbroker.co.uk"
},
{
"name": "Motive Extension",
"version": "1.0",
"isActive": true,
"id": "mcciwbch@motive.com"
},
{
"name": "Troubleshooter",
"version": "1.1a",
"isActive": true,
"id": "troubleshooter@mozilla.org"
},
{
"name": "HP Smart Web Printing",
"version": "4.5",
"isActive": false,
"id": "smartwebprinting@hp.com"
},
{
"name": "Inbox Toolbar",
"version": "1.2.0.41",
"isActive": false,
"id": "inboxcomtoolbar@inbox.com"
},
{
"name": "Norton Toolbar",
"version": "2012.5.12.5",
"isActive": false,
"id": "{2D3F3651-74B9-4795-BDEC-6DA2F431CB62}"
},
{
"name": "Norton Vulnerability Protection",
"version": "11.3.0.9 - 4",
"isActive": false,
"id": "{BBDA0591-3099-440a-AA10-41764D9DB4DB}"
}
]
}

Tyler Downer
  • Administrator
  • Moderator
1165 solutions 6641 answers

Please update to Firefox 20 Update Firefox to the latest version, then try again.

Question owner

Unfortunately, even though I did do what you suggested and updated to Firefox 20, I still got the same error message...

The screen 'flashes' for a split second as it were and then it seems to be opening a web page but comes up with the error that I mentioned.

cor-el
  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers

Did that product make or required to make changes to the Firefox connection settings like using a local proxy?

Check the connection settings.

Question owner

I followed the link you gave (thank you) to understand where to look, but the selection I currently have on my laptop is:

'use system proxy settings'

I am unfortunately not savvy to know whether (or not) the product was required to make changes..

cor-el
  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers

I assume that the default "Use the system proxy settings" should be fine, but you can try a direct connection (no proxy) to see if that has any effect.

Try to create a new profile as a test to check if your current profile is causing the problems.

See "Creating a profile":

If the new profile works then you can transfer some files from an existing profile to the new profile, but be careful not to copy corrupted files.

bigsky 0 solutions 1 answers

Hi, in case you haven't solved your problem - here's what i've discovered based on having same issue. where IE proxy system settings automatically allows local host url access; It appears FF system proxy or auto-detect does not, it's settings blocks local host URL access. To access local host, "no proxy" settings should allow or, only way to allow this exception (or any other exceptions) is through their manual settings. You should see in manual settings that the local host is already set to be allowed through.

FF also has plug-ins available which allows you to configure multiple proxy settings/profiles that you can toggle between based on your connection needs. THis way, when you want to use local host you can select it's proxy profile and go back to default proxy settings for regular web surfing, etc

Hope this helps you.

Modified by bigsky