X
Tap here to go to the mobile version of the site.

Support Forum

Switching from external display to MBP retina display, poor quality, must restart FF19.0.2

Posted

Here's the sequence of events:

1) Start FF on my MBP (OS 10.8.2), and retina display works properly.

2) Connect my MBP to a 24" external display, which has max resolution of 1920x1200 (set as primary). FF displays nicely on external display.

3) Disconnect external display and FF is now pixelated on MBP retina. Refreshing System Dispay preferences doesn't seem to help, or I haven't found the magic technique.

4) Restart FF and all is well.

So the issue appears to be FF not recognizing the need to revert to Retina resolution.

Here's the sequence of events: 1) Start FF on my MBP (OS 10.8.2), and retina display works properly. 2) Connect my MBP to a 24" external display, which has max resolution of 1920x1200 (set as primary). FF displays nicely on external display. 3) Disconnect external display and FF is now pixelated on MBP retina. Refreshing System Dispay preferences doesn't seem to help, or I haven't found the magic technique. 4) Restart FF and all is well. So the issue appears to be FF not recognizing the need to revert to Retina resolution.

Modified by dshean

Chosen solution

You're welcome

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • A plugin to detect whether the Adobe Extension Manager is installed on this machine.
  • Shockwave Flash 11.6 r602
  • Displays Java applet content, or a placeholder if Java is not installed.
  • The Google Earth Plugin allows you to view 3D imagery and terrain in your web browser.
  • Adobe® Acrobat® Plug-in for Web Browsers, Version 11.0.02
  • Microsoft Office for Mac SharePoint Browser Plug-in
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:19.0) Gecko/20100101 Firefox/19.0

More Information

Application Basics
Name
Firefox
Version
19.0.2
User Agent
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:19.0) Gecko/20100101 Firefox/19.0
Build Configuration
about:buildconfig
Extensions
Name
Version
Enabled
ID
Adblock Plus
2.2.3
true
{d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}
Ghostery
2.9.3
true
firefox@ghostery.com
The Tracktor - Amazon Price Tracker
1.0.7
true
firetracktor@thetracktor.com
Zotero
3.0.14
true
zotero@chnm.gmu.edu
Adobe Acrobat - Create PDF
1.1
false
web2pdfextension@web2pdf.adobedotcom
Important Modified Preferences
Name
Value
accessibility.typeaheadfind.flashBar
0
browser.cache.disk.capacity
358400
browser.cache.disk.smart_size_cached_value
358400
browser.cache.disk.smart_size.first_run
false
browser.cache.disk.smart_size.use_old_max
false
browser.places.smartBookmarksVersion
4
browser.startup.homepage
http://www.nytimes.com
browser.startup.homepage_override.buildID
20130307023931
browser.startup.homepage_override.mstone
19.0.2
dom.mozApps.used
true
extensions.lastAppVersion
19.0.2
gfx.blacklist.webgl.msaa
4
network.cookie.prefsMigrated
true
places.database.lastMaintenance
1363331769
places.history.expiration.transient_current_max_pages
104858
plugin.disable_full_page_plugin_for_types
application/pdf
print.macosx.pagesetup-2
PD94bWwgdmVyc2lvbj0iMS4wIiBlbmNvZGluZz0iVVRGLTgiPz4KPCFET0NUWVBFIHBsaXN0IFBVQkxJQyAiLS8vQXBwbGUvL0RURCBQTElTVCAxLjAvL0VO
privacy.donottrackheader.enabled
true
privacy.sanitize.migrateFx3Prefs
true
Graphics
Device ID
0x fd5
GPU Accelerated Windows
1/1 OpenGL
Vendor ID
0x10de
WebGL Renderer
NVIDIA Corporation -- NVIDIA GeForce GT 650M OpenGL Engine
AzureCanvasBackend
quartz
AzureContentBackend
none
AzureFallbackCanvasBackend
none
JavaScript
Incremental GC
true
Accessibility
Activated
false
Prevent Accessibility
0
Library Versions
Expected minimum version
Version in use
NSPR
4.9.4
4.9.4
NSS
3.14.1.0 Basic ECC
3.14.1.0 Basic ECC
NSSSMIME
3.14.1.0 Basic ECC
3.14.1.0 Basic ECC
NSSSSL
3.14.1.0 Basic ECC
3.14.1.0 Basic ECC
NSSUTIL
3.14.1.0
3.14.1.0

cor-el
  • Top 10 Contributor
  • Moderator
17477 solutions 157949 answers

Helpful Reply

Try to set the Integer pref gfx.hidpi.enabled to 2 on the about:config page.

Try to set the Integer pref <b>gfx.hidpi.enabled</b> to <i>2</i> on the <b>about:config</b> page. *http://kb.mozillazine.org/about:config

Question owner

That seems to solve the problem. Thanks.

That seems to solve the problem. Thanks.
cor-el
  • Top 10 Contributor
  • Moderator
17477 solutions 157949 answers

Chosen Solution

You're welcome

You're welcome

Question owner

Hmmm. Now seeing strange behavior with search bar autocomplete list being cut off (attached example).

Hmmm. Now seeing strange behavior with search bar autocomplete list being cut off (attached example).
cor-el
  • Top 10 Contributor
  • Moderator
17477 solutions 157949 answers

Try to disable hardware acceleration in Firefox.

Try to disable hardware acceleration in Firefox. *Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available" *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes *https://hacks.mozilla.org/2010/09/hardware-acceleration/